My OS: Windows 10 Home
I believe that it all started with the installment of a possibly dodgy security suite "Akick". I had just done a fresh windows install a few days before it running only the built in Microsoft Security before it.
I felt something was not right about it and it stayed on my PC (Acer E1-532P) for 3 days or so. On reboot it always told me that my computer was protected. This message coming quite late after Windows started made me suspicious and on the final time it didn't load at all forcing me to be smart and uninstall it.
Anyhow. my problem was that I suddenly noticed that no USB flash drive was being read. I can hear the Windows sound of something being installed but no drive letter appeared. I tried different slots both internal and external and nothing. I also tried other USB flash drives and still nothing. A net search suggested this and that (power options changes, uninstalling USB driver in Device Manager, disabling quick start, etc. ) and still nothing. I then did a Windows Restore but it would not do so. I tried earlier restore points and still nothing--Windows restore could not complete. And I got the same error message in trying to put it back to its previous point , to undo restore, and oddly enough the same message of no success popped up.
Oh yeah another odd thing: Although the task bar Windows Security Defender said all is OK actually clicking on it showed that it wasn't turned on and nor can I turn it on saying "this app is turned off by group policy". I managed to fix that problem and tried everything again- restore, USB repair solution etc.
Besides these 3 problems everything was great BTW all was running smoothly. Oh and my external mouse and keyboard are wireless so the USB connector making them run works fine. The only problem seems to be the addition of USB flash drives (even external hard drives could be connected via USB and no problem). drives therefore work Windows booted in quickly. It seems then, having exhausted my fixes I tried ReimagePlus. I was surprised to see how many things were found wrong (so many that I hesitated using it--it was after all soon after a fresh reinstall of the OS so how could you claim so many problems? After running the software I have to say that my problem has not been solved.
(BTW though there is a beep and a USB slot does appear in Device Manager it does have a yellow icon on it BUT no USB is seen in Disk Management)

The ways I tried to solve the USB problems is as follows:
Solution 1 - Turn off Fast Startup
Solution 2 - Update your drivers / install the default driver
Solution 3 - Uninstall all USB drivers including hidden ones
Solution 4 - Change USB Selective Suspend Settings
Solution 5 - Reconnect your USB devices
(Disconnected all drives and reconnected them 1 at a time after reboot.
Solution 6 Ran Windows Defender and Malware-bytes malware and found nothing

I did not try (as suggested on a website):
a) "USBOblivion tool"
b) to Disable USB3 support from BIOS
c) Update chipset drivers (had been done right after the fresh OS reinstall)

Thank you