Front USB 3.0 Random detection behaviour


  1. Posts : 14
    Windows 10 64 bit
       #1

    Front USB 3.0 Random detection behaviour


    Hi,

    I am facing issues with my front two USB 3.0 ports of my Asus z170I mitx pro gaming board. Primarily, the issue is that;
    Sometimes the USB devices get connected, sometimes not.
    Sometimes after few tries they work, while sometimes never.
    They work fine on usb 3.1 and 2.0 ports at the back.
    These devices are working fine on other PCs i checked.
    Drivers are upto date and did all kinds of power and root hub troubleshooting steps but no progress.

    I was trying to uninstall the usb drivers..somehow ended up crashing ny windows for good. What I found out through command prompt of windows recovery is that even without windows the same behaviour persist and often USBs in the front two 3.0 ports dsnt get detected randomly while after few attempts it does. So what can be the issue?

    NOTE: I have 1 broken 3.0 header SSTX pin on my board which was broken during building my PC..can this be the cause of all this fuss???
      My Computer

  2. fireberd's Avatar
    Posts : 2,335
    Win 10 Pro, 20H2
       #2

    The broken pin could be the problem, or at least part of the problem. You will never know until you get the motherboard replaced since there is only one USB 3.0 header on this board. Another area to consider is the cable and front panel ports in the case. On one PC I built, the front USB ports on a new case were defective.

    I just built a new PC with an ASUS ROG Maximus VIII motherboard and on my front USB 3.0 ports, I have one flash drive that will not work in one of the two USB 3.0 ports, but works fine in the other. Both USB 3.0 ports work OK with other devices.
      My Computers


  3. Posts : 14
    Windows 10 64 bit
    Thread Starter
       #3

    I see. So can this be replaced easily as my board is still under 1st year of warranty?
      My Computer

  4. fireberd's Avatar
    Posts : 2,335
    Win 10 Pro, 20H2
       #4

    Contact ASUS and explain what the problem is. They may replace it or they may consider that not a warranty problem. Good Luck.
      My Computers


  5. Posts : 14
    Windows 10 64 bit
    Thread Starter
       #5

    Hi,

    I got a New Motherboard fortunately by ASUS mentioning them the issue. I am getting the same issue again now. Front 3.0 headers have the same random nature of detecting devices. My note 3 mobile isnt getting recognized at all while it gets recognized over oldest PCs and devices .. same for my 500 GB hard drive .. it is not at all getting detected. and USBs do get detected but often they do not.
    I have all drivers updated along with a new windows Install. Facing the same all over again.

    I believe that now this is my Fractal Design node 202 casing 3.0 header that is the issue here.

    Kindly advise
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:21.
Find Us




Windows 10 Forums