Windows 10: CMD crashes when running "bcdedit -set TESTSIGNING ON"

  1.    12 Feb 2017 #1

    CMD crashes when running "bcdedit -set TESTSIGNING ON"


    To get the driver for an old audio interface to install, I have to run a script which includes the line "bcdedit -set TESTSIGNING ON" so that Windows will accept a modified inf file. This has worked fine on two other machines running Windows 10, but on my new laptop this command makes the CMD window crash without turning test signing on. Is there a way to fix this?
      My ComputerSystem Spec


  2. Posts : 396
    Windows 10 Pro 64 bit
       12 Feb 2017 #2

    Try this. bcdedit /set testsigning on
      My ComputersSystem Spec

  3.    12 Feb 2017 #3

    I tried it, but it still crashes. I'd be surprised if the syntax was the problem now because the same command worked in the past.
      My ComputerSystem Spec

  4.    12 Feb 2017 #4

    Try sfc command (run option 3) SFC Command - Run in Windows 10

    If sfc can't repair everything DISM - Repair Windows 10 Image
      My ComputerSystem Spec

  5.    12 Feb 2017 #5

    ComputerGeek said: View Post
    Try sfc command (run option 3) SFC Command - Run in Windows 10

    If sfc can't repair everything DISM - Repair Windows 10 Image
    Thanks for the suggestions. Unfortunately neither scannow nor dism can see any problems.
      My ComputerSystem Spec

  6.    14 Feb 2017 #6

    I tried running the command in the other direction, to turn test signing off, and it didn't crash, but it also told me that I wasn't allowed to do it. I can't remember the exact message now, but it was something to do with locking down the boot process. This machine is new hardware with the OS installed by the manufacturer. I had previously installed the driver on older hardware with the OS installed from a disk. I suspect the difference lies somewhere there and I have more or less accepted that what I wanted to do is not possible.
      My ComputerSystem Spec

  7.    14 Feb 2017 #7

    You could try turning off secure boot in BIOS. That blocks testsigning.
      My ComputerSystem Spec


  • Posts : 396
    Windows 10 Pro 64 bit
       14 Feb 2017 #8

    Did you turn off secure boot in BIOS?
      My ComputersSystem Spec


  •  

    Related Threads
    Typical error: Descrizione Percorso dell'applicazione che ha generato l'errore: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\microsoftedgecp.exe Firma del problema Nome evento problema: MoCFGSUP Nome completo...
    Hi, I ran into a weird problem with my Windows 10 Pro installation. Earlier this week, I used the Windows 7 Backup and Restore program to do some backups (including a system image) in preparation for a new desktop I'll be bringing home tomorrow....
    Solved Weird process running - "Monitor Virutal Wlan Service" in AntiVirus, Firewalls and System Security
    I was checking my system configuration and happened across this weird one! 45650 Note the spelling: "Monitor Virutal Wlan Service" - "Virutal" rather than "Virtual" but either way, I can see no reference to such a process on the net. Searching...
    Loading Dump File Kernel Bitmap Dump File: Kernel address space is available, User address space may not be available. ************* Symbol Path validation summary ************** Response Time (ms) Location...
    This problem didn't happen to me before upgrading from Windows 8. If I'm deleting, copying or moving a folder called "include", explorer.exe closes itself and reopens after a few seconds. If I'm only opening the folder, the green progress bar moves...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 04:02.
    Find Us