Windows 10: How to manage 2 Marvell RAID PCIe cards during boot?

  1.    3 Weeks Ago #1

    How to manage 2 Marvell RAID PCIe cards during boot?


    I installed Marvell RAID PCIe SATA card and could manage to enter Marvell configuration utility using Ctrl + M.

    I installed 2nd card and I can see it in Windows using Marvell software and I created RAID successfully..

    But I want to rid of this software (it installs loads of things I don't need (Apache, PHP, a website etc)

    I tried Ctrl + M again and it only shows Card 0.

    How do I manage second card in Marvell Configuration Utility during boot?
      My System SpecsSystem Spec

  2. Caledon Ken's Avatar
    Posts : 1,011
    Windows 10 Pro Build 1607
       3 Weeks Ago #2

    Sorry and it is likely just me.

    When you say you installed a Marvell Raid PCIe Sata card is this just the Marvell RAID card and then you attach your storage to this or is there SSD storage built into card.

    When I search this term I get two cards but each has ports for drives to be connected too.

    I then read your comment that you installed a second card which has me thinking this is actual storage.

    If you could help me understand are these actual storage devices or cards to add ports and functionality.
      My System SpecsSystem Spec

  3.    3 Weeks Ago #3

    I have 2 pcie sata cards with 2 x 2 hdd connected (2 each). The cards are sata controllers. Not a storage..
      My System SpecsSystem Spec

  4. Caledon Ken's Avatar
    Posts : 1,011
    Windows 10 Pro Build 1607
       3 Weeks Ago #4

    Thanks. Are you sure that the BIOS detects even one, not to challenge you. The CRTL M, as I understand it, for your board is for the Marvell built in controller.

    When you see the BIOS messages as you boot can you confirm they are the drives on your cards?
      My System SpecsSystem Spec

  5.    3 Weeks Ago #5

    Ctrl M is for any marvell. When I ctrl m I can see one card only.

    But inside windows I can see both cards using marvell software. And I can use both raids. They are perfectly functional.

    What i want is to rid of windows marvell soft and use ctrl m marvel configuration utility during boot only.

    That's the point of this post

    Thanks
      My System SpecsSystem Spec

  6. Caledon Ken's Avatar
    Posts : 1,011
    Windows 10 Pro Build 1607
       2 Weeks Ago #6

    I wonder if this is a BIOS detection issue. CRTL M should be showing you all three controllers as I'm very sure there is one on your board. Not sure if you've customized your BIOS much, if so this idea maybe a non starter.

    My thought would be to remove the CMOS battery, wait 20 secs, install and enter BIOS, load defaults, then customize. On mine I have it set to show what it detects as part of the boot, screen flashes, shows drives, then Intel controller.

    It may even need the built in one enabled so it can see all. (This is a guess.)

    Changing BIOS settings on working system is obviously your call.

    I went looking for technical docs on their bios process but that was a bust.
      My System SpecsSystem Spec

  7.    2 Weeks Ago #7

    No mate, nothing like that. First of all the mb has no Marvell on it. The primary on-board controller is Intel and the secondary is Asmedia (as in ass-media, because it cant handle neither CD ROM nor RAIDs - totally useless).

    Second - if I disable the Marvell cards in BIOS anyhow, they wont work. Yet they do work marvelously both of them

    I just cannot see them both in the utility.
      My System SpecsSystem Spec

  8. Caledon Ken's Avatar
    Posts : 1,011
    Windows 10 Pro Build 1607
       2 Weeks Ago #8

    Wow. I mixed you up with someone else. I thought we had the same motherboard strain, Asus P8P67, mine being deluxe rev 3.1. It has the marvell on board. My board also won't boot from CD unless I connect via USB.

    Sounds like there is a limitation is software. Are these right from Marvell or are they from a computer vendor, like say Vantec or MSI. The reason I ask as they might be the next logical place to ask, especially about unpublished limitations.

    I went to Marvell.com and could click on Support but then they start up with having an Non Disclosure Agreement with them. I did find some technical documentation on a chip but it was 2009 vintage.
      My System SpecsSystem Spec

  9.    2 Weeks Ago #9

    Could be the bios can only cope with one add-on controller as using the same resources? I'm guessing here that only the one cards drives are showing during the Post? and ctrl M is only ever going to access the one card.
    May have done better with a 4 port Card.
      My System SpecsSystem Spec


 

Related Threads
Hi, I have issues when booting my EFI Windows 10 Pro x64 - AU 1607 - 14393.321 SSD on a Mac Pro 5.1 w Apricorn Velocity DUO x2 Last boot time was 1:58 min while: - Fast Startup checked - Downloaded 'latest' 2006 (?) AHCI drivers for the...
Can anyone tell me how to setup the bios in the ga-h97-gaming 3 to Recognise Two 950pro attached to two ADDONICS adm2px4. I have tried just about all conceivable settings and it still wont recognise the 950pro as usable raid drives. Would I be...
Using a PCIe x1 card in a PCIe x16 slot in PC Custom Builds and Overclocking
Here is something I recently found out. I have tired this and it works. You can use a PCIe x1 card, or a PCIe x4 card in a PCIe x16 slot. They work fine. So if you think you are short of PCI-e slots, you may not be. A shorter PCIe card works fine...
I have an asus motherboard based off intel on windows 7. It prompts to say windows 10 update is available. I checked with Intel and ASUS and it seems there is no support for Intel RST Software raid in windows 10 on my motherboard. I need to find a...
Here is something I recently found out. I have tired this and it works. You can use a PCIe x1 card, or a PCIe x4 card in a PCIe x16 slot. They work fine. So if you think you are short of PCI-e slots, you may not be. A shorter PCIe card works...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:44.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums