Windows 10: Can't safely remove Seagate Expansion drive connected using USB3.0SS

  1.    17 Jan 2017 #1

    Can't safely remove Seagate Expansion drive connected using USB3.0SS


    I've got a Seagate Expansion drive connected to my PC using a USB A - USB 3.0 micro B cable.
    I'm unable to find any "Safely remove" option, and at one point when unsafely removing I got a blue screen.
    I've tried:

    • The tray. Nothing there.
    • Running "rundll32 shell32.dll,Control_RunDLL hotplug.dll", and the drive does not show up there.
    • Looking in device manager. There it shows under "Disk drives" as "Seagate Expansion SCSI Disk Device" and I see that under "Storage controllers" I've got a "USB Attached SCSI (UAS) Mass Storage Device".
    • If I on the device go right click, "Properties", "Hardware", select it, "Properties", "Policies" it has no "Removal policy" options. Only "Write-caching policy" options.

    How do I make Windows understand/handle this drive as an external drive that can be safely removed?
      My ComputerSystem Spec

  2.    17 Jan 2017 #2

    Are your USB Chipset drivers up to date?
      My ComputerSystem Spec

  3.    17 Jan 2017 #3

    There's a Seagate KB on the topic. Does it help?

    Windows will not allow me to safely remove my drive. It keeps reporting the drive is busy or in use

    /* EDIT */
    What is your actual Seagate model? Some drives are configured as non-removable by the vendor
      My ComputerSystem Spec

  4.    17 Jan 2017 #4

    Better yet here's how to check for yourself if your device tells Windows if it's removable. Download USBTreeView. Select your drive and check capabilities and status in the Device Descriptor.
    Attached Thumbnails Attached Thumbnails 2017-01-17_174722.jpg  
      My ComputerSystem Spec

  5.    22 Jan 2017 #5

    So I've been testing this for a while now, and I got it working on several other computers.
    Somehow it seems to have something to do with a specific set of USB 3.0 ports on the back of my computer. The one I was using didn't give me a "Safely remove" option, but when testing some of the others the option appeared.
      My ComputerSystem Spec


 

Related Threads
I got my new Seagate 2 TB Expansion Drive and made the first image of my new laptop (running Win 10 anniversary build) using Macrium Reflect. All went well, and I closed Macrium, then attempted to eject the external drive from the notification area....
Win 10 Pro 64bit. I have an external hard disk (WD MyBook) connected via USB3. After using it I use the "Safely Remove ..." thingo to remove/unmount it. Sometimes I want to mount it again but the only way I have found to do that is to power the...
Please answer! I just need to be able to remove it so I can use it like a backup. :drool: --EDITED AFTER SOLVED-- Figured it out! Go to Control Panel/Hardware and Sound then right click on the external, and press Remove Device. Then unplug...
I have a perplexing problem. I have a Seagate 2TB external drive that when I plug it into my USB3 port it appears in Explorer and sometimes I can even navigate through some of its folders. However after 2-5 minutes it just disappears and a message...
I recently upgraded to Windows 10 and post that It was working fine without any issues. I have two external drive connected to it. 1. 1 TB Iomega powered drive. - now RAW 2. 2TB seagate external drive. The 1tb drive suddenly became RAW and I...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:27.
Find Us