Windows 10: Tablet driver wont work. Some error missing DLL messages.

  1.    12 Jan 2017 #1

    XP-PEN Tablet driver problems . Some error , unsure.


    So this post is long, sorry for anyone taking the time to read it .

    i have this graphics tablet called STAR 5 . From a Chines company called XP-Pen. Great looking device, but it needs these drivers from their site to work Related Download- xp-pen ( CD Driver Downloads ) .

    So this company is known for having non functioning drivers, they work when they want to. No one actually knows how these drivers really work, not even support. So this is a common problem among the digital art community which I dabble in.

    So I had a driver installed from a different tablet model from a different company ( Huion ).
    Common practice ; to avoid conflicts with the new drivers; by removing the previous one which I did.

    Yet The tablet did not work. Currently It has pen cursor tracking ,but no pressure -
    (the pen mimics applied pressure on screen, like a traditional tool , pens, markers etc.
    So pressure was not working .


    After reinstalling drivers over an over, and moving the usb port on a whim , it for no given reason started to work. But only for a hour. I did something to knock it out of wack , now its back to non functioning . Then I kept changing usb ports to no avail.

    I probably made the problems worse, when i used Revo Uninstaller to remove it, going into some registry items and deleting files that appeared in a files list ; which possibly included some DLLs that got caught in the list. Probably due to the wonky nature of the xp-pen driver installer. Or whatever the case.


    I'm just trying to get this thing running normal. I installed even in different locations. It will ask to install in Programs (x86) . But I installed it in a few locations out of desperation to get it to work, like Programs folder, and just on the main C drive.

    I know it can and might work, because it did before for a moment. So i also pressed some things and noticed i get DLL missing errors. So i just need help getting this thing working right. its driving me nuts. its money lost every moment i cant get this to work.

    I've recently noticed a wintab32 driver in the tablets' own folder, and took it and replaced the wintab32 in system 32 with it. Normally a driver program will install and work. But placing it there activated something.

    But not sure its supposed to be there.

    The dll errors are hard to pin point, they come and go, as i install and reinstall .so im just confused here.

    The tablet pressure has to work, tracking has to work, and the express button keys has to work. thats what im trying to get . so far, pressure works when it wants to. keys have worked, but no longer work anymore. been that way the whole day.

    The tablet drivers from the different company i briefly mentioned, are known for their working drivers. So not sure why those work, but this company cant get their driver in order.
    Last edited by OtherWay1982; 12 Jan 2017 at 05:54.
      My ComputerSystem Spec


  2. Posts : 2,640
    64bit Win 10 Pro ver 1703 Build 15063.540
       12 Jan 2017 #2

    Probably the best approach is to back up all data you want to keep and reset the tablet back to factory mode. Then you can try again with a clean system to get the driver installed, although I will say you are quite lucky if you can get another manufacturers driver to work in place of the original one.
      My ComputersSystem Spec

  3.    12 Jan 2017 #3

    Time will tell. I wont give up yet.
      My ComputerSystem Spec

  4.    12 Jan 2017 #4

    What is ATL100.DLL ? My computer says im missing it.
      My ComputerSystem Spec


  5. Posts : 2,640
    64bit Win 10 Pro ver 1703 Build 15063.540
       12 Jan 2017 #5

    Its a Windows file which would normally be in the C:\windows\system32 folder. Running a SFC /scannow command should restore it if it has become corrupt or modified.
      My ComputersSystem Spec

  6.    12 Jan 2017 #6

    I think ultimately, i need some way to direct the tablet exe program to find or use the wintab32 in systems 32, or wow64 folders.

    Is there ways to do that ?
      My ComputerSystem Spec


  7. Posts : 2,640
    64bit Win 10 Pro ver 1703 Build 15063.540
       13 Jan 2017 #7

    I'm afraid I can't help with that one. Have you tried using the Star04 drivers instead of the Star05 ones just in case they work better?
      My ComputersSystem Spec

  8.    13 Jan 2017 #8

    Ive been playing the role of Victor Frankenstein with the drivers for the past few hours.

    The Star 4 driver is only good for its Interface, and it activates the express keys on the tablet, so that they function - the problem is while the keys work, pressure sensitivity and accuracy does not work for on the star 5 tablet using the star 4 driver.

    Now with the Star 5 driver, it gives me the best pressure, but it turns off the express keys. So they become useless. its been one or the other.


    I been mixing and matching every which way i can guess at ; files from the star 4 driver ; so that is the main UI ( menu interface ) so i can use the key buttons with.

    And trying to get the driver wintabs and whatever else makes the pressure work form the star 5 driver ; without losing the UI menu with working express keys.

    The star 4 driver basically has its files open so i can see them. I'm no hacker, so i have no idea what does what exactly. And still im sure stuff is out of my reach .

    Other problem with the star 5 driver is it is only a EXE .there are no files i can see. Once it installs , it wipes out the star 4 UI .its frustrating . No idea what to do. this is something i want to work. But im limited in know how .
    Last edited by OtherWay1982; 13 Jan 2017 at 11:18.
      My ComputerSystem Spec

  9.    13 Jan 2017 #9

    Have you tried opening the .exe file for the Star 5 drivers with 7zip? If the programmer just included the .inf, .cat, and .dll files 7zip will often extract them for you. Some vendors do it that way, others do not. Intel comes to mind in the NOT category for their 10.x.x.x and newer driver versions, In their older 9.x.x.x (and lower first numbers) .exe files you could easily extract that stuff. Not so for the newer ones. Try it on your file, and see what happens. You might get lucky!
    Good luck and HTH,
    --Ed--
      My ComputersSystem Spec

  10.    13 Jan 2017 #10

    I give up . I'll just continue to use my Huion tablet. Their drivers actually work. I wont be using this new xp pen tablet at all. I'll use it as a dinner tray or something . Thanks for all the advice.
      My ComputerSystem Spec


 

Related Threads
I have a Tablet drawing monitor, and today the pen stopped working, I fiddled with it for a while, I tried uninstalling the drivers for the Hardware and reinstalling, but then I noticed that the Tablet Settings and Calibration Options you normally...
BSODs with two different error messages. in BSOD Crashes and Debugging
Hallo everybody, first post on the forums. I had updated from win 7 to 10 several months ago and today I got my first BSODs. It happened two times in a row within an hour while I was playing on Pokerstars and running my usual set of programs. First...
Keyboard in RDP sometimes wont work in Network and Sharing
Hello, I am facing this strange issue, i keep some rdp windows open for work all day and at some point the keyboard just stops working on the remote desktops, only the mouse works, to get it working again i have to close the rdp session and...
I upgraded my Toshiba laptop automatically from 8.1 to 10 when the software came out (months ago) - have had no issues with it. Then I was using my laptop it flashed blue and turned off. It now comes up with with recovery - your pc/device needs to...
Netflix wont work? in Software and Apps
I have updated my laptop to windows 10 and since then the app wont work, I have also tried loading it on the internet and chrome but it still doesn't work. Every time I go on it works but when I press what I want to watch it loads and then comes up...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:57.
Find Us