1. Joined : Nov 2016
    Posts : 5
    Windows 10
       5 Days Ago #1

    Drive missing in "This PC" but still works fine in command prompt

    This problem is usually fixed by slow solutions such as restarting my PC. But I run into this every day, so I need a better solution. I have a Buffalo NAS (network hard drive). I have to keep that at Auto-on mode because it's noisy. So everytime I want to turn the drive on, I need to wake it up with a network wake-on-lan command. That works fine.

    The problem is, sometimes, due to sleep/resume etc. the drive just disappears from "This PC" (or My computer). If this happens, my drive x: still works perfectly in a command prompt. I connect to the drive with net use x: \\LS-WSXL64F\share /persistent:yes and that works usually. But sometimes only command prompt sees the drive and Explorer says "Windows can't find X:". At the same time "This PC" does show "LS-WSXL64F: LinkStation" which is a server version of the drive. It has some funny folders in it and is useless, I need the real x: drive which has my own folder structure. So Explorer does have connection to the drive, but X: is dead and I can't revive it even with "net use x: /delete" and then the previous net use x: \\LS.. For command prompt the net use commands work perfectly but not for Explorer. Explorer has "Map network drive". As a slow solution, I can remap successfully, but I just want to force and refresh the same mapping always, regardless of if the drive is physically off sometimes (which adds to the problem).

    How do I force Explorer to recognize the same drive as command prompt recognizes?

    Why is "net use" disconnected from "Map network drive"?

    Is there a possibility for a shortcut for the "Map network drive" with all parameters included?
      My System SpecsSystem Spec

  2. Joined : Aug 2016
    S/E England
    Posts : 1,112
    10 Home x64 (1607), Pro x86 (1511 & 1607)
       5 Days Ago #2

    jimhoyle said: View Post
    How do I force Explorer to recognize the same drive as command prompt recognizes?
    This does seem a common problem with drive mapped to a network share, particularly for business networks where the server may drop the connection if idle for too long. The connection is re-established if you access it from the command prompt, but in Win10 File Explorer doesn't seem to be able to recognise that the drive has returned. In Win7 apparently it did.

    I don't have a permanently mapped drive letter to my network drive, preferring to access it without the need for a drive letter in File Explorer through Network > Device_name > Share_name. In fact, for ease of access I have that pinned to my Quick Access in File Explorer.

    If, while your File Explorer can still see your X: drive, you pinned it to your Quick Access, then a click on the pinned X: drive may well 'remind' File Explorer that, yes, it does have X: mapped after all.
      My System SpecsSystem Spec

  3. Joined : Jun 2016
    Los Angeles
    Posts : 533
    Windows 10 Pro
       5 Days Ago #3

    You should be able to see this drive by going to Start/Search or by pressing the Windows Key+R and typing \\ComputerName
      My System SpecsSystem Spec

  4. Joined : Nov 2016
    Posts : 5
    Windows 10
       21 Hours Ago #4

    Bree said: View Post
    If, while your File Explorer can still see your X: drive, you pinned it to your Quick Access, then a click on the pinned X: drive may well 'remind' File Explorer that, yes, it does have X: mapped after all.
    Thanks alot! This helped me to get this far:

    It seems that indeed in Windows 10 "Map network drive" (explorer and network drive recognition) and command prompt (net use) are not in complete sync with eachother. I can partially refresh the drive in explorer by going to \\LS-WSXL64F\share then explorer recognizes X:. For "This PC", I have to press F5 to refresh and see a functional X: there. However, F5 does not refresh the left side (Quick access). It still looks like it's disconnected. But by clicking, it works and changes to connected icon.

    For the command prompt side, first I have to make sure drive is connected by navigating explorer to \\LS-WSXL64F\share . That is probably the same as Run or I can also do the same with AutoHotkey's "DriveGet, oVar, Status, \\LS-WSXL64F\share" and "If oVar <> Ready" will then tell whether it connected. Then I can do "net use x: /delete" and "net use x: \\LS-WSXL64F\share /persistent:yes" and finally I have to do something like "%comspec% /c x:" to refresh x: so that it's also ready without a delay later on.

    So, it almost works for me now, however I can't fully get the explorer icons automatically refreshed. They may have the red crosses at the left side even the drive is already connected and F5 is pressed to refresh.
      My System SpecsSystem Spec


Similar Threads
Thread Forum
"Boot Device Not Found" - but hitting "Enter" afterward PC boots fine
I had to buy a new (SSD) HD and had trouble booting from a disc until I enabled Legacy Mode and disabled Secure Boot in BIOS. Now whenever I boot up I get a "No Boot Device Found" message until I hit "Enter" at which point i'm allowed entry into my...
General Support
[How-To] Context menu "Open elevated Command Prompt Here" without UAC
1. Create a newTask named OpenCmdHereAsAdminNoUAC and activate "Run with the highest privileges" 2. Go to the Actions Tab, create a new Action "Start a Program" choose "C:\Windows\System32\cmd.exe" and set the Working Directory (Start in) to...
Chrome keeps becoming "unresponsive", but IE works perfectly fine
About an hour ago, websites are starting to load slower (not my internet) than they normally do, and the ones that do load eventually become unresponsive. It's so bad that I can't even load chrome://history or chrome://plugins without them becoming...
Browsers and Email
Right Click Command Menu Missing "Print" option for PDF's
I've seen several threads on this, but none of them solved my problem, which only started with my upgrade to Windows-10. I run a small eBay business, and used to print all my shipping labels for the day in 1 fell swoop by selecting them then...
General Support
D Drive is missing in my " My computer menu"
Dear All, Here is the Problem that i could't find my D Drive in my Computer menu. The problem evoked from Disk management settings, I wanted to extend Drive unfortunately i Made click on "Make Portion as active". After clicking when i restart...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:32.
Find Us
Twitter Facebook Google+

Windows 10 Forums