Windows 10: Conflict between Intel SSD Toolbox and RAID Controller card... Solved


  1. Posts : 39
    Windows 10 Pro x64 / Arch Linux
       09 Jan 2017 #1

    Conflict between Intel SSD Toolbox and RAID Controller card...


    A new issue has arisen for me, apparently between 1) the Intel SSD Toolbox, which I use to "optimize" an Intel 530 SSD, which I have as my boot drive, and 2) an Adaptec 8405 PCIe RAID controller card, which has some other SATA drives attached. This problem did not exist previously; I have been using them together for about a year without incident.

    I only use the SSD Toolbox about once per month; as I believe the optimization process it performs is essentially "garbage" collection and disposal. And I already have Windows 10 set to execute TRIM on the SSD while idle. It just seems like good practice to do a thorough optimization once in a while. The Toolbox also shows some metrics on the life-expectancy of the SSD and its health. And there are some diagnostic tools in the Toolbox, which I've never needed to use.

    Anyway, the latest development is that as soon as I launch the Toolbox, I notice that the Toolbox is slower to show the updated life-expectancy and health graphs for the SSD [it used to take just a second; now it takes ~5 seconds]. Then I notice that my computer starts acting very sluggish: the mouse pointer will start freezing for 3-4 seconds, while I'm moving the mouse! And any thing I click on will take a long time to execute... It is bad enough that the machine is more or less unusable once this happens. So then I will try to reboot, but it just hangs on the blue Rebooting screen [I've waited over 10 minutes], until I have to force reset.

    After that first happened, I check the Windows system Event log, but to my surprise, there did not seem to be any warnings or errors associated with the massive performance degradation. Then I further investigated, and launching the Toolbox definitely triggered the problem, and soon after, I lost the ability to access my D:\ drive, which is the one through my RAID controller. The RAID controller card has some activity indicator LEDs on it, and looking at those, I could see that they slowed down and soon ground to a complete halt after I launch the Toolbox!

    Since I only use the Toolbox about once per month, I'm not sure what could have changed to cause this new conflict. The only thing I can think of is that I updated the firmware for the RAID controller card. I haven't updated the drivers for it because I already have the latest; there haven't been any driver updates for it over the 6+ months... It just seems strange that the controller firmware would make such a difference.

    I could try "rolling back" the firmware to the prior version. But it's a bit of a process, and I'm not very confident that's causing my issue. It's the only explanation I could think of. Whatever other miscellaneous Windows updates and other software updates occurred this past month shouldn't have anything to do with the RAID controller.

    Is there anything else I can do to try to fix this? I'm not too optimistic that either Intel or Adaptec will offer a solution anytime soon, if either even acknowledge there is an issue. I don't think this is a Windows problem per se, but where else to post it?

    Thanks for any thoughts / info!
      My ComputerSystem Spec


  2. Posts : 39
    Windows 10 Pro x64 / Arch Linux
       10 Jan 2017 #2

    I reallize it is a relatively obscure issue I'm having. And it's not too big a deal just to stop using the Intel SSD Toolbox [to avoid the problem] ... But I'd still be interested in any thoughts or other suggestions

    Thanks!
      My ComputerSystem Spec


  3. Posts : 39
    Windows 10 Pro x64 / Arch Linux
       11 Jan 2017 #3

    After intentionally triggering the problem once again by launching the Intel SSD Toolbox, I do see a relevant Warning in the Windows System Log of Event Viewer.

    Event ID 129, Source: arcsas

    Code:
    Reset to device, \Device\RaidPort3, was issued.
    That is followed by Event ID 40 and 41, also with Source: arcsas, which are informational level events.

    Code:
    The description for Event ID 40 from source arcsas cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    
    If the event originated on another computer, the display information had to be saved with the event.
    
    The following information was included with the event: 
    
    \Device\RaidPort3
    Got LUN RESET for path #00, target #0000
    
    the message resource is present but the message is not found in the string/message table
    Code:
    The description for Event ID 41 from source arcsas cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    
    If the event originated on another computer, the display information had to be saved with the event.
    
    The following information was included with the event: 
    
    \Device\RaidPort3
    Got Target RESET for path #00, target #0000
    
    the message resource is present but the message is not found in the string/message table

    Any idea how to resolve these? It seems that launching the toolbox triggers the RAID controller to reset, but this apparently fails, and the associated D:\ drive becomes inaccessible. That explains the sluggish behavior of the computer, and the "hang" on trying to shutdown or restart.

    Based on my research online, this type of issue can be based on a lot of things. It could be that the PCIe link power state is set to "turn off" to save power [not the case for me]; it can be a faulty SATA cable connection [also not the case for me] - it definitely is triggered by launching the Intel SSD Toolbox.

    It could be that the firmware upgrade to the latest version actually introduced this issue. But I'm still reluctant to downgrade the firmware back to the prior version...

    Any thoughts / other suggestions?

    Thanks!
    Last edited by oxonsi; 11 Jan 2017 at 21:02.
      My ComputerSystem Spec

  4.    20 Jan 2017 #4

    I stumbled across your post, and I think I have been experiencing similar if not the same issue for a while. I have an intel 520 ssd in a similar setup. I haven't looked too much into it but I can honestly say of my suspicions, the toolbox was not one of them. I will start monitoring and testing this issue and certainly let you know if I come across anything.

    Obscure, probably. Annoying as hell, absolutely.
      My ComputerSystem Spec


  5. Posts : 39
    Windows 10 Pro x64 / Arch Linux
       20 Jan 2017 #5

    Thanks for your reply! I'm sorry you are experiencing something similar, but it is helpful to know it's not just me.

    If your issue is similar, but not exactly the same, you may want to check 1) that PCIe link power management is disabled [enabled, it allows PCIe slots to shut down to save power, but it can cause this kind of problem], and 2) check that the SATA / SAS cabling is secure. Apparently a loose cable can also cause this type of thing. Otherwise, I'm afraid you are in a similar boat with me: no known solution I can find.

    In my case, I'm certain it is the Toolbox that triggers it. I've used my machine everyday the past week without launching the Toolbox, and I haven't experienced any slowdowns, errors, etc. I also checked the Windows system log in the Event viewer, and no errors. Definitely none of the Event ID 129 from arcsas [that is the Adaptec RAID controller driver]. I'm really not sure why this problem arose now for me. I'd been using this configuration for a long time without issue. The only relevant change I recall making since the last time Toolbox worked was updating the RAID controller firmware. And I'm not even sure software can conflict with a device firmware. I've heard of driver conflicts, but not firmware conflicts...

    I've somewhat resigned myself to avoiding use of the Toolbox. It is aggravating. I have an Intel SSD, and I can't use the software for it.

    Looks like you do have a similar configuration to mine. Do you also happen to have an Adaptec 8405 RAID controller? I don't know if the problem is limited to that particular RAID card, or if it is more general. I'm not holding out much hope for a solution from Intel or Adaptec. My guess is if I tried contacting them with this obscure problem, Intel would tell me it's Adaptec's problem, and Adaptec would tell me it's Intel's problem

    Thanks again for responding, and let me know if you find any more information or a solution.
      My ComputerSystem Spec

  6.    22 Jan 2017 #6

    Hi there

    Maybe a silly suggestion - but does the RAID controller allow you to EXCLUDE specific HDD's from RAID configuration --- the RAID configuration might be set up in BIOS - you probably need to set this up BEFORE Windows boot as the RAID set up will be done BEFORE Windows loads.

    You might have a special bootable RAID configuration DVD or similar -- I've no experience with that particular card but usually you want RAID to configure Disks BEFORE Windows starts rather than use Windows controllers if you are using these types of controller cards.

    (There's no problem with Windows at boot loading the RAID driver - but the base configuration needs to be done (AFAIK) BEFORE Windows properly starts).

    Another OK solution is to define the SSD as a SEPARATE Single array as RAID 0 if your card allows it - I know it sounds peverse to have a RAID 0 array of just 1 Disk but this will keep the SSD as BOOT device (and actually it will perform even better - although SSD's don't need much if any enhancements these days).


    I'm using an SSD as a RAID 0 configuration !!! -- actually this avoids the need to use the Intel toolbox in any case -- but I've got an HP RAID controller so not exactly identical to your case. I have 3 arrays defined -- 1 SSD for boot, 2 X 2HDD's as 2 arrays - 2 HDD's in each array.

    In my BIOS boot there's an option for the HP Raid controller which says Configure RAID - this can be entered BEFORE any OS boot.

    Cheers
    jimbo
      My ComputerSystem Spec


  7. Posts : 39
    Windows 10 Pro x64 / Arch Linux
       16 Feb 2017 #7

    Resolved


    Thanks for your reply and suggestion. I'm sorry I didn't notice it sooner... In my configuration, I have my boot SSD connected directly to the motherboard's SATA 3 port. Then I have two other SSDs attached through the RAID controller in RAID 0. It is a 4 port RAID card, so I guess I could also connect the boot SSD to the card and leave it separate from the already existing RAID 0 array consisting of the other 2 SSDs. But then I believe I wouldn't be able to use Intel's SSD toolbox at all.

    And in the meantime, there has been another firmware update to the Adaptec 8405, and a driver update. And Intel released a new version of their Toolbox. Between all of those changes, I now find that I can use the Intel SSD Toolbox again. There is no longer any interference with the RAID controller. Perhaps these companies actually do pay attention to issues. I'm really not sure which update addressed the problem, as I didn't test after each one. I happened to discover all of these updates about the same time, and installed all of them, one after the other... I really thought it would all be to no avail, but I decided to test it anyway. To my surprise, the Toolbox now works, and my RAID card does not grind to a halt. All is back to normal and works perfectly fine.

    I hope this may help anyone else experiencing this issue. Update to the latest versions for everything involved: 1) Adaptec RAID controller firmware, 2) Adaptec RAID drivers, 3) Intel SSD Toolbox. I confirm they do now work together on Windows 10 x64.
      My ComputerSystem Spec

  8.    17 Feb 2017 #8

    Hi there

    another solution -- or suggestion is to not use the RAID card at all and use Windows storage spaces - equivalent to software RAID.

    On most cheaper RAID controllers (domestic ones on desktop PC's - not enterprise grade SAS controllers etc) the speed is SLOWER than by using Software RAID (which in Windows is essentially Storage spaces). The major disadvantage of this is though if you use say LINUX VM's you wont be able to pass native HDD's to the VM as Linux can't handle Windows storage spaces.

    Cheers
    jimbo
      My ComputerSystem Spec


  9. Posts : 39
    Windows 10 Pro x64 / Arch Linux
       17 Feb 2017 #9

    Yes, I think in my case [just 2 SSDs in RAID 0], it would be better to use Windows storage spaces, or the RAID included on the motherboard. The Adaptec 8405 I have is an entry level enterprise SAS controller with SATA support, and it costs about $450 retail. For my purpose, it is probably only complicating things unnecessarily. I think an enterprise grade RAID controller is only really worthwhile when you have more than 2 drives, and want to use higher RAID levels like RAID 5 for example.

    That is interesting about Linux VMs with Windows storage spaces... I am not using Linux VMs, but I do dual boot my system. I have the boot SSD partitioned and use GRUB2 boot loader to select between Windows 10 and Linux. My RAID 0 drive is available to both Windows and Linux. As you mentioned before, the RAID controller boots first, before GRUB2 is loaded. And there is a way to enter the RAID setup program at boot.

    Cheers!
      My ComputerSystem Spec

  10.    18 Feb 2017 #10

    I have not had the time I would like to spend on this issue recently, but I would like to say upon reviewing my system logs at breakneck speeds, I do not see that error since I stopped using Intel's toolbox. Good call on that Oxonsi.
    @jimbo45 Certainly not a silly suggestion about the raid controller allowing exclusion. I do not run any raid config, but of course there are settings that shouldn't affect non-raid, but does.

    I know it sounds perverse...
    It does! Something I have never really thought of but sounds fun! I will have to look into this sometime. Only because I can

    Long story short, I not only changed the exclusion setting. but also flagged all of the drives hot swappable. Verified PCIe link power management was disabled, and threw the toolbox out the window. This solved a couple nagging issues related to this overall thread .

    I have to say that drive power management is not something in the forefront of (eg link power management) but can cause some crazy issues. About a year ago I finally solved an issue that had persisted for a very long time. In fact, there are posts all over these forums (including seven and eight) about it.

    The IO operation at logical block address 0xc575238 for Disk 3 (PDO name: \Device\0000003c) was retried.

    Error occurrence was very random and caused a ton of seemingly unrelated inconsistent OS errors. Troubleshooting all the usual suspects and their families for a while. After scouring thread after thread of reports and different solutions, I started getting superstitious booting up. "Do a little dance and spin clockwise 3 times or else!" Long story short, turns out there was a short in ONE of the receiving pin connectors of sata port two (so cable swapping had no affect), and due to normal vibration of the chassis, sub woofer, turbulent airflow, or whatever, brief power loss would occur. Interesting how many different errors get logged.

    I have to mention this because this thread, on the surface, started smelling like this. Thank goodness not even close.

    Thanks guys and cheers!
      My ComputerSystem Spec


 

Related Threads
Hi everyone, i have one headache of a problem which im hoping someone can help me out with. also sorry if this is in the wrong category. Many months ago i had two WD Cavier Blue 1TB 7200RPM hard drives installed in my old computer as RAID 0....
By Gigabyte system board uses "Intel Rapid Storage Technology. Version 11.0.0.1339 (c) 2003-11 Option-ROM" as a firmware function. This version does not support Win 10. I contacted Gigabyte and they pointed me to version 14 software drivers which do...
gang I cannot find a download anywhere for the USER Console/GUI/UI for Intel RST that is compatible with Windows 10? This is NOT a driver question - the driver is already loaded and presumably functioning correctly per device manager. What I...
I upgraded to Win 10 from 8.1 with RST version 14.0.0.1143. I have two RAID arrays on the Intel MB controller, a 2-SSD RAID 0 for the system and a 4-SSD RAID 10 for data. I sometimes experienced system freezing when mucking with the write cache...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:57.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums