Windows 10: Odd Problem with mouse binds

  1.    07 Jan 2017 #1

    Odd Problem with mouse binds


    So, on my mouse, the logitech g303, whenever i press mouse3, it registers as mouse1. If there was a way to reset all my key binds to default, that would be great. When I press mouse1, it does not act as mouse3. I have already tried changing all of my key binds through the logitech software, but that does not seem to do anything. Please I really need to get this fixed.
      My ComputerSystem Spec

  2.    07 Jan 2017 #2

    Generally speaking, a complete uninstall of the mouse/software and then a new download of the latest software and install of it will reset it. Otherwise just download the latest driver/software and check for a default setting. There should be a factory default profile in the software.

    Logitech G303 Deadalus Apex Gaming Mouse: Review!!! - YouTube
      My ComputerSystem Spec

  3.    07 Jan 2017 #3

    But I was having the same issue before I had the software installed???
      My ComputerSystem Spec


 

Related Threads
The problem with the mouse. in Drivers and Hardware
While browsing the web, the mouse cursor freezes. You need to reset the computer to continue to browse the web.
Hello, Have a Logitech Wireless Optical Mouse M/N M-R0006 Works just fine; no problems. Have a new radio program that controls a sw radio. It uses the right-hand button to change frequencies. Cannot get it to work. Apparently nobody...
Problem with mouse in Drivers and Hardware
Hi, I use a Trust GXT25 mouse and it works perfectly. Yesterday, I got an Xbox 360 Wireless reciever, plugged it in, installed it and everything worked fine. However, when i restart the system, the mouse cursor doesnt show up. The mouse is powered,...
Problem with mouse in Drivers and Hardware
Updated from win 7 to 10 things going well then mouse stops working
Having upgraded to Win 10, I was pleasantly surprised at how well everything went, until I tried to start my Apache web server. Even though IIS is not installed, there is a http daemon running, that is (a) bound to port 80, and (b) doesn't appear in...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:36.
Find Us