1.    06 Jan 2017 #1
    Join Date : Jan 2017
    Posts : 2
    Windows 10 Education

    No Drivers Work Right With PowerColor RX 470


    Ever since I built my computer, I've been getting BSODs, Freezing, Hanging, and Crashing. All of the BSOD errors were VIDEO_TDR_FAILURE (Caused my atikmpag.sys). I tried everything that I could think of, update Windows, update AMD drivers, update BIOS, update ALL drivers, memtest, chkdsk, sfc, HDD tests, DDU, check for overheating, and more. I think that I solved most of that problem though, I installed the drivers provided my PowerColor on their website, and haven't gotten any more BSODs, but it's only been about 12 hours, only time will tell. After installing the PowerColor drivers, I was greeted by another strange issue, constant screen flickering. I got the screen flickering using 2 different PowerColor drivers, the one I got off their website, and the one on the disk that came with it. After about an hour of fiddling around in the settings, I found the culprit; my display was set to 144hz. My monitor can display 144hz just fine, and the AMD drivers let me use 144hz on my monitor. It doesn't flicker on any thing lower than 144hz though, such as 120hz, 75hz, 60hz, etc. I'm glad that it's no longer crashing, but I'd really like to get the full potential out of my monitor, but I can settle for 120hz until I find a fix. Is there any way to fix this? I DID try to update the monitor drivers, but that didn't change anything. Also, I did reseat my GPU, rotated the RAM sticks, and secured connections in my computer, but that didn't fix the flickering, but I haven't checked if it got rid of the BSODs on AMD drivers, as I had already installed the PowerColor drivers, do you think it's worth checking?
      My ComputerSystem Spec
  2.    06 Jan 2017 #2
    Join Date : Apr 2016
    x
    Posts : 225
    Win 10

    I think you need an SSD for your OS as if you are using the 1tb drive it could be bottlenecking the mb/s to reach 144hz as in rendering speed through the CPU ?

    you can use your 1tb for all software ect as this loads faster if it is not the OS.
      My ComputerSystem Spec
  3.    06 Jan 2017 #3
    Join Date : Jan 2017
    Posts : 2
    Windows 10 Education
    Thread Starter

    Quote Originally Posted by RoadBlaster View Post
    I think you need an SSD for your OS as if you are using the 1tb drive it could be bottlenecking the mb/s to reach 144hz as in rendering speed through the CPU ?

    you can use your 1tb for all software ect as this loads faster if it is not the OS.
    But the thing is, I was getting 144hz perfectly fine with the AMD drivers, but after switching to the PowerColor drivers, it starts flickering with 144hz.

    Also, I've NEVER heard anything about 144hz being restricted by only having a SSD.

    EDIT: Weird... Just changed the settings back to 144hz, and it works with no flickering.
      My ComputerSystem Spec
  4.    06 Jan 2017 #4
    Join Date : Apr 2016
    x
    Posts : 225
    Win 10

    Yes, but a mechanical hard drive is such old tech to use as the OS system, so the CPU is having to wait for hard drive begin sending data before it continues with frame rendering causing the bottle neck as the hard drive is the really slow part of the OS.

    SSD is 10 times faster at loading & reading as there is no mechanical arm swinging across the disk, before you look at any other problem get an SSD what ever size you want ?

    Don't try copying across you OS on the SSD do a fresh clean install with the latest Crimson drivers for your GPU.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
NVIDIA 8400GS drivers fail, constantly reverts to MS drivers
I have been having this issue since getting windows 10 whereby the screen will go black for a few seconds and then a message come up saying 'display drivers have failed to start, using MS basic drivers'....This has happened multiple times, even...
Graphic Cards
Clean install, all seems to work. Do I still need to install drivers?
Hey folks. Just did a windows 10 clean install in my system. ASUS p8z77-m + 3770k + samsung 850 evo + 2TB HDD. I got no exclamation marks in device manager and everything seems to work. LAN and Sound are alright for instance. Do I still...
Drivers and Hardware
Video Drivers/Playback drivers/gaming issues/very slow?
Hi everyone, I really have a big complain about Windows 10 and that is the video playback buffer. Back at Windows 8.1 i had no issues at all. I regret getting this upgrade. So I've been searching for my drivers which is an Intel(R) HD Graphics (I...
Drivers and Hardware
Line 6 POD Studio UX2 - Current Drivers Do Not Work With Win 10
This isn't a request for help just a heads-up. The Line 6 POD Studio UX2 audio interface does not work with Windows 10. The latest available version of the driver is 4.2.7.1 and it hails from 2013. Despite being listed for Windows 10 in the...
Drivers and Hardware
AMD released new drivers which should work with Windows 10 build 10122
601809947274452992 https://www.tenforums.com/tutorials/4807-windows-update-check-install-windows-10-a.html
Windows 10 News
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:01.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums