Can't right click using touchpad

  1. Posts : 1
    Windows 10

    Can't right click using touchpad

    Hi, I'm having trouble with my moms PC (Acer laptop). Right clicking is not working, but left click is working fine.

    I went to the trackpad settings and first checked that "Use two fingers to right click" was checked, and it was. Then I tried checking the other option called something like "Press in the lower right corner of the trackpad to right click". Here's where the fun started. Now I was ONLY able to right click. Didn't matter where on the trackpad I pressed - always gave me a right click... So had to use TAB and spacebar to disable that option again lol.

    Tried going to the real control panel (i.e. the old classic one) and checked the mouse options... didn't have anything about right clicking in there. And there is no driver-specific tab there. I remember when wetting up the computer a year ago that it was impossible to find drivers that gave a tab there. So I'm stuck with the Windows 10 settings panel.

    Anyone have any idea what's going on?
      My Computer

  2. Caledon Ken's Avatar
    Posts : 24,756
    Windows 10 Pro x64 Version 2004

    Welcome to the TenForums.

    Not sure what is happening but you are second to post problem in last few hours. I would try to roll back driver.

    If this works you may wish to disable Window driver updates.

    Stop Windows Updating Drivers
    Right click on Windows Start
    Click on Control Panel
    Click on System and Security
    Click on System
    Click on Advance system settings
    Click on Hardware tab
    Click on Device Installation Settings
    Click on No
    A menu appears (first time) click Never Install driver software.
    You may get a warning. Click the option that says Iíll take care of it (not exact words)

    The other thread is in the General Support section.

    Please post back in Rolling Back work.
      My Computer

  3. Bree's Avatar
    Posts : 19,644
    10 Home x64 (21H1) (10 Pro on 2nd pc)

    BadCash said:
    Hi, I'm having trouble with my moms PC (Acer laptop). Right clicking is not working, but left click is working fine.
    As @Caledon Ken says, yours is the second post with this problem in a matter of hours. The other post is here.

    In my experience a Synaptics touch pad (and most are Synaptics) can occasionally get its hardware registers in a state the driver cannot understand. Even a Restart doesn't seem to clear them. The only remedy I've found that works is to shut down the laptop, remove the battery and wait for a minute so that any residual power can drain away. Then replace the battery and start Windows normally.

    If that doesn't fix it, then work through Ken's sugestion.
      My Computers


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 20:39.
Find Us

Windows 10 Forums