Windows 10: Qualcomm Atheros QCA61x4A problem

  1.    31 Dec 2016 #1

    Qualcomm Atheros QCA61x4A problem

    Good afternoon tenforums.

    I bought a new laptop this month, which has the Qualcomm wifi card inside. Sometimes it works for a long period of time and others it will not last 5 minutes. The wifi essentially drops and turns to limited connectivity and requires a troubleshoot to fix. The same error appears everytime which is 'The default gateway is not available - Fixed'.

    On top of it dropping frequently it also sometimes has extremely slow speeds, downloading at 10kb per second - as opposed to on my poor old laptop where I would get 1.5 - 2.8 mb. These problems are only applicable to this laptop and no other device with wifi experiences this.

    I have tried the normal default gateway fixes found on the internet. I have installed numerous drivers and none have so far worked. I have also posted on acer forums (my laptop model) and nobody there has been able to successfully help yet.

    Does anybody here have any ideas/heard of this happening before?

    The laptop advertised ultra-fast wifi speed and I've got the exact opposite.

    Thanks you all

    - Sparta
      My ComputerSystem Spec

  2. Posts : 236
    Server 2012 R2 and Windows 10 x64 v1709
       31 Dec 2016 #2

    Sparta said: View Post
    I have tried the normal default gateway fixes
    Did that include
    > Check for firmware upgrades on your router
    > Test your computer with someone else's router (problem still the same?)
    > Check for BIOS updates on your m/b
      My ComputerSystem Spec

  3.    02 Jan 2017 #3

    I am having the same problem with my laptop which has the same wifi card. I've had my computer several moths, but have been unable to connect to my home wifi for the last 10 days.

    In my case the problem appears to be laptop-router specific. Every other device in the house is able to connect, and the laptop with the QualComm card is able to connect to other wifi networks.

    The driver on my computer appears to be more recent than the 2015 update on my laptop manufacturer's website, and I'm wary of downloading a new driver from a random website that shows up in a google search. Next step is to call my ISP tomorrow to find out whether there was an update on their end.
      My ComputerSystem Spec

  4.    11 Jan 2017 #4

    Similar problem here with same wifi card. Just bot from Amazon. Love the machine, hate the wifi card.

    I have ~10 other devices on the network which all work just fine...
    4 iphones
    2 notebooks (1 MacAir, 1 Lenovo Yoga 14)
    1 ipad
    2 airport express
    1 chromecast

    Wifi router is a Linksys 4500.

    Have tested the Flex 4 on networks outside my home and it seems to work just fine.
    All other devices show solid wifi/internet service. Service is 200 Mbps. Typical iphone speedtest reveals 30-90 Mbps depending on proximity to router.

    Speedtest on the new Flex 4 can vary between 1-3 Mbps (obviously impaired) up to 100 Mbps (working just fine).
    My upload speed is limited to 20Mpbs and that appears to be unaffected no matter what. Even when download speed is terrible, upload speed is consistently 20 Mbps.

    I disabled the card using Device Manager, stuck a USB wifi dongle in and connectivity was outstanding (90Mbps).

    So something about this card does not like my network, yet every other device loves it.

    I've updated all the drivers. Uninstalled the device and had the system re-discover it. Nothing works.

    I figure there is a setting that needs modifying but I'll be darned if I can find it.

    Would love to hear any suggestions. Pretty darn frustrating.
      My ComputerSystem Spec

  5.    11 Jan 2017 #5

    Download WiFi inspector and run it. This will tell you what channels your neighbors are broadcasting on and what channel your Atheros is Receiving the broadcast on. You may need to change the broadcast channel to a different one in the Router setup to accommodate the Atheros card and not be on the same broadcast channel as your neighbors.
      My ComputerSystem Spec

  6.    11 Jan 2017 #6

    ComputerGeek said: View Post
    Did that include
    > Check for firmware upgrades on your router
    > Test your computer with someone else's router (problem still the same?)
    > Check for BIOS updates on your m/b
    Yes I have tried all of these, with no luck.

    I have also reformatted my HD completely, uninstalled AV and still the same issue - default gateway unavailable.

    I'm thinking the product is fault itself.
    Last edited by Sparta; 11 Jan 2017 at 20:38.
      My ComputerSystem Spec

  7.    13 Jan 2017 #7

    Spunk, I'm using the 5ghz band. Channel 149. Only one other network withing range on that channel.

    Honestly though, why would the presence of other networks on that channel ONLY effect the Atheros card and none of the other 10+ wifi devices in my home? (I left out an Apple TV in my previous list)

    Sparta, I purchased this notebook at Amazon. This is actually the second machine they have sent to me. I exchanged the first for a new machine when these problems occurred hoping is was simply a faulty wifi card. My conclusion is that there is a conflict between this card and my network which is very specific to this card.
      My ComputerSystem Spec

  8.    05 Feb 2017 #8

    I think I fixed this by setting the "roaming aggressiveness" to lowest in Device Manger. After I did this it been working and not breaking as soon as I enable the wifi adapter
      My ComputerSystem Spec


Related Threads
Solved Disabled wifi qualcomm atheros in Network and Sharing
After clean installing windows 10 pro the latest version till today, my qualcomm atheros qca 9565 bt and wifi combo is disabled. I cant do anything to turn wifi on. What should i do? :'( my device is ok. Works with 8.1 and 7. But only here in...
Qualcomm Atheros Drivers? in Drivers and Hardware
Hi, Is there a new network adapter for windows 10 that is Qualcomm Atheros? I have the version AR9485 and I think the version was The reason I am saying this is because my Wifi does not work (only on my Asus computer.) I am sending...
Hello everyone. My notebook would not complete installation of Windows 10 due to athwbx.sys problem. BSOD. This is a driver file found in Windows 8 for the Atheros Wireless Network hardware. However I am updating from Windows 7 and this file is...
Qualcomm/Atheros Wireless Lan Driver in Drivers and Hardware
Qualcomm/Atheros Wireless Lan Driver Version WHQL
where can i find qualcomm atheros ar3012 bluetooth driver for windows 10 ?
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:11.
Find Us