Windows 10: Media Transfer Protocol Device (MTP Device) support for Windows 10 N Solved

  1.    18 Dec 2016 #1

    Media Transfer Protocol Device (MTP Device) support for Windows 10 N


    Hey everyone,

    I'm using Windows 10 N Anniversary Update, the one with no media bloatware like WMP. However I wish my iPhone was accessible with File Explorer to copy photos. It turns out you have to install Media Feature Pack for Windows 10 N (KB3133719) to get it working.

    The KB3133719-x64.msu.msu file itself is just around 100 MB. However when you install it it takes ~500 MB of space which is 40 MB more than if you install regular Windows 10 non-N (yes I had to install several virtual machines to figure it).

    This is absolutely not reasonable because the MTP Device drivers included in KB3133719-x64.msu.msu only take up about 3 MB! The works part is the BK3133719 package installation is permanent and you cannot remove it from your N system afterwards with DISM (tried it, Remove-Package returns an error).

    I managed to extract CAB from MSU and extract driver INF & DLL of interest from CAB. However when I try to apply driver to my iPhone in Device Manager (you have to use shift-Restart > Troubleshooting > Advanced > Startup settings to install unsigned driver because driver signature is inherited from extracted CAB, according to Microsoft, sorry can't re-find article) the wizard says the device cannot be added because Device class is missing. Actually, yes, the device class "Portable device" is missing in Windows 10 N.

    So I wonder if anyone could help me to
    1) add "Portable device" class manually to my Windows 10 system (I can get all DLLs from CAB of the KB3133719)
    or
    2) get the Windows-Portable-Device-Package actually out from CAB inside KB3133719-x64.msu.msu and make it install only the driver.

    I already tried editing Media-Feature-Pack MUM (it's found inside CAB, I removed all <update> string lines except Windows-Portable-Device) & making new signed CAT for it (used makecat.exe) then re-packing and re-signing the CAB (yes I installed my custom generated certificate to Trusted Publishers & Trusted root), thanks to this awesome guide. However I get the error (file not found) upon installing signed CAB package to a fresh 10 N virtual machine. When I sign the CAB generated from extracted untouched files everything installs fine. So I assume I do everything right when it comes to signing but there's some double-check somewhere (probably reference to other packages inside Windows-Portable-Device MUM) that I cannot figure out.

    Here's what I'm doing & where I'm stuck:
    Code:
    via http://woshub.com/how-to-sign-an-unsigned-driver-for-windows-7-x64/
    via http://stackoverflow.com/questions/19411440/makecab-create-a-cab-file-from-all-the-files-in-a-folder
    
    
    1. Download Visual Studio Community 2015: https://www.microsoft.com/en-us/download/details.aspx?id=48146
    Configure Visual Studio Community 2015 installation: check "Universal Windows App Development Tools > Tools (1.4.1) and Windows 10 SDK"
    
    
    2. Unarchive (using WinRAR or expand command) KB3133719-x64.msu.msu > microsoft-windows-mediafeaturepack-oob-package-original.cab > microsoft-windows-mediafeaturepack-oob-package-original
    
    
    3. Edit adn save using Notepad .\microsoft-windows-mediafeaturepack-oob-package-original\Microsoft-Windows-MediaFeaturePack-OOB-Package~31bf3856ad364e35~amd64~~10.0.14393.0.mum
       to delete all update entries except:
       - Microsoft-Media-Foundation-Package
       - Microsoft-Media-Foundation-WOW64-Package
       - Microsoft-Windows-Portable-Devices-Package
    
    
    2. Run Command Prompt as Administator
    
    
    cd "C:\Program Files (x86)\Windows Kits\8.1\bin\x64"
    
    
    makecert -r -sv C:\Certificate.pvk -n CN="Generic Certificate" -eku 1.3.6.1.5.5.7.3.3,1.3.6.1.4.1.311.10.3.6 C:\Certificate.cer
    
    
    (Password - None)
    
    
    Note (according to https://msdn.microsoft.com/en-us/library/windows/desktop/aa386968(v=vs.85).aspx)
    To find EKU, double-click any CAT from original CAB and View Signature > View Certificate > Details > Copy to File > Save as CER
    Double-click CER > Details > Enchanced Key Usage contains numbers:
    Code Signing (1.3.6.1.5.5.7.3.3)
    Windows System Component Verification (1.3.6.1.4.1.311.10.3.6)
    This determines a certificate is valid for Windows Update installations.
    Otherwise DISM returns error:
    0x800B0110 -2146762480 CERT_E_WRONG_USAGE The certificate is not valid for the requested usage
    (https://social.technet.microsoft.com/wiki/contents/articles/15260.windows-update-agent-error-codes.aspx)
    
    
    cert2spc C:\Certificate.cer C:\Certificate.spc
    
    
    pvk2pfx -pvk C:\Certificate.pvk -spc C:\Certificate.spc -pfx C:\Certificate.pfx
    
    
    3. Install Certificate.cer to Local Computer > Trusted Publishers and Trusted Root Certification Authorities Stores
    
    
    4. Create CDF file using Notepad
    
    
    # # # # # # # # # # # # # # # # # # # # 
    
    
    [CatalogHeader]
    Name=Microsoft-Windows-MediaFeaturePack-OOB-Package~31bf3856ad364e35~amd64~~10.0.14393.0.cat
    ResultDir=.\
    PublicVersion=0x00000001
    EncodingType=
    
    
    [CatalogFiles]
    <HASH>Microsoft-Windows-MediaFeaturePack-OOB-Package~31bf3856ad364e35~amd64~~10.0.14393.0=.\Microsoft-Windows-MediaFeaturePack-OOB-Package~31bf3856ad364e35~amd64~~10.0.14393.0.mum
    
    
    # # # # # # # # # # # # # # # # # # # # 
    
    
    Copy CDF & MUM to "C:\Program Files (x86)\Windows Kits\8.1\bin\x64"
    
    
    5. Continue to Command Prompt as Administator:
    
    
    makecat Microsoft-Windows-MediaFeaturePack-OOB-Package~31bf3856ad364e35~amd64~~10.0.14393.0.cdf
    
    
    signtool sign /f C:\Certificate.pfx /t http://timestamp.verisign.com/scripts/timstamp.dll /v "C:\Program Files (x86)\Windows Kits\8.1\bin\x64\Microsoft-Windows-MediaFeaturePack-OOB-Package~31bf3856ad364e35~amd64~~10.0.14393.0.cat"
    
    
    Copy CAT to C:\Users\Ilya\Downloads\KB3133719-x64.msu\microsoft-windows-mediafeaturepack-oob-package
    
    
    6. Run Windows PowerShell & input script, press Enter
    
    
    # # # # # # # # # # # # # # # # # # # # 
    
    
    function compress-directory([string]$dir, [string]$output)
    {
        $ddf = ".OPTION EXPLICIT
    .Set CabinetNameTemplate=$output
    .Set DiskDirectory1=.
    .Set CompressionType=MSZIP
    .Set Cabinet=on
    .Set Compress=on
    .Set CabinetFileCountThreshold=0
    .Set FolderFileCountThreshold=0
    .Set FolderSizeThreshold=0
    .Set MaxCabinetSize=0
    .Set MaxDiskFileCount=0
    .Set MaxDiskSize=0
    "
        $dirfullname = (get-item $dir).fullname
        $ddfpath = ($env:TEMP+"\temp.ddf")
        $ddf += (ls -recurse $dir | ? {!$_.psiscontainer}|select -expand fullname|%{'"'+$_+'" "'+$_.SubString($dirfullname.length+1)+'"'}) -join "`r`n"
        $ddf
        $ddf | Out-File -encoding UTF8 $ddfpath
        makecab /F $ddfpath
        rm $ddfpath
        rm setup.inf
        rm setup.rpt
    }
    
    
    # # # # # # # # # # # # # # # # # # # # 
    
    
    7. Input PowerShell commands:
    
    
    cd C:\Users\Ilya\Downloads\KB3133719-x64.msu
    
    
    compress-directory .\microsoft-windows-mediafeaturepack-oob-package .\microsoft-windows-mediafeaturepack-oob-package.cab
    
    
    8. Continue to Command Prompt as Administator:
    
    
    signtool sign /f C:\Certificate.pfx /t http://timestamp.verisign.com/scripts/timstamp.dll /v "C:\Users\Ilya\Downloads\KB3133719-x64.msu\microsoft-windows-mediafeaturepack-oob-package.cab"
    
    
    # # # # # # # # # # # # # # # # # # # # 
    
    
    Here's error I get when install signed CAB using DISM
    
    
    Deployment Image Servicing and Management tool
    Version: 10.0.14393.0
    
    
    Image Version: 10.0.14393.0
    
    
    Processing 1 of 1 - Adding package Microsoft-Windows-MediaFeaturePack-OOB-Package_Wrapper~31bf3856ad364e35~amd64~~10.0.14393.0
    [==========================100.0%==========================]
    An error occurred - Microsoft-Windows-MediaFeaturePack-OOB-Package_Wrapper Error: 0x80090352
    
    
    Error: 0x80090352
    
    
    DISM failed. No operation was performed.
    For more information, review the log file.
    
    
    # # # # # # # # # # # # # # # # # # # #
    I found absolutely no information about error 0x80090352 & Windows Update.

    Please help!
    Last edited by username1; 18 Dec 2016 at 19:46.
      My ComputerSystem Spec

  2.    18 Dec 2016 #2

    After 3 days of looking for a solution I finally managed to almost figure it out. Now I have MTP USB Device recognised but I receive error "The class installer has denied the request to install or upgrade this device" when I try updating Apple Mobile Device USB to MTP...

    1. Download and install "Apple Mobile Device Support 10.0.1.3" (or any other version, it is also included in iTunes or iCloud for Windows)
    2. Download "KB3133719-x64.msu.msu"
    3. Extract MSU using WinRAR (or expand command in Command Prompt)
    4. Extract "microsoft-windows-mediafeaturepack-oob-package.cab" using WinRAR (or expand command in Command Prompt)
    5. Find and copy to Desktop these folders from extracted "microsoft-windows-mediafeaturepack-oob-package.cab" folder:
    1) amd64_microsoft-windows-wpd-portabledeviceapi_31bf3856ad364e35_10.0.14393.0_none_787531c102bc9494
    2) amd64_microsoft-windows-wpd-mtpclassdriver_31bf3856ad364e35_10.0.14393.0_none_ff2df011b0df1756
    3) amd64_c_wpd.inf_31bf3856ad364e35_10.0.14393.0_none_cf8526fd6c5c5991
    4) amd64_wpdfs.inf_31bf3856ad364e35_10.0.14393.0_none_536140fce94e6668
    5) amd64_wpdcomp.inf_31bf3856ad364e35_10.0.14393.0_none_a705ad6d2231825e
    6) amd64_wpdmtp.inf_31bf3856ad364e35_10.0.14393.0_none_4d0eb11e9d6341a8
    7) amd64_wpdmtphw.inf_31bf3856ad364e35_10.0.14393.0_none_25b2f5f3461d993d
    8) amd64_bthmtpenum.inf_31bf3856ad364e35_10.0.14393.0_none_2d6c2e43aaa47c56
    6. Rename folders to 1-8 in order of 4-th paragraph
    7. Restart your PC to special mode using Start > Restart holding Shift button > Troubleshoot > Startup
    8. At startup dialog press 7 (Disable Driver Signature Enforcement)
    9. Launch Command Promt as Administrator
    10. Install files using this commands in sequence of folders
    MOF files:
    mofcomp %PATH%
    INF files:
    pnputil /add-driver %PATH%
    11. Start > Restart with Shift > Troubleshoot > Startup
    12. At startup dialog press 7 (Disable Driver Signature Enforcement)
    13. Right-click Start > Device Manager
    14. Choose USB Controllers > Apple Mobile Device USB > Update driver software... > Browse my computer > Let me pick from a list > MTP USB Device > Next > Error!
    Last edited by username1; 20 Dec 2016 at 20:03.
      My ComputerSystem Spec

  3.    20 Dec 2016 #3

    OK, thanks to this wonderful article I managed to figure out how to completely uninstall Media Feature Pack for Windows 10 N permanent update KB3133719. Here's some details on what I did in case comment won't be published there:
    I replaced string permanence=permanentUntilReset with permanence=removable in all files “Microsoft-Windows-MediaFeaturePack * .mum”. The “main” package wrapper file (Microsoft-Windows-MediaFeaturePack-OOB-Package_Wrapper~31bf3856ad364e35~amd64~~10.0.14393.0.mum) didn’t want to uninstall and returned error. However command
    Code:
    WUSA /UNINSTALL /KB:3133719
    worked like a charm, at the end command prompt asked for restart & viola – package removed. Next thing I’m going to try is edit MUM so it didn’t remove Media Transfer Protocol support.
    And here’s how to remove traces of update from WinSxS (if you don’t do that after uninstalling permanent update you won’t gain any disk space back!). First command:
    Code:
    dism /online /cleanup-image /startcomponentcleanup
    Check out results. Second command:
    Code:
    dism /online /cleanup-image /startcomponentcleanup
    Lastly I attach everything you need to completely uninstall Media Feature Pack for Windows 10 N KB3133719 in no time !

    I'm also happy to report I successfully modified MUMs to be able to uninstall
    Media Feature Pack for Windows 10 N preserving MTP device support. I attach the second ZIP for that. Basically it leaves only drivers for all Media Transfer Protocol Devices (MTP Devices), ~7 MB, and uninstalls all bloatware like Windows Media Player and it's codecs (~500 MB). So yes, a lot of valuable space has been saved today !

    BONUS TIP
    The quick way to only
    install MTP Device drivers for Windows 10 N from KB3133719 (without other packages) is:
    1. UnRAR "KB3133719-x64.msu.msu" to your Desktop
    2. UnRAR "microsoft-windows-mediafeaturepack-oob-package.cab" to your Desktop
    3. Run command as Administrator:
    Code:
    dism /online /add-package /packagepath:"C:\Users\%YourUserName%\Desktop\microsoft-windows-mediafeaturepack-oob-packagemicrosoft-windows-portable-devices-package~31bf3856ad364e35~amd64~~10.0.14393.0.mum"
    GENERAL NOTE
    However the only issue after either partially uninstalling of KB3133719 or installing only Windows Portable Devices Package is class/type in Device Manager will be named "Unknown" not "Portable device" (device name itself and icon are fine - Apple iPhone & portable device icon). And you will have to manually configure AutoPlay for Apple iPhone in Settings of Windows. Other then that it works fine. Sorry I couldn't figure out how to fix that tiny issue.

    Happy holidays
    !
    Last edited by username1; 20 Dec 2016 at 20:17.
      My ComputerSystem Spec


  4. Posts : 1
    Windows 10 Pro 64bit 1703
       13 Apr 2017 #4

    Thank you very much for your awesome find, @username1.

    After doing the creators update two days ago, I had forgotten to apply the Media Feature Pack. Since I only require its MTP drivers I found your thread. Had to adapt a little but I thought I might share back. The filenames changed a bit. Also for me, my mobile phone (One Plus 3, labelled A3003) is correctly addressed in device manager.

    I installed four packages for that, not sure if all were required:

    1. microsoft-windows-portable-devices-package~31bf3856ad364e35~amd64~10.0.15063.0.mun
    2. microsoft-windows-portable-devices-package~31bf3856ad364e35~amd64~en-us~10.0.15063.0.mun
    3. microsoft-windows-portable-devices-package-windows~31bf3856ad364e35~amd64~10.0.15063.0.mun
    4. microsoft-windows-portable-devices-package-windows~31bf3856ad364e35~amd64~en-us~10.0.15063.0.mun

    All applied using the dism method and doing a reboot afterwards. Works perfectly and without all the other Media bloat.
      My ComputerSystem Spec


 

Related Threads
How to Cast Media to Device from Microsoft Edge in Windows 10 Microsoft Edge is a new web browser that is available across the Windows 10 device family. It is designed for Windows 10 to be faster, safer, and compatible with the modern Web. ...
Driver / Device support in Drivers and Hardware
When I upgraded from windows 7 ultimate to Windows 10 Pro all the drivers and connections seemed to have come across without problem. I use a Dell Axim x51v PPC. It was visible and accessible. Last week I could not access windows 10 anymore as a...
Latest Windows Device Recovery Tool update brings support for Acer devices 85372 Download: http://go.microsoft.com/fwlink/?LinkID=525569
Windows Device Recovery Tool updated with HoloLens & Clicker support Version: 3.3.31 74350 Download: http://go.microsoft.com/fwlink/?LinkID=525569
I can cast music to my Sony Bravia XBR 65x850b tv. However when I have it as a a duplicate display sound I get on the speakers primary display does not come from the speakers on the TV. On the device manager the TV shows as a media device....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:45.
Find Us