1.    14 Dec 2016 #1
    Join Date : Nov 2015
    Romania
    Posts : 160
    Windows 10 Insider Build 17035 / Ubuntu 17.10

    UEFI + Secure Boot not logging into W10 (dual-boot)


    Hei,

    So I'm the guy who tried to move from Legacy to UEFI some days ago. I managed to move both Ubuntu and W10 to UEFI.

    More info on both of the situations here:

    Solved Can't boot into UEFI mode - Lenovo Z50-70 - Windows 10 Forums

    Queston about GRUB2 + UEFI - Ask Ubuntu

    It seems that when I enable Secure Boot I keep getting these errors (It works if Secure Boot is not enabled, also Ubuntu boots just fine):
    Attached Thumbnails Attached Thumbnails DSC_0004.jpg   DSC_0003.jpg   DSC_0002.jpg  
      My ComputerSystem Spec
  2.    14 Dec 2016 #2
    Join Date : Nov 2015
    Romania
    Posts : 160
    Windows 10 Insider Build 17035 / Ubuntu 17.10
    Thread Starter

    Tried to do a startup repair:

    Logs: http://pastebin.com/2BjC1x5j
    Attached Thumbnails Attached Thumbnails DSC_0003.jpg  
      My ComputerSystem Spec
  3.    15 Dec 2016 #3
    Join Date : Jun 2016
    Los Angeles
    Posts : 1,104
    Windows 10 Pro

    You cannot run the Bootrec commands from the X:\Sources temporary drive. These commands need to be run from the Drive letter the OS is on. Remember, in the RE(Recovery Environment) the OS drive may not be C:

    At command prompt (x: sources) type this exactly as written:
    bcdedit |find “osdevice” (Must inc and the |), the | before Find is the Upper case \ key) press enter. This will tell you what drive letter the OS is on.It may not be on the C: drive.
    Now use the returned as the drive letter for OS, for this example, assume C: or whatever drive letter is the os device.
    Or, you can type C: and press enter, then type DIR and press enter. If there is a Windows directory under that drive letter, then that is the OS device. Or D: etc Type that drive letter once you know, followed by the Bootrec command.

      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Ubuntu Boot option still available in UEFI BIOS after Dual Boot
Recently I played around with dual booting Linux Mint on my system. I decided that I would delete it for the present as I have other things to focus on. However, after deleting partitions and fixing my MBR to only boot windows my UEFI BIOS still...
General Support
Solved UEFI bios enabled but no secure boot on windows 10?
So i had secure boot up and running on my windows 8.1 machine after a clean install, but now since microsoft upgraded me to windows 10 it seems as my secure boot is off again, but it's enabled in my bios is so weird, it's enabled in bios but off in...
General Support
Solved Partition scheme win10 x64 family, uefi and secure boot ?
Hello, I'm currently reinstalling entirely windows 10 x64 with uefi , hardware fast boot, and secureboot. I'm a bit confused because win 10 installer set: Recovery on partition 1 System on partition 2 (win re) MSR (not formated) 3 Then...
Installation and Upgrade
Boot mode uefi with secure boot disable
Ok im about to upgrade to win 10 then do a clean install afterwards of win 10, but i wanted to assure i have everything correct before i start. I updated again my profile with Belarc to assure i have a completed list of my software, i notice this...
Installation and Upgrade
Question about Windows 10 UEFI BIOS with Secure Boot
So, basically if we have a computer that doesn't have a UEFI BIOS with Secure Boot, then we can't upgrade to Windows 10? Am I right or wrong here?
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:56.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums