I recently bought an HP Pavilion desktop that came with a Realtek soundcard. It also had this Bang & Olufsen (B&O) software called ‘Play’ installed that is used to control the audio options (albeit very few). The problem is that B&O Play seems to have loudness equalisation turned on by default and there is no option to turn it off ( the option has also been removed from the normal windows audio options panel (there is a box saying ‘turn off all effects’, but unchecking it makes no difference).

So I looked online and the consensus seemed to be that rolling back the driver to the substitute audio device driver would give me back the normal enhancement control options (see:Solved: How to disable Bang Olufsen horrible audio correction? - HP Support Forum - 5294181). After doing so the loudness equalisation box is visible (and off by default), problem solved.

This creates a new problem, however. Now I have the echo back/sync issue when I try to monitor the line in. This is normally fixed by unchecking 'listen to this device' under the line in properties 'listen' tab.
But after the rollback, when you look under the 'levels' tab in speaker properties, it only shows one control for speaker volume and not the usual Realtek audio output volume and line in level controls. Unchecking "listen to this device results in silence.

I'm starting to wonder if this is an unfixable inherent issue with the soundcard/software the PC came with. Therefore the only solution may be to install a new soundcard.