Windows 10: a request for device descriptor request failed

Page 1 of 2 12 LastLast
  1.    08 Dec 2016 #1

    a request for device descriptor request failed


    hello guys in my device manager there is a yellow triangle on a usb device driver saying : a request for device descriptor request failed first i thought maybe 1 of my us ports not working but when i tested all ports are working even card reader but the error is still there i updated drivers (chipset - etc) but it didnt help so i want to know how to get rid of that error and what is the problem with my laptop?
    note: sometimes when i trun on my laptop that error is gone mysteriously and most of the times its showing up
    note: i recently changed my wireless adapter tho the orginial adapter was a bt/wifi combo but the new one is just a wifi adapter and i have an ssd installed instead of dvd optical drive and both are working well
    note: things i already tried: disabling fast boot-updating generic usb drivers-taking out battery for 5 minutes-updating drivers
      My ComputerSystem Spec

  2.    09 Dec 2016 #2

    i recently changed my wireless adapter
    Is this a USB adapter? Does the error go away if the adapter is removed? With the yellow flag in Device Manager, right click it and Uninstall it. Remove the USB Device from the computer end and Restart your computer. When the computer comes back up, plug the USB device into different USB port of the computer.
      My ComputerSystem Spec

  3.    10 Dec 2016 #3

    spunk said: View Post
    Is this a USB adapter? Does the error go away if the adapter is removed? With the yellow flag in Device Manager, right click it and Uninstall it. Remove the USB Device from the computer end and Restart your computer. When the computer comes back up, plug the USB device into different USB port of the computer.
    i have no usb adapter attached and my device is a laptop
    only thing i have attached to laptop is a mouse
      My ComputerSystem Spec

  4.    10 Dec 2016 #4

    update: driver properties location part says Port_#0007.Hub_#0003 wich device can this be?
      My ComputerSystem Spec

  5.    11 Dec 2016 #5

    So, the Wireless adapter that you replaced is not a USB device? Please include the Full Make and Model# of your laptop.
    Right click the device choose Properties/Details/Property take the drop down arrow and choose Hardware ID's copy the text and paste it into Google and/or paste here.
      My ComputerSystem Spec

  6.    14 Dec 2016 #6

    spunk said: View Post
    So, the Wireless adapter that you replaced is not a USB device? Please include the Full Make and Model# of your laptop.
    Right click the device choose Properties/Details/Property take the drop down arrow and choose Hardware ID's copy the text and paste it into Google and/or paste here.
    it says : USB\DEVICE_DESCRIPTOR_FAILURE
      My ComputerSystem Spec

  7.    15 Dec 2016 #7

    If you've already update the chipset drivers, also check if there's a BIOS update.

    Also check to see if this happens with any more frequency when the laptop is plugged vs unplugged (power can also be a cause)
    Does your laptop also have a webam? The cam also connects to the USB bus.

    Don';t know if it will help but try running USBLogView. If lucky, maybe it'll show a device dropping in / out
      My ComputerSystem Spec

  8.    16 Dec 2016 #8

    ComputerGeek said: View Post
    If you've already update the chipset drivers, also check if there's a BIOS update.

    Also check to see if this happens with any more frequency when the laptop is plugged vs unplugged (power can also be a cause)
    Does your laptop also have a webam? The cam also connects to the USB bus.

    Don';t know if it will help but try running USBLogView. If lucky, maybe it'll show a device dropping in / out
    i have checked every function i could and everything is working (webcam usb3 usb2 ports mouse keyboard etc )
    this error surprise me tho
      My ComputerSystem Spec

  9.    16 Dec 2016 #9

    Maybe it's time to step back from the current efforts, and start over. I suggest you read over this excellent tutorial and try all of its steps: [Solved] Unknown USB Device (Device Descriptor Request Failed) for Windows 10 - Driver Easy. The one that may provide you with some easy relief is the one where you uninstall the device whose descriptor is failing, reboot, and see what happens when device enumeration recurs during boot-up. If you're lucky, it will fix itself.
    HTH,
    --Ed--
      My ComputerSystem Spec

  10.    18 Dec 2016 #10

    EdTittel said: View Post
    Maybe it's time to step back from the current efforts, and start over. I suggest you read over this excellent tutorial and try all of its steps: [Solved] Unknown USB Device (Device Descriptor Request Failed) for Windows 10 - Driver Easy. The one that may provide you with some easy relief is the one where you uninstall the device whose descriptor is failing, reboot, and see what happens when device enumeration recurs during boot-up. If you're lucky, it will fix itself.
    HTH,
    --Ed--
    my bios is and custom unlocked bios (latest version) (thanks to Bios Mods -The Best BIOS Update and Modification Source ) because of lenovo hardware whitlist maybe thats causing the problem???
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Fresh install of Windows 10 and the last driver I need to sort out is the above. I believe it is my powered USB 3 hub to which I plug in my keyboard and mouse. Technically it is working but I don't like seeing yellow triangles on devices. So...
Let me start out by saying that I've googled the shit out of this problem, tried several things, and nothing worked. I have a D-Link USB 2.0 Hub that I got about a week ago. It's been working awesome up until recently. It's a plug and play...
After installing Windows 10 anniversary update, I get the following error in the device manger: Unknown USB Device (Device Descriptor Request Failed) Tried uninstalling and restarting PC. Reinstalled Windows made from media tool. Nothing fixed...
Hello, ok so after recently doing a clean install of windows 10(please don't get me started on that mess). my system has been plagued by random usb drops. it's where everything connected via USB suddenly disconnects then reconnects out of the blue....
Hello I have a USB device (X.Vision PCDVB-3100) It work properly in Windows 8 and Windows 8.1 But now in Windows 10 when I connect it to USB port, The Windows give me this error: “Windows has stopped this device because it has reported...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 19:42.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums