1. Joined : Dec 2015
    Bulgaria
    Posts : 5
    Windows 10 Home x64
       3 Weeks Ago #1

    SSD not working in AHCI after Windows 10 install


    My situation is the following:I had a LGA 775 Mobo pc,and one of my father's collegues was upgrading his pc so he gave us his old computer system,i found out that his motherboard had better functions and is better overall,motherboard is gigabyte ga-ep35-DS3L,i installed it in my case and hooked up all devices,booted into windows and it worked like a charm - no reinstall needed.But 2 months ago i bought SSD 120GB,i installed in my pc,all worked great,enabled the ahci mode in bios then proceeded with installing windows.i decided to go with windows 7 as it is my favorite os and i had it already on a usb drive.i've always used usb drives to install os,but i haven't installed os on this pc because the windows 7 installation from my other mobo was working without problems.Okay,plugged the USB with Win7 on it into pc,booted as usb-hdd as it was the only option that would boot from the usb,the loading of windows install files took way too long (like 10+ minutes),so i decided to pull out my Windows dvd and install it using cd/dvd drive.that way it loaded almost instantly and installation went smooth,drive recognized,partitioned it - ssd was os drive,1TB HDD was my Storage.All good to up last night,i decided to upgrade my Windows 7 to Windows 10,downloaded the iso from microsoft using media creation tool and made bootable usb drive with rufus.remember the ahci mode was enabled all the time,even before the windows 10 install.Alright so i booted into usb-hdd and windows 10 began loading installation files,it was really slow but when it loaded the files all became fast and snappy.On the drives screen i deleted the 100Mb system reserved partition and the 111GB os partition from the ssd drive and made new one (as i know the windows 10 uses 500MB instead of 100MB system reserved partition).All good,installation started,fast,snappy,then it was time to restart.System rebooted and BOOM i get message on screen: Port-01: No device found (port 1 is where my ssd was connected to).I was googling for long time,most of the times it was ssd failure.i thought my ssd died and i removed it from my pc,but this morning i thought - well i should try using ide instead of ahci to see if it recognizes the ssd.so went in bios,changed to ide,plugged the ssd back in,turned on the pc and...my ssd was recognized in bios!but that's where the good news end,so the ssd is working,but only in ide,matter of fact im writing this post on windows 10,but i want my pc to be ahci mode so i can use all the advantages over ide,so i went back in bios and set the sata mode to ahci,and...again the ssd failure port-01: No device found.I repeated the procedure and restored the ide mode.
    what comes to my mind is: this mobo is kind of old(like all of the lga775) and it doesn't fully support boot from usb like others do,it has usb-zip,usb-hdd,usb-fdd,usb-cdrom,the only one that boots the usb is usb-hdd and it boots slow as hell,after that i removed ssd and put sata to ide mode,plugged in my windows 7 usb and proceeded with installing it.nope,when i reached the partition screen,i made 100GB os partition and rest as storage partition on my hdd (ssd unpluged),installation begin and in the second as it began there was error box,error said : "windows cannot copy files required for installation. the files may be corrupt or missing. make sure all files required for installation are available, and restart the installation.".i know for damn sure this usb is fully working and in perfect condidion,not so long ago i installed windows 7 on my laptop from it,also installed windows 7 on my mum's pc from it-so usb is not the problem.What i think it is,is that maybe the motherboard doesn't support usb boot and recognizes usb as hdd (even when i press f12 for boot menu i have "+" symbol on Hard Drives and under it there is usb-hdd - the only mode that my usb is booted,it doesn't boot from normal usb-hdd mode listed).so basically i think i screwed up something with my ssd-maybe mbr or something else,i am not an ssd expert as i have it for quite a short time.
    i will be thankful if you guys help me on this case - i want to restore my ssd so it's recognized in ahci mode,not only in ide,and i want to install windows 10 on it,i will make a bootable dvd drive this time as it's fully supported by motherboard,will not experiment with usb installations on this motherboard anymore,i am scared to go with it actually :d
    computer is functioning properly with ide mode,but you know ahci is crucial for ssd and even hdd performance.

    pc specs:
    mobo: gigabyte ga-ep35-DS3L
    CPU: Intel Xeon E5440 2.83 (xeon mod)
    Ram: 6GB DDR2 800mhz
    Graphics: AMD R9 270 2gb
    PSU: Chieftec 500W
    HDD: Seagate 1TB sata 3
    SSD: KingSpec 120GB sata 3(i know it is a chinese brand but it is working great and is super fast)
    case: DeepCool tesseract BF
      My System SpecsSystem Spec


  2. Joined : Jan 2015
    UK, Midlands
    Posts : 6,241
    Win 10 Pro (1607)
       3 Weeks Ago #2

    Please summarise the problem briefly, and use line spacing to delineate paragraphs.

    The above is extremely difficult to read, so you will get better responses if you lay out your issue briefly and clearly. Thanks!
      My System SpecsSystem Spec


  3. Joined : Dec 2015
    Bulgaria
    Posts : 5
    Windows 10 Home x64
       2 Weeks Ago #3

    my pc was in ahci mode,i had win 7 previously,installed win 10 with both ssd and hdd connected and after first restart ssd was no longer working in ahci.

    how i fixed: removed ssd,changed sata mode to ide,connected ssd again and wiped all partitions from it using the windows 10 dvd,after that i disconnected hdd,put ahci mode in bios and installed windows 10 with only ssd connected.after installation plugged in back hdd and everything worked.

    problem is when you have 2 or more drives,sometimes windows installs boot files on other drive and makes the install not working as ahci or maybe it doesnt install ahci drivers on correct drive during install
      My System SpecsSystem Spec


  4. Joined : Jan 2015
    UK, Midlands
    Posts : 6,241
    Win 10 Pro (1607)
       2 Weeks Ago #4

    Thanks.. glad you got it working. Certainly what you ended up doing was entirely rational, although quite undesirable- forcing Windows to do the right thing. However, it should be reasonable to expect an upgrade to work as you'd wish, saving you reinstalling programs, reconfiguration.... at least most of the time.

    However, as you say, if there's insufficient unallocated space on the nominally system drive, Windows will place other partitions (EFI, Recovery...) on another drive if there's space on one. I find it troubling that that can happen without warning.

    It will be worth examining your HDD closely to see if there are redundant partitions on it created when you upgraded. Don't use Disk Management for that if you wish to see the 16 Mb System partition should one exist there... use a different partition manager.
      My System SpecsSystem Spec


  5. Joined : Dec 2015
    Bulgaria
    Posts : 5
    Windows 10 Home x64
       2 Weeks Ago #5

    thanks for answer,actually i deleted all of the partitions on hdd and made only one for storage.funny thing is that both windows 10 from ssd and windows 7 from hdd were booting in ide mode
      My System SpecsSystem Spec


  6. Joined : Jan 2015
    UK, Midlands
    Posts : 6,241
    Win 10 Pro (1607)
       2 Weeks Ago #6

    Did you perhaps have Win 7 installed on your HDD at some point and so you it seemed you had two bootable disks installed?
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Help with Intel series 7 SATA AHCI Controller Drive for windows 10
Hi, bit of a long shot, not sure if anyone will be able to help me. I remember a good few years back i would always use the latest SATA or matrix / RST drivers and would always update them regularly, I’m pretty sure i have had newer drivers on my...
Drivers and Hardware
Is Windows 10 Standard AHCI Driver Sufficient?
I have an I5 Ivy-Bridge (B75 chipset) system. Windows 10 is up and running (fresh install) and I've been able to load all but the correct SATA drivers - still using the "Standard" AHCI SATA driver that windows installed. Asus hasn't released a...
Drivers and Hardware
Solved AHCI Clean install windows 10 onto new SSD drive
I seem to remember, when I installed windows 7 Pro 64 bit on a new build, a few years ago, I had to install some specific drivers during the Windows 7 installation to ensure drives used AHCI mode. Do I still need to do anything during windows 10...
Installation and Setup
Install AHCI Driver after Win 10 installation
Hi All. I would appreciate some help on this one. I found a spare 160GB SATA Drive on which I have decided to install a trial of Win 10 to explore it further for now. The only way that I could get this HD to be seen in the BIOS would be to...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:07.
Find Us
Twitter Facebook Google+



Windows 10 Forums