Let me start out by saying that I've googled the shit out of this problem, tried several things, and nothing worked.

I have a D-Link USB 2.0 Hub that I got about a week ago. It's been working awesome up until recently. It's a plug and play device, however windows is failing to recognize it, and thus making everything I have plugged into it unusable.

In the 'Device Status' box it says:
Code:
Windows has stopped this device because it has reported problems. 
(Code 43)A request for the USB device descriptor failed.
And in the 'Events' tab, there's a few listed, I'm not sure if they are much help:

Code:
Device not migrated

Device USB\VID_0000&PID_0002\6&1330e4d7&0&3 could not be migrated.
Last Device Instance Id: USB\VID_0000&PID_0001\6&3AE11B61&0&1
Class Guid: {36FC9E60-C465-11CF-8056-444553540000}
Location Path: 
Migration Rank: 0xF000FFFFFFFFF100
Present: falseStatus: 0xC0000719
Code:
Device configured (usb.inf)

Device USB\VID_0000&PID_0002\6&1330e4d7&0&3 was configured.
Driver Name: usb.inf
Class Guid: {36FC9E60-C465-11CF-8056-444553540000}Driver Date: 06/21/2006
Driver Version: 10.0.14393.0
Driver Provider: MicrosoftDriver 
Section: BADDEVICE.Dev.NTDriver Rank: 0xFF0000Matching 
Device Id: USB\DEVICE_DESCRIPTOR_FAILUREOutranked 
Drivers: usb.inf:USB\DEVICE_DESCRIPTOR_FAILURE:00FF2000
Device Updated: falseParent 
Device: USB\ROOT_HUB30\5&35f8b9e6&0&0
Code:
Device not started

Device USB\VID_0000&PID_0002\6&1330e4d7&0&3 had a problem starting.
Driver Name: usb.inf
Class Guid: {36FC9E60-C465-11CF-8056-444553540000}
Service: 
Lower Filters: 
Upper Filters: 
Problem: 0x2BProblem Status: 0x0


I've tried:
Restarting computer
Deleting the 'driver' in device manage and restarting
Force installed various different USB Hub drivers through windows
Uninstalling the driver and restarting
Altering USB power settings
Letting windows automatically update driver software
Scanning for hardware changed
Tried looking for a 'Power Management' tab in the properties menu - it's not there (because I am on desktop?)
Contacting D-Link support - the guy knew nothing