Ethernet doesn't have a valid IP configuration ... newb question

  1. Posts : 3
    Windows 8.1 and 10
       15 Nov 2016 #1

    Ethernet doesn't have a valid IP configuration ... newb question

    Hello. I have the Ethernet doesn't have a valid IP configuration problem which I've googled and discovered is common and well known, i.e., make sure the adapter is set to obtain the IP automatically, and if that fails update the drivers.

    However... I need help getting the drivers installed. I don't know where to get them from, or where to install them to.

    The computer that is not connecting either via ethernet or wifi is an Acer laptop running Win 10. I have a Lenovo running 8.1 that does connect, thus I must use the Lenovo to get the drivers, then transfer them to the Acer and install them.

    Can someone please tell me how to do this? Where do I get the driver files (specifically, how do I know which files I want) and then how to install them once I've transferred them to the Acer?

    Thank you
      My ComputerSystem Spec

  2.    15 Nov 2016 #2

    Provide make and model for the Acer laptop, so we can look up the network interfaces. Also might be nice to let us know if you're using wired Ethernet or WiFi on the Acer machine. If you can provide that info, we can get you headed in the right direction. HTH,

    PS: I keep an el cheapo StarTech USB 3.0 to GbE adapter around (Newegg: $22) for when NICs go south. You can plug it into most PCs (the drivers load automatically) and use a fast, simple, wired Internet connection to fix a machine that's having problems with its built-in network interfaces quickly and easily. In these days of Windows 10, I use it at least once a month!
      My ComputersSystem Spec

  3.    15 Nov 2016 #3

    We don't know it's a driver fault open a CMD prompt type ipconfig /all post results
      My ComputerSystem Spec

  4. Posts : 3
    Windows 8.1 and 10
    Thread Starter
       15 Nov 2016 #4

    Make is Acer, surely? It's an Acer Aspire. Don't know what other information would be useful. Serial number? CPU? Please don't think I'm being facetious.

    It will not connect via either ethernet or wifi, so I assume I need the drivers for both.

      My ComputerSystem Spec

  5.    15 Nov 2016 #5

    It's got to have a model number as well as the model name "Aspire" If I go to the Acer Laptops page I see at least 8 families of Aspire models, each of which probably has as many or more model numbers per family. These determine what's inside, and are needed to figure out what's potentially causing your problem.
    As for Samuria's post: he's right: go head and run ipconfig /all and post a screen cap of the output here (or save it to a file and let us see what's inside). It could be something related to your router or IP configuration. It's not necessarily a driver problem. I just have drivers on the brain today, and may have jumped to an erroneous conclusion.
      My ComputersSystem Spec

  6. Posts : 3
    Windows 8.1 and 10
    Thread Starter
       15 Nov 2016 #6

    Two screenshots of ipconfig /all. Bottom of the screen was off the page so I've copied it on the left for convenience. Hope it's legible!

    Working on the model name.
      My ComputerSystem Spec

  7.    15 Nov 2016 #7

    On phone so can't see all your image but it does show WiFi and network correct so it's not drivers we need to set a fixed IP are you sure DHCP is turned on on the router as it picks up the gateway but doesn't get an IP which could be no DHCP running on router
      My ComputerSystem Spec

  8.    15 Nov 2016 #8

    Lack of default gateway info (field is blank) indicates issues in communicating with your router/wireless access point. This is what you need to investigate and resolve to get back to work. Have you tried running the network troubleshooter? (Type "troubleshoot network" into Cortana/search box, and it will open right up). I bet it tells you something like "unable to communicate with network gateway" or similar. Try it, and let us know what happens.

    PS: It may end up being something as simple as resetting the router/WAP (powering it down, then powering it back up). Usually works for me when mine goes wonky... But wait, it's working for your Lenovo. So this may require rebooting your problem PC, or doing something with its IP stack (like a reset as explained in Network Adapters - Cleanup and Reset in Windows 10 - Windows 10 Forums).
      My ComputersSystem Spec


Related Threads
So... I just updated from win 7 to win 10, as I got it for free. All went smoothly, but there was no ethernet connection. I'm running a custom built pc, connected to my router via ethernet cable. At first windows detected the cable, but said:...
Hello, I'm about 4 hours deep into trying to fix this. I've followed several forum posts with similar issues, with no luck. I've been running windows 10 on my PC with my current hardware (including modem/router) for about a year now with no...
I've been working on this for over two hours now. I have wifi on laptop. In Windows 10 I can't access internet on PC with Ethernet. On the same computer I have a Linux Mint partition and ethernet connection is fine there 160Mbps. I've unplugged...
Where to start so to begin with my issues started when we got a new router. We had issues with the old one so we installed a new router and got it working fine WiFi worked alright but Ethernet would not connect it my computer when I ran the...
8 hours ago my computer was connected via Ethernet and functioning fine during online gaming. This morning approx. 4 hours ago I awoke to notice the computer updated and restarted during my sleep. Now the network icon has an exclamation mark and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:56.
Find Us