Unknown USB Device ( Device Descriptior Request Failed )

Page 1 of 4 123 ... LastLast

  1. Posts : 25
    Windows 10
       #1

    Unknown USB Device ( Device Descriptior Request Failed )


    Greetings folks

    I have a problem that bugs me for years, I never intentionally solved it, sometimes those errors disappears and all USB ports work fine, sometimes they do not. So anyone can help me please, it would be great.

    Some of my ports do not work all the time, I cannot identify a specific moment. Inside the Device Manager, Universal Serial Bus controllers, I get 1, 2 or more "Unknown USB Device ( Device Descriptior Request Failed )", sometimes more sometimes less.

    CPU: Intel Core i7 3770
    Motherboard: AsROCK H77 Pro4/MVP
    Windows 10 all available updates downloaded and installed as of today, and everyday. The problem appeared on Win 8 or 7, not sure when. So it's not necessarily Windows 10 specific. I ported it to 10.
    Here is what they look like:
    http://prntscr.com/d6rm6k

    Bios is up to date. Chipset drivers updated, various solution tried from googling, I even managed to make all USB ports stop working testing some of these solutions, I had to restore windows from a ghost image I had.

    It's like these USB ports remain suspended sometimes.

    Any advice on what to try? The most annoying part is that from the frontal USB ports some stop working randomly too.

    Thank you

    EDIT: The problem is the motherboard. The computer was checked at a computer service, and it seems the time has come for it to be buried.
    Last edited by Rostos; 26 Nov 2016 at 09:47.
      My Computer

  2. AndreTen's Avatar
    Posts : 20,644
    Windows 10 (Pro and Insider Pro)
       #2

    Hi Rostos and welcome to Ten Forums!

    I would recommend two utilities. Maybe they can reveal what's going on.

    USB Device tree viewer from Uwe Sieber and Nirsoft's USBDeview. They will give you info about connected devices..
      My Computers


  3. Posts : 25
    Windows 10
    Thread Starter
       #3

    Thank you. I did that, but it is all Chinese for me. I think it's time for a visit to a repair service. Problem is that the tower is heavy and big. I hate doing that.

    What I noticed it that some USB ports are not even powered now, I input something in them and it fails to even light up, and the problems are all related to 2.0 ports, all 3.0 work fine.

    Using what you gave me I tried to Restart or Remove those yellow ports, but either it does not work, or I get an Access Denied when trying to restart. Maybe there are physical problems.
      My Computer

  4. AndreTen's Avatar
    Posts : 20,644
    Windows 10 (Pro and Insider Pro)
       #4

    Usual culprits and solutions for such behavior are:
    - hardware. You are using kb/mouse combo, if I read your picture correctly. Try with other devices.
    - loose connections on motherboard. Open the case and check if connections are firm
    - disable "selective suspend" in power options
    - You checked for latest drivers, but check again - in device manager, select first USB host controller and uninstall it - proceed with other, then restart PC and it will reinstall them
    - run sfc /scannow from admin command prompt and check if there are any problems. If software problem is inherited from Windows 7 or 8, that would be important. Or even install Windows 10 over existing installation again (in-place upgrade...)

    If all fails, most probable cause would be motherboard. You can buy cheap USB 2 controller card and install it. Your USB 3 port works fine if I recall it - just select xHCI to smart auto in BIOS and USB 2 devices will be recognized at startup.

    Good luck.
      My Computers


  5. Posts : 25
    Windows 10
    Thread Starter
       #5

    1. I have an USB mouse, Bloody is the name, and a wireless keyboard ( it has an usb receiver, or whatever the name ), from Microsoft. The keyboard will soon be changed with a cabled one, I had enough of wireless keyboards or mice.

    2. I will try to do that tomorrow, I will check the motherboard schema. I am more accustomed to changing HDDs, installing a new cooler, RAM, the basics. There is a chance I moved something inside when doing that.

    3. Just did. I did that many months ago, but since I keep reverting to a fresh ghost each several months I sometimes forget to do that. Will go in my refresh folder instructions.

    4. Uninstalled the host controllers, restarted. The issues remain.

    5. I used sfc, it seems there is an opencl.dll that is not good and cannot be fixed. And when I said that the problem is inherited, I did not mean that this is an upgrade from Win 8 or 7. Windows 10 is installed from scratch on a formatted partition. . When I used to have windows 8 I had sometimes the same problems with the unrecognized stuff.

    Thank you for your advice.
      My Computer

  6. EdTittel's Avatar
    Posts : 3,752
    Windows 10
       #6

    opencl.dll is not the issue: it simply shows you've updated your Nvidia drivers and they're no longer the same as the built-in, default MS version of that file. It's only a problem for the DISM scanner; it's actually not a problem for your PC. You can fix that if you want, but it sounds like you have more important fish to fry. I'd keep trying the do-it-yourself route before taking the machine into the shop, especially if you don't have another PC or laptop to use while you're waiting to get your desktop back.
    HTH,
    --Ed--
      My Computers



  7. Posts : 25
    Windows 10
    Thread Starter
       #7

    Thanks for the input. I am still doing that, looking for possible solutions, but I suspect something physical is happening.

    Now the USB 3 ports have problems too. Like when using the USB mouse sometimes it freezes for half a second. I changed to the frontal USB 3 port that seems to be unaffected, and I added a 4 usb splitter to it. Things are working fine, but all other USB2 or USB3 either do not work at all, or in the case of the 2 USB3 ports on the back of the case they work, but they have glitches.

    I tried checking the motherboard, but most of the USBs are built in, so I cannot check if they are fitted properly. They do have power, but that's it, whatever I insert into them, it's not working.
      My Computer

  8. EdTittel's Avatar
    Posts : 3,752
    Windows 10
       #8

    My guess is that some of your USB ports are tied to the basic chipset, while others run from third party circuitry (often Renesas or VIA, in my experience). The Intel and AMD USB 3 drivers are pretty solid, but it's hit or miss with the third-party providers. My follow-on guess, if you don't mind me piling one on top of the other, is that you don't have a physical connection problem but rather, a USB 3 hub or port driver problem. If your ASRock H77 is like my Z170 board, the built-in H77 USB 3 controllers from Intel are fine, and the add-on ADMedia controllers are what's giving you problems. See if you can figure out which ports go where (Nirsoft's USBDeview is reasonably good at this, Microsoft's USB View provides the best view of physical ports) and maybe by shifting things around you can improve them.
    HTH,
    --Ed--
      My Computers


  9. Posts : 25
    Windows 10
    Thread Starter
       #9

    Not sure if I am doing it right, but if I am guessing, the selected 4 ports are the frontal 4 USB slots from which only one, which is USB 3, is working, while the other 3 do not recognize devices.

    http://prntscr.com/d8fcan

    I am not sure what I have to do.
      My Computer

  10. CountMike's Avatar
    Posts : 16,647
    W10 Insider + Linux
       #10

    Did you set USB as Legacy type in BIOS ?
      My Computers


 
Page 1 of 4 123 ... LastLast

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 19:28.
Find Us




Windows 10 Forums