USB3 Ports not working correctly after Win 10 Anniversary Ed Update

  1.    08 Nov 2016 #1

    USB3 Ports not working correctly after Win 10 Anniversary Ed Update


    I have a problem with my USB3 ports. Prior to upgrading to the Anniversary edition of Windows 10, both my USB2 and USB3 ports worked fine. If I plugged in my external USB3 drive into a USB2 port, the white light on the drive illuminated and the drive operated using USB2. If I plugged the same drive into a USB3 port, then the blue light on the drive illuminated and the drive operated at the higher speed of USB3.

    Having updated my system to the Anniversary edition of Windows 10, I can only make the external drive operate on USB3 if it is plugged into a USB3 port when I power the PC up, or reboot. If I power up the PC with the drive disconnected and then plug it into a USB3 port at a later time, then it only operates as a USB2 device.

    Can anyone suggest why the USB3 drivers only seem to load when the PC powers up with a USB 3 device connected??

      My ComputerSystem Spec

  2.    10 Nov 2016 #2

    USB3 Ports not Working

    Hi Guys,

    I have been playing around with this some more and it definitely looks like the USB3 drivers are not being loaded at power-up unless a USB3 device is connected at the time. Once the drivers have loaded. I can disconnect and move my USB3 device to any other USB3 port and it works.

    Can anyone suggest a reason why these drivers are only being loaded if a device is connected at power-up and give my any clues on how to make them load by default as they did before the Anniversary upgrade??

      My ComputerSystem Spec

  3.    10 Nov 2016 #3

    I can suggest a reason, but it may not be a valid one: device enumeration occurs during boot-up, and drivers get loaded to match devices found. In your case, for some unfathomable reason, the system is not detecting USB 3 from the ports themselves, but has to find a device for them to register and be loaded. Here's a highly relevant snippet from the board layout info in the manual:

    Click image for larger version. 

Name:	ga-usb-ports.jpg 
Views:	24 
Size:	53.9 KB 
ID:	109558

    It will be interesting for you to determine if the ports you're talking about come from the Intel Chipset or the added VIA USB 3 hubs. I've seen weird issues with VIA hubs before, but the Intel stuff is usually pretty solid. Sorry to say, though, I'm unfamiliar with this particular Gigabyte mobo, though.
      My ComputersSystem Spec

  4. Posts : 245
    Server 2012 R2 w/SCCM and Windows 10 x64 v1803
       10 Nov 2016 #4

    It's been awhile since reading a USB 3 overview but as I recall it, USB 3 identification begins in the initial hardware handshake that occurs between the Root hub on the m/b and the downstream USB device. This h/w signalling on the USB bus cable indicates when the data bus and both ends are ready and able start send/receive data. A USB 3 device indicates bus speed by an added signal on one of the wires that makeup the bus. That's part of how they accomplish backward compatibility. USB 3 sends a signal during the handshake a USB 2 device does not.

    Only when the hardware handshake is completed successfully, the device sends (and Windows expects to read) device data. The USB device sends its Descriptors (burned into its firmware) which identify the device (so windows can find a suitable driver) and also has a USB 3 flag set. (By the way, when the hardware handshake fails is when Windows gives that familiar "Unrecognized USB Device" message. Windows knows a device is out there but the h/w handshake sequence failed so Windows can't receive Windows identification data. The device is "unrecognized")

    So I'd reinstall the motherboard chipset drivers. Also check if there any newer release. Also check if there's a BIOS update.
      My ComputerSystem Spec

  5.    11 Nov 2016 #5

    I agree with CG's explanation and analysis. I'm guessing it's most like the VIA drivers that are causing your difficulties, though.
    Good luck!
      My ComputersSystem Spec

  6.    15 Nov 2016 #6

    USB3 Ports Not Working

    Hi Guys,

    Many thanks for replying. I took the covers off of the PC this morning, but it is impossible to work out which ports are direct from the Z77 and which ports come off of the "via" hub. The manual for the motherboard does not give enough info. Anyway, I tried a USB 3 device on all of the available ports with the same results, so I guess that until I can find an updated driver from Gigabyte, I will just have to leave a USB3 device plugged in all of the time.

    Anyway, many thanks for the ideas.......

      My ComputerSystem Spec


Related Threads
Anytime I restart my computer or the power goes off it doesn't restart correctly. Basically, there is a black screen with a spinning circle with dots and it will stay that way for hours. The only solution I've found is to insert the windows 10...
Hello folks, I cloned my C drive and updated to windows 10 a week ago. Yesterday SATA ports 2 and 3 stopped working (on MOBO gigabyte GA-Z77M-D3H-MVP). I think it is a windows 10 problem because I have: swapped my drives between SATA ports....
Hello, I recently received an update to my ASUS Vivobook laptop which was running windows 10, quite flawlessly I might add. After the update, my touch pad stopped accepting multi-touch and my USB ports stopped recognizing any devices including my...
Okay, I upgraded from Windows 7 Pro 64Bit to windows 10 Pro 64bit. Everything ran smooth and fine. But my USB3 ports mounted on a Logilink product (Art. PC0058) PCI ExpressCard 2xUSB3 work only as power supply. The error indicated by...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:03.
Find Us