The Intel Atom Z3740 is supported by a System on Chip (SOC), typically used on tablets and smaller laptops such as the Asus Transformer range (and many others). The devices were shipped with Windows 8.1 and included a webcam which worked fine on 8.1/32.

However on upgrading to Win 10/32, there have been problems in getting the webcam to work. It is surprising that neither Intel nor Microsoft have addressed the issue.

I have undertaken some investigations to this, but as far as I am able to determine the issue has not been fully addressed.

I have an Asus t100ta with 32gb using windows 32 bit. On upgrading to Win 10, the imaging device was defined as Intel AVstream - I tried 3 drivers none of which recognised the webcam.

On deleting the AVsteam drivers the system found the Intel Imaging Signal Processor 2400 drivers.
There were three 2400 drivers: 01082014 didn't work removed
603.9600.2102.45420 07072014 didn't work removed
603.9600.1948.31252 28012013 identifies the camera, but with issues.

The issues in version 31252 both in Skype and the camera app is over-zoomed with poor definition.
As the issue is on the camera app and Skype, I don't believe it is an issue with Skype as some would contend (was fine in 8.1 anyway).

So in summary we have had some partial success with a 2400 device driver (from SOC ver10e).

Can anyone definitively through some light on this as there are many folks on different systems having issues with win 10 here?