1. Joined : Nov 2016
    Posts : 3
    Windows 10 Pro, build 1607
       05 Nov 2016 #1

    USB device - Windows install old driver for Canon scanner (Code 43)


    I recently updated to the new Win 10 build on two computers. After installation the USB Scanner (Canon 5600F) is not recognised, it worked fine in the previous build of Win 10 on both units. Windows has installed an old driver (dated 2006), but when I try to update to Canon's own driver (dated 2015), windows tells me the "best driver for this unit is installed" and refuses to update it. Details below - can anyone help please?

    The error message I get in device manager is

    "Windows has stopped this device because it has reported problems. (Code 43)A request for the USB device descriptor failed."

    The events are:

    Device USB\VID_0000&PID_0002\7&13f2a09a&0&1 was configured.Driver Name: usb.infClass Guid: {36FC9E60-C465-11CF-8056-444553540000}Driver Date: 06/21/2006Driver Version: 10.0.14393.0Driver Provider: MicrosoftDriver Section: BADDEVICE.Dev.NTDriver Rank: 0xFF0000Matching Device Id: USB\DEVICE_DESCRIPTOR_FAILUREOutranked Drivers: usb.inf:USB\DEVICE_DESCRIPTOR_FAILURE:00FF2000Device Updated: falseParent Device: USB\VID_0409&PID_0058\6&3c69614&0&2
      My System SpecsSystem Spec


  2. Joined : Aug 2015
    Wales
    Posts : 164
    Win 10 Pro 64Bit
       05 Nov 2016 #2

    Hi

    Have you tried to roll back the driver under device manager>"printer name">properties?

    Regards
    UKMedia
      My System SpecsSystem Spec


  3. Joined : Nov 2016
    Posts : 3
    Windows 10 Pro, build 1607
       05 Nov 2016 #3

    Hi,

    That's not an option - the button is greyed out so it doesn't think there is a previous version available.

    Regards
      My System SpecsSystem Spec


  4. Joined : Aug 2015
    Wales
    Posts : 164
    Win 10 Pro 64Bit
       05 Nov 2016 #4

    Okay. Can you uninstall the existing driver within Device Manager and then install the one from the Cannon web site?

    Regards
    UKMedia
      My System SpecsSystem Spec


  5. Joined : Nov 2016
    Posts : 3
    Windows 10 Pro, build 1607
       05 Nov 2016 #5

    Thanks for the effort, but the conclusion is that the scanner is bust - had MS support on chat for about an hour and a half and tried also the scanner on win 7 and on Linux, with similar issue, so the conclusion is I need a new scanner. Thanks for the help though.

    Regards
      My System SpecsSystem Spec


  6. Joined : Apr 2015
    Posts : 44
    Windows 10
       05 Nov 2016 #6

    When you connect a USB Plug and play device, the PnP device sends info burned into its firmware by its manufacturer. Windows uses this info to identify the device and find a driver.

    The string in your data that USB\VID_0000 shows VID (which is vendor ID). Valid VID value is non-zero. Windows fills in a the all zero value when it can't read device data to know what it really is The problem
    > Check your computer maker website. Reinstall the latest chipset drivers
    > Check if there's a BIOS update
    > Try turning on the Canon before you connect to USB port as well as trying it before power on. Sometimes is a power related issue

    /*EDIT*/
    Just saw last post. Yeah.. if scanner isn't recognized on other machines either, then the problem is on scanner side.
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
BSOD 'Thread stuck in device driver' error code 0x000000EA
My system freezes for a few seconds and then BSOD gets displayed showing 'Thread stuck in device driver'. This happens randomly. I updated the BIOS version but the problem still persists. All the other drivers are updated. I am using AMD E1-6010 APU...
BSOD Crashes and Debugging
Bluetooth speaker driver install fails, device manager error code 10
Hi, On Windows 8. 1, I had no issues with this speaker. It's a JBL Charge. After upgrading to 10 it worked fine until a reboot when it failed to connect (it pairs, but won't connect, and the speaker doesn't appear as an audio-out option in Sound...
Drivers and Hardware
Solved Canon MP240 Scanner No Driver (Unsupported)
My canon printer isn't supported by Windows 10. Troubleshooting it just tells me there is no drivers. It prints fine, but i cannot use the scanner. Is there any way i can get the scanner to work, more specifically in gIMP?
Drivers and Hardware
Canon MF4570DN Scanner Drivers Fail to Install
Since I installed Windows 10, my scanner suddenly failed to function, I'd get an error that it couldn't find the scanner. I have a networked Canon MF4570DN printer/scanner. I went to Canon and downloaded what claims to be the Windows 10...
Drivers and Hardware
Install an HP Scanjet 5300c Scanner on Windows 10
Just asking: How can I do this (using the USB thing) on Windows 10 if I even can?
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:07.
Find Us
Twitter Facebook Google+



Windows 10 Forums