Windows 10: I cannot install Logitech Setpoint - just recently Solved

  1.    01 Nov 2016 #1

    I cannot install Logitech Setpoint - just recently

    Hi all,
    I'm desperate here. I've been using Logitech Setpoint for years. That is software that allows you to customize your Logitech Mouse or Keyboard. I've had my share of problems with Setpoint, but this is a new one.
    I had a drive failure, and I just got Windows 10 Pro 64bit up and running last month, then I got the Anniversary Upgrade. I've been able to install all of my programs so far, except Setpoint. I installed the Logitech Unify software, and it paired with my Performance MX mouse. But when I try to install Setpoint, I get a popup message that says "The Setpoint Installer has stopped" .

    I've tried the latest version, and the two previous. Same thing. I've tried running it as Administrator, same thing.

    I almost have to asssume it is related to the AU on Windows 10. My laptop is running Setpoint, but it's still running the Windows 10 Pro 1511 version. I've posted on the Logitech forum, but don't know if I'll learn anything - as I really think it's a Windows issue.

    Any ideas? I love this mouse, but I can't program anything without the Logitech Setpoint software. Thanks for any help.
      My ComputerSystem Spec

  2. Posts : 21,027
    Win10 Pro, Win10 Pro N, Win10 Home, Win10 Pro Insider Fast Ring, Windows 8.1 Pro, Ubuntu
       01 Nov 2016 #2

    It could be a security certificate problem.
    Microsoft has tightened the security screws to protect users, and the people who communicate with them online, by requiring updated security certification for drivers and other software the runs at boot.

    Logitech has really slept this one out.
    In Firefox for example, you cannot install the Set Point add-on any more because the certificate hasn't been updated.

    You could try turning off secure boot in BIOS and then see if you can install it.
    Be warned, turning off secure boot leaves you open for rootkit malware attacks.
    So if it only works when secure boot is turned off, and not when you turn it back on(if it lets you install), you have a serious decision to make: security or comfort.
      My ComputersSystem Spec

  3.    01 Nov 2016 #3

    Thanks Cliff,
    Good point. And I haven't had to go into BIOS for so long, I don't remember if I have secure boot set or not. Wish me luck.

      My ComputerSystem Spec

  4. Posts : 21,027
    Win10 Pro, Win10 Pro N, Win10 Home, Win10 Pro Insider Fast Ring, Windows 8.1 Pro, Ubuntu
       01 Nov 2016 #4

    hooked said: View Post
    Thanks Cliff,
    Good point. And I haven't had to go into BIOS for so long, I don't remember if I have secure boot set or not. Wish me luck.

    Good luck, I like set point too for my surfing mouse, so I have a good idea how you feel.
      My ComputersSystem Spec

  5. Posts : 3,261
    10.5 Home 1803 x64
       01 Nov 2016 #5

    I have installed Setpoint on clean install of AU without any problems. It might be your security blocking it.
    Try to temporarily disable your AV. You might try a cleanup (rebuild WMI, WinSxS, etc), run WC.bat as admin.
    I cannot install Logitech Setpoint - just recently Attached Files
    • File Type: bat WC.bat (462 Bytes, 10 views)
      My ComputerSystem Spec

  6.    01 Nov 2016 #6

    I'm using Logitech Setpoint version 6.65.62 on Windows 8.1 for a Logitech Zone Touch Mouse T400. I installed it about a week ago with no problems. So the driver does work on Windows 8.1. I have both Administrator and standard user accounts on my computer and I installed it from the Administrator account.
      My ComputerSystem Spec

  7.    01 Nov 2016 #7

    Thanks for all your input. Logitech forums actually got my answer. He said to disable all startup svcs (except msft) and disable all Startup apps then install it.
    Worked like a champ.
    The thing that had be confused, is my laptop which is still on Windows 1511, it's running setpoint. I made a restore point and uninstalled setpoint, reinstalled it... no problem. So I was convinced it was AU. And I had my AV disabled from the first time I
    tried installing.??
      My ComputerSystem Spec


Related Threads
Latest Logitech SetPoint Software in Drivers and Hardware
Latest Logitech SetPoint Released Date: May 23, 2018 Software Version: 6.68.250 OS supported: Windows 7, Windows 8, Windows 10 Updated Description: Bug fixes
Did a clean Windows 10 install yesterday, and installed the latest Logitech setpoint. After the installation it stated that I can edit settings for my mouse or keyboard by clicking the setpoint tile in the start menu. Well it is not there, and I...
Hello, On my old PC running W7, I used it with a Logitech MK 300 wireless Keyboard and with atheir Wireless Mouse. Worked just fine. Would like to use them both with my new W10 PC. The Wireless Mouse works just fine. I cannot get the...
Version SetPoint6.67.83_64 (64bit) Now if they could fix smooth scrolling crashing in Chrome, that would be something. :)
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:34.
Find Us