1. Joined : Apr 2016
    Posts : 23
    Windows 10 Home
       26 Oct 2016 #1

    USB Drives plugged in but No Safely Remove Icon in Tray, and


    ....no drives listed in Hardware List.

    When I plug USB drives in, the Safely Remove Hardware icon does not appear in in system tray (its not hidden either)

    First, I went to Settings > Personalization > Taskbar > Select which Icons Appear on the Taskbar...



    .. and found it was already on

    Next I tried using the solution in this post...

    Solved No safely remove icon in tray any more after Windows 10 Anniversary up - Windows 10 Forums

    ...making a shortcut from "rundll32 shell32.dll,Control_RunDLL hotplug.dll", but when I run the shortcut, there are no devices listed...



    (in this screenshot, you can see two USB drives in the Explorer window in the BG but nothing listed in the panel. )

    NOTE: They are listed in Disk Management and in the Device Manager under Disk Drives, and they function just fine..
    I think the Safely Remove Hardware icon is not appearing because despite being detected and showing in Explorer, Device Manager and Disk Management, its not being listed in this panel for some reason.


    NOTE2: I recently installed a new motherboard.

    ASUS B150M-A
    CPU Intel Core i5 - 6500 (3.2 GHz)
    Mem 4096 MB (DDR4 - 2133)

    I am 100% sure it was working before that, but I cannot say for sure if it was still working after that.
    A friend suggested that it might be a setting in BIOS, but I have looked through it and nothing stands out.

    Any suggestions would be welcome.


    ETA: this is not the system listed in my System Specs page. That is another computer which I still have.
      My System SpecsSystem Spec


  2. Joined : Apr 2016
    Posts : 23
    Windows 10 Home
       29 Oct 2016 #2

    No-one can offer any suggestions?
      My System SpecsSystem Spec


  3. Joined : Jul 2014
    Serbia
    Posts : 6,518
    All kinds
       30 Oct 2016 #3

    Are they shown as Removable device in Disk Management ?
    In Device manager > Policies > Removal policy, are they set for Quick removal ?
      My System SpecsSystem Spec


  4. Joined : Apr 2016
    Posts : 23
    Windows 10 Home
       31 Oct 2016 #4

    CountMike said: View Post
    Are they shown as Removable device in Disk Management ?
    In Disk Management they are listed as "Removable Drive" in the box on the left

    In Device Manager
    - under "Disk Drives" they are listed as "USB Devices"
    -
    under "USB Serial Bus Controllers" they are listed as "USB Mass Storage devices"
    - under "Portable Deivces" they are listed under their drive letter

    CountMike said: View Post
    In Device manager > Policies > Removal policy, are they set for Quick removal ?
    I do not appear to have a "Policies" option in my Device Manager
      My System SpecsSystem Spec


  5. Joined : Jul 2014
    Serbia
    Posts : 6,518
    All kinds
       31 Oct 2016 #5

    Sorry, missed one step Device manager > Disk drives (properties for particular disk) > Policies > Removal policy.
      My System SpecsSystem Spec


  6. Joined : Apr 2016
    Posts : 23
    Windows 10 Home
       31 Oct 2016 #6

    When I go to Device Manager>Disk drives and click on the Properties for each drive, this is what I get


    This is the USB Stick - Drive G:
    No "Policies" tab


    This is a Portable HDD - Drive H:
    No "Policies" tab


    This is a Portable HDD - Drive I:
    It has a "Policies" tab (shown) but nothing about a Removal Policy
      My System SpecsSystem Spec


  7. Joined : Jul 2014
    Serbia
    Posts : 6,518
    All kinds
       31 Oct 2016 #7

    This is what I get for all USB sticks:
    Click image for larger version. 

Name:	disks USB 1.JPG 
Views:	1 
Size:	119.6 KB 
ID:	108317
      My System SpecsSystem Spec


  8. Joined : Apr 2016
    Posts : 23
    Windows 10 Home
       31 Oct 2016 #8

    I have another computer at work that runs Windows 10. I will check to see what it says when I get there.

    ETA: Right, so I have done this.

    I brought with me the actual USB stick (which gave me no Policies tab at all) and the Silicon Power 1TB drive that did give me a Policies tab but with no Removal Policy option panel. I did this to eliminate any chance that the problem might lie with the stick and/or the HDD.

    The computer at work is the same version of Windows 10 Home

    The USB stick does give me the Policies tab with the Removal Policy panel

    The USB HDD does give me the Policies tab with the Removal Policy panel AND the Write-caching Policy panel

    I have another Seagate USB HDD at work, and it gives me both panels on the Polcies tab. I then checked with several other USB Sticks I have at work, and every one of them gives me just the Removal Policy panel on the Policies tab.

    I think we have isolated the issue to that missing Removal Policy panel.

    So, what creates that missing panel? Could this be something missing in the registry?
    Last edited by smartcooky; 31 Oct 2016 at 16:01.
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Cannot Safely Remove External Drives
Hello all, In recent weeks, it has become impossible for me to safely remove my external drives. (Mostly, I use Western Digital Passports, Passport Ultras, etc). I am using Windows 10. I close all of my programs and folders. I get the...
Drivers and Hardware
Solved Safely Remove Hardware icon with nothing plugged in, shows 3 dots(...)
I installed Windows 10 on my desktop and the safely remove hardware icon is always there even when nothing is plugged in. When nothing's plugged in, clicking the icon just shows 3 dots (...) and a link to open the Hardware and Devices window (or...
Drivers and Hardware
Solved No safely remove icon in tray any more after Windows 10 Anniversary up
It has been a week or so after I updated Windows 10 on my Dell E4300 to the Anniversary edition. It has not been a smooth update, many DCOM errors mainly to permission problems and apparently from system user accounts being changed after the update,...
Drivers and Hardware
question about shuting down and or safely remove ext usb hard drives
general question is when shutting down the screen show what ever app is preventing shut down (why can't windows just spell out write there what app is hanging) same goes for safely removing external USB hard drives (something is still active...
Drivers and Hardware
Solved Hide Windows Remove USB Safely Tray Icon.
Does someone knows a way to hide it for good? Not disabling it, because that could cause some trouble, just that doesn't show in the tray? A .reg file would be awesome. I want this for 2 reasons: First, I don't use it, I use USB Disk Ejector; and...
Customization
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:33.
Find Us
Twitter Facebook Google+



Windows 10 Forums