Windows 10: Unable to access all files on 4TB GPT internal drive turned external Solved


  1. Posts : 9
    Windows 10 Home x64
       24 Oct 2016 #1

    Unable to access all files on 4TB GPT internal drive turned external


    Hi all!

    I have been running two 3.5" hard drives internally in my stationary computer for some time now, one is 2TB and the other is 4TB. As I have recently switched to a laptop setup I wanted to bring these two drives with me for storage, so I took out the 4TB and put it in an external case. The drive was used a single partition GPT in order to gain access to all 4TB.

    Now however, I am able to access it when connected through USB, but some files are not accessible. I cannot open them, and when I try to copy them I get Error 0x80070057: parameter is invalid. Remaining files on the drive work fine. I am trying to access the external drive on a Win10 Home x64 laptop (Lenovo Y700)

    I did some digging, and in disk management in windows the drive shows up just fine as being one volume, 3,63TB, however in MiniTool PartitionWizard only 2TB of the drive show up as being a volume, and the remaining 2TB show up as being unallocated. I assume that this is somehow connected to the GPT format of the drive.

    Does anyone have any clues as to what might fix this and get me access to my files? PartitionWizard has an option to extend the volume into the unallocated space, but this seems exceedingly dumb to try as I'll probably lose the files for good then.
      My ComputerSystem Spec


  2. Posts : 9
    Windows 10 Home x64
    Thread Starter
       24 Oct 2016 #2

    Click image for larger version. 

Name:	1.jpg 
Views:	2 
Size:	18.1 KB 
ID:	107357Click image for larger version. 

Name:	2.jpg 
Views:	2 
Size:	21.1 KB 
ID:	107358
      My ComputerSystem Spec


  3. Posts : 2,034
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       24 Oct 2016 #3

    Not all external enclosure interface support large capacity HD. You might have to get a new one that supports large capacity. Make sure to read the spec before buying it.
      My ComputerSystem Spec


  4. Posts : 9
    Windows 10 Home x64
    Thread Starter
       24 Oct 2016 #4

    I had a look at the specs of my enclosure just 5 minutes ago (took a while to find, it's a very old one) and it does seem it only supports 2TB hard drives, thanks a lot!
      My ComputerSystem Spec

  5.    24 Oct 2016 #5

    I'd check if the Enclosure has a newer Firmware available before buying a new one , but I think TopGun is right about 4TB support.

    I am using this 4 Bay one...
    https://www.amazon.com/Mediasonic-HF.../dp/B003X26VV4
      My ComputerSystem Spec


  6. Posts : 9
    Windows 10 Home x64
    Thread Starter
       25 Oct 2016 #6

    The enclosure has long since been removed from the manufacturers website, so I've given up hope of solving it this way.
    I've had a look at the Mediasonic enclosure, sadly most brands are not sold in my country (Denmark) and I am stuck with Raidsonic if I want anything with more than one bay. So far it looks like I'm going with
    Icy Box IB-3620U3 External 2 Bay JBOD System for 3.5 inch SATA I/II/III HDD: Amazon.co.uk: Computers Accessories
    Despite peoples complains about noise, it seems to be my best option.
      My ComputerSystem Spec

  7.    25 Oct 2016 #7

    Lots of recent threads mention problems with dropped USB connections and data losses on Icy Dock units. User "Rivre" has been posting a great deal about this brand lately and just announced his decision to switch out Icy Dock in favor of MediaSonic. You two should talk: here's a search on his recent postings.
    HTH,
    --Ed--

    Here's a direct link to that thread: Looking for a 4-bay USB 3.0 external HDD enclosure - Windows 10 Forums.
      My ComputerSystem Spec


 

Related Threads
Unable to access external USB Drives! in Drivers and Hardware
Hi I recently upgraded my PC to windows 10 and every since have been unable to access any USB external drive. The laptop picks up the drives and acknowledges that they are there and working but they do not appear in file explorer. I have...
So here's what happened. I've decided to make my 1TB WD external HDD to aninternal one, I connected it internally using SATA, booted up Windows, and found it wasn't displayed in my computer. I tried to assign a drive letter and initialize it,...
Dear Sir/Madame, I was moving video files (AVI) from an external backup drive (WD Element) to another external backup drive (Seagate expansion) after having moved another video file from my laptop (Acer) to that Seagate external drive. The night...
The power went out while doing a Windows 10 update. I purchased a USB to SATA connector, connected it to another Windows 10 PC's USB port. The external hard drive that I removed from my other PC is not showing in Windows File Manager.
I have a Toshiba 2TB Canvio USB 3.0 Desktop Hard Drive, it was working yesterday but I am now having problems with accessing it today. I connected it today and in my computer it shows up as Local Disk (G:), when I click onto it to try and access it...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:16.
Find Us