Windows 10: Cannot Safely Remove External Drives

Page 5 of 6 FirstFirst ... 3456 LastLast
  1.    20 Feb 2016 #41

    thats what I always do, but when I click on the safely remove icon, I do not get any indication it is now safe to remove the device, which is typical.
      My ComputerSystem Spec

  2.    24 Apr 2016 #42

    Don't want to give my hardware specifications for privacy reasons, but I've found a solution for some users. I was having the same issue i.e. not being able to disconnect USB media, particularly storage devices. Here is what worked for me:
    • Open the Disk Management utility by right-clicking the windows icon (other other various methods)
    • Navigate to your external USB storage device
    • Right-click the disk and there should be an option to take the drive "offline."
    • Now you can eject your storage device from the little application in your "hidden icons" menu on the taskbar.
    • Bam - Presto - Alakazam! You can safely remove your device.


    Best guess at what's going on here is, as suggested in earlier posts on this thread, there's some kind of web-app like a cloud service or some other nonsense Microsoft's created that's keeping the read/write channels open for the device. Anyway, will work for at least some Windows 10 users.

    Wish you all much success -- cheers.
      My ComputerSystem Spec

  3.    26 Oct 2016 #43

    For me, it was Windows Defender. I turned off "Real time protection", and I was able to safely remove USB device without the in-use message.
      My ComputerSystem Spec

  4.    26 Oct 2016 #44

    Mine is off as well, but that did not resolve it for me,,,
      My ComputerSystem Spec

  5.    22 Dec 2016 #45

    I have had this issue from the beginning of Win10 -predominantly a WD MyBook but a smaller WD would give that message and never be available for disconnect.
    I use the Everything search software which can be a service as well as configured to run at start up within its options. An icon will appear in the ^hidden icons after first use.
    I went into the Everything options and removed the choice to be available at start up since being a running service seemed to a double action. The icon now does not appear in that task notification area.
    For the first time since Win10 was born the external drives immediately do the correct signal and can be disconnected.
    IF the system search is the main tool then it might be that indexing needs to be turned off for external drives
      My ComputerSystem Spec

  6.    22 Dec 2016 #46

    Thanks for the tip, I only read though what you said real quick, so I did not digest it just yet but will give it a go soon and report back,,, thank you kindly!
      My ComputerSystem Spec

  7.    22 Dec 2016 #47

    Well, I have been living with this since the beginning and the pop up message does say something is accesing the drive but Taskmanager does not display activity. At least my situation has progressed from the total shut down being interrupted and a restart would occur because an external was plugged in during the early Win10 versions.
    I don't use the Win10 search and I have attempted to cancel its indexing but Everywhere indexes and likely the recent backup files I put on the external...or whatever...is being noted by that search index.
    I don't really have a scientific proof; it was just by chance that removing the double configuration because I didn't need it in that pop up box produced consistent 'safe to remove' signals. Its the first repeatable performance since July 2014. At least, it has worked for a week at this point.
      My ComputerSystem Spec


  8. Posts : 31
    Windows 7 and Windows 10
       03 Mar 2017 #48

    Going into Services and restarting the Server service and/or the Computer Browser service has more often than not allowed the Safely Remove option to then work from the system tray for me. I don't know why it works, and I don't even know if it's safe to do, I just know that it seems to solve the problem and I've never had any problems caused by it. Btw, it's really annoying that Microsoft can't just solve this problem properly already, as it's been affecting me and others since at least Windows 7.
      My ComputerSystem Spec

  9.    03 Apr 2017 #49

    WD My Book Can not be removed.


    I shut down the Task Manager, now Safely Remove USB Drive works on WD My Book. I could always remove USB Drives.
      My ComputerSystem Spec

  10.    15 Apr 2017 #50

    bobjohn39 said: View Post
    I shut down the Task Manager, now Safely Remove USB Drive works on WD My Book. I could always remove USB Drives.

    Same situation here... on my Windows 10 machine, thumb drives could always be safely removed by right-mouse clicking Eject from Windows Explorer.

    However, WD Passport drives - and other mass storage devices - do not have the right-mouse click eject option available. So I would just use the Safely Remove Hardware and Eject Media icon, usually found in the Taskbar's Show Hidden Icons whenever a device was connected.

    Then all of a sudden, I started getting the 'Problem Ejecting USB Mass Storage Device' alert during Passport ejection. Tracked it down to the fact that I recently began auto-launching Task Manager, which apparently maintains a process thread with mass storage devices and consequently throws the error alert.

    I shut down Task Manager and boom... no longer receive any alerts during mass storage device removal.

    BTW, running Task Manager has no impact on safely ejecting USB thumb drives.
      My ComputerSystem Spec


 
Page 5 of 6 FirstFirst ... 3456 LastLast

Related Threads
How to Add or Remove Duplicate Drives in Navigation Pane of File Explorer in Windows 10 By default, all removable drives are shown separately in the navigation pane of File Explorer in addition to being shown under This PC in the navigation pane....
Hello, My wife is currently using build 10130, and is trying to use her SATA HDD (which was her 2nd HDD) externally, with a SATA to USB adapter. However, on plugging the HDD in, all that shows as new in Devices and Printers is the following "USB...
Solved Freezing external hard drives in Drivers and Hardware
I've been trying to transfer files to several external hard drives of mine in order to clear up space on my HDD, however every time I do begin a transfer, it will only do so for about 2-3 seconds, and then the transfer rate will drop rapidly until...
Solved Can't format external USB drive. in Drivers and Hardware
I am trying to format 2 partitions on an external 1TB USB3 drive. I had 2 ExFat partitions (partitions 6 and 7) which I have deleted and created 2 new ones using diskpart which I want to format NTFS. When I try to format them using disk...
How to safely remove W10? in Installation and Upgrade
I installed W10 in a E: partition and after trying it I prefer to remove it. I had boot problems lately in this laptop after formating and deleting the partition as I have always done to get rid of some testing OS. It didn't boot at all and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:45.
Find Us