Windows 10: Insert a disk... Oh yeah how many times ?

  1.    20 Oct 2016 #1

    Insert a disk... Oh yeah how many times ?

    Bloody Windows 10.. sorry but I hate the thing and here's one reason why.

    I put a CD in and close the tray.

    Windows brings up a dialog:

    Inset a disk
    Please insert a disk into Drive I:
    Help me choose a Disk (what nonsense is this LOL ??)

    and opens the drive.

    You can repeat the above until you go mad , or move back to the XP computer which works perfectly.
    A Win10 reboot *may* fix the problem temporarily.

    If I have EAC open, it will list the tracks and you've almost ready to go, but up comes that stupid dialog again.

    Is there any way to get it to bugger off?

    Thanks... and sorry to be so emphatic !
      My ComputerSystem Spec

  2. Berton's Avatar
    Posts : 5,275
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       20 Oct 2016 #2

    Have you tried changing the data cable between the ODD and the motherboard? Could be either a SATA or a PATA type.
    Have you tried a different ODD? Could be it is losing communication with the motherboard.
    Did you have WinXP on that exact computer/hardware setup? If so did you get the proper Win10 drivers for the motherboard? Seldom will WinXP hardware drivers work properly with Win10.
    Adding to the issue, based upon the 8GB RAM, is that you are running the 64-bit version of Win10 while only the Pro version of WinXP was available as 64-bit and wasn't in much use by consumers as it was so new at the time there weren't as many 64-bit versions of software.
    Nearly all hardware drivers have to be 64-bit for 64-bit versions of Windows or 32-bit for 32-bit versions of Windows [or any other Operating System].
    Another possibility is the drive doesn't like a particular brand of discs, might try something more mainstream such as TDK, Sony, Verbatim, etc. The discs I've had the most issues with were the colored Memorex CDs and the Memorex Music CDs. The most reliable CDs for burning I've used were the DuraBrand from Wal*Mart and Kodak, DuraBrand was dropped and I don't see the Kodak in my area.
      My ComputerSystem Spec

  3.    20 Oct 2016 #3

    Is that actually drive I: ?
      My ComputerSystem Spec

  4.    20 Oct 2016 #4

    Drive I is a Pioneer BDRW BDR 207D and Drive K a Plextor PX-L890SA. Both have had the same problem.

    Are you saying they need a 64bit driver that is not native to Windows? If so that might be it as I never installed their own drivers (if there were any).

    However the problem is intermittent... so a bit harder to debug. I did try uninstalling it from Device Manager, but then it wouldn't re-install without a reboot.

    Thanks for the replies... looks like this isn't a known issue...
      My ComputerSystem Spec

  5. Berton's Avatar
    Posts : 5,275
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       21 Oct 2016 #5

    The Pioneer is a Blu-Ray drive that also works with CDs and DVDs and the Plextor is a DVD burner. Looks like both are SATA-connected. It's very possible that Windows does not have drivers for everything.

    I did try uninstalling it from Device Manager, but then it wouldn't re-install without a reboot.
    That is not uncommon, drivers need to unload from memory and the usual way is to reboot. Memory [RAM/Random Access Memory] is volatile, that is anything stored in it while in use is lost when a computer is shut down or rebooted. That's why when programs lock up the last solution is to shutdown or restart the computer, clears its mind to give a fresh start.
      My ComputerSystem Spec

  6.    21 Oct 2016 #6

    I realize why you think it may be Windows 10, but I can tell you that Windows 10 is not to blame here. You have something else loaded, either an application or a chipset driver, that is getting in the way of your drive access.
      My ComputerSystem Spec


Related Threads
I added an existing .VHD (XP SP3 guest OS, which I originally created in Virtual PC 2007 running on an XP SP3 host OS) to Hyper-V via the Hyper-V Manager. It worked fine, except, I have no "Insert Integration Services Setup Disk" option in the...
I am having an issue with my Windows 10 Pro on a Dell Optiplex 780 machine where every time I open a Windows Explorer window, doesn't matter what directory, I get the following error message: "Please insert the last disk of the multi-volume set and...
100% Disk usage some times in Performance & Maintenance
I'm running windows 10 on an acer aspire v5. It's not some super computer but it's still a pretty good machine, 700gb+ free, runs pretty well. Sometimes, I check the task manager and it's at 100% disk usage. I don't know why and it concerns me, even...
Cannot figure out how to stop this window from displaying on start up. (pic attached) Any help will be appreciated.
Please insert a disk into (D:) in Drivers and Hardware
Hello! I have a 1080p Action camera. You can find it Here. I have had it for about a month. It worked fine and I loved it. But recently I have been getting this error. When I plug it into my PC I get a message "Please insert a disk into (D:)." When...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:03.
Find Us