Unkown USB device (device descriptor request failed) after disconnect


  1. Posts : 2
    windows 10
       #1

    Unkown USB device (device descriptor request failed) after disconnect


    Hello, ok so after recently doing a clean install of windows 10(please don't get me started on that mess). my system has been plagued by random usb drops. it's where everything connected via USB suddenly disconnects then reconnects out of the blue. well I was using a Rosewill Transenclosure RX200R-APU-25B USB 3.0 dual 2.5 hard drive enclosure and transferring files from one drive to another (connected via USB) when one of these drops occurred. Now whenever I plug in my hard drive enclosure in a windows warning pops up and says "the USB drive that was just connected Malfunctioned and could not be installed" and in system manager it says "Unknown USB device (device descriptor request failed)". I know it's not the hard drives because I can remove them and use another connection and they work fine, all files intact. It's just now my hard drive enclosure won't recognize. This also happened to a "Loot crate exclusive Game of Thrones stark sigil 4GB USB stick I plugged in and turned into a windows 10 install drive. When I plugged it into use it after the windows media creator said it was done the USB stick was raw and unformatable. Please help. Microsoft keeps telling me it's a hardware issue even though it happened on two different systems. both operating windows 10 never any issue with windows 7 or 8.1

    Dell N7110
    i5-2450M about to upgraded to an i7-2820 if I can get this USB issue under contol
    16GB Samsung DDR3 Ram
    3-750GB HDD, 250GB HDD
    EVGA GTX 1060 3GB DDR5
      My Computer


  2. Posts : 5
    WINDOWS 10
       #2

    The driver could have been corrupted please re install the drivers for dell. Hope this helps
      My Computer


  3. Posts : 2
    windows 10
    Thread Starter
       #3

    ok so I found out a whole bunch of things and have a whole bunch new problems. so I solved the issue with the random USB drops. Control Panel>Power Options>Change power plan options> Advance power options>USB Settings> USB selective suspend setting> change from enabled to disabled. ok I was on with Microsoft support and they def acknowledge that it was their feature cutting the power at the wrong that time damaged the driver, correct, but the problem is the driver is embedded in the hardware of the enclosure since it was raid, and now I can't even get the enclosure to appear in device manger at all. no error, no nothing. It also makes my T.V. screen(attached to computer via HDMI to EVGA GTX card via mPCIe slot) go black for like 6 seconds and then it slowly from top down comes back. I found the manufacturer of the raid card JMicron and it's chip is a JMS551 and I got the update tool but cuz windows doesn't register the enclosure as JMicron JMS551 it doesn't see the device I'm assuming. I had the tool before the enclosure stopped registering and when it was plugged in the utility could not find it. It found the one inside my USB to SATA cord fine.
      My Computer


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 07:56.
Find Us




Windows 10 Forums