Page 3 of 4 FirstFirst 1234 LastLast
  1.    05 Oct 2016 #21
    Join Date : Mar 2014
    Cape Breton Nova Scotia ,Canada
    Posts : 3,459
    insider build 10586.3 win10 pro 64

    Again, that's what these forums are for, no?
    correct ,I hope someone with the same issue, comes along , really I do , good luck
      My ComputerSystem Spec
  2.    05 Oct 2016 #22
    Join Date : May 2015
    Central IL
    Posts : 4,021
    Mac OS Sierra

    rivre at this point you are not helping yourself by being forthcoming with following the items that we have asked you to do to find out if it is the driver for your computer or the enclosure. This discussion is over and unless you actually do what we have asked for you to try multiple times, you are on your own.
      My ComputerSystem Spec
  3.    05 Oct 2016 #23
    Join Date : May 2015
    Central IL
    Posts : 4,021
    Mac OS Sierra

    Quote Originally Posted by caperjack View Post
    correct ,I hope someone with the same issue, comes along , really I do , good luck
    Probably not on here. These kind of threads where the person posts and asks for help, then turns around and starts throwing up road blocks as they do not believe what we are asking them. Then they wonder why they hear silence as in the post they made in Post #20.
      My ComputerSystem Spec
  4.    05 Oct 2016 #24
    Join Date : Jun 2016
    Posts : 213
    Windows 10 64-bit home
    Thread Starter

    Bro67, why are you continuing to harass me in here? You are not contributing to this thread. I came in here asking for advice and I have followed the suggestions offered. Why do you continue to post in here since it's obvious you are not here to help or offer suggestions? Since others are at least trying to be helpful why don't you leave this thread for others to help?

    And are you purposely being obtuse? I have already listed several posts ago all the things I've tried, including suggestions by members in here and by the tech rep I spoke with. Why are you pretending I haven't been trying to solve this issue? And who are you to say this thread is over? I came in here asking for help. I wasn't looking for a fight. But thanks for derailing this whole thread.

    Also, not every suggestion will work. The point in any thread is to hopefully get suggestions that may work. That doesn't mean every suggestion is a good one. In another thread I was told the best advice is to do a repair install for a few "missing" codec files, when it turned out that was totally unnecessary and the files weren't even missing. Thankfully another poster helped out because if I listened to the first suggestion, I would have gone through an entire repair install and lost all my updates for no reason as it wouldn't have restored the missing files.
      My ComputerSystem Spec
  5.    05 Oct 2016 #25
    Join Date : Mar 2014
    Cape Breton Nova Scotia ,Canada
    Posts : 3,459
    insider build 10586.3 win10 pro 64

    I may not fully understand your setup and the different types of drive connections ,so I could be totally off on this suggestion ,the docks are hot swappable , is it possible to try a non working drive in a working case ,or are the connections different ,, and it likely you would have tried this already if it was possible ..I also read on the site something about a reset switch on the back [I need to reread the site to see if I can find what I read ] case if a drive wasn't working .
      My ComputerSystem Spec
  6.    05 Oct 2016 #26
    Join Date : Mar 2014
    Cape Breton Nova Scotia ,Canada
    Posts : 3,459
    insider build 10586.3 win10 pro 64

    just found some links on this site, http://www.icydock.com/goods.php?id=175 ,, to a forum ,http://www.icydockforums.com

    and a blog ,http://icydock.blogspot.ca/

    hope it helps, but as I read a bit of it I don't thing its a very active forum
      My ComputerSystem Spec
  7.    05 Oct 2016 #27
    Join Date : Mar 2014
    Cape Breton Nova Scotia ,Canada
    Posts : 3,459
    insider build 10586.3 win10 pro 64

    assuming the drives plug into the usb3 of the motherboard ,maybe check motherboard maker for a motherboard driver update for win10
      My ComputerSystem Spec
  8.    06 Oct 2016 #28
    Join Date : Jun 2016
    Posts : 213
    Windows 10 64-bit home
    Thread Starter

    Thanks for the suggestions.

    I took a look at their forum, and there's practically no activity there. There was no mention of this issue there.

    The thing is those drives all work fine if I connect the enclosures via esata. They come right up and work fine. It's only when I connect the enclosure using USB 3.0 that the drives aren't recognized. Per Icy Dock's suggestion in an email I received, I tried starting the enclosure with just 1 drive inside, and it still wasn't recognized over USB 3.0.

    When I set up my new PC a few months ago, I installed all the latest drivers, direct from Gigabyte, my motherboard manufacturer. I'll also mention that I have an old USB 2.0 enclosure by another manufacturer and that is instantly recognized in my motherboard's USB 3.0 ports. So the only enclosures that don't work are the Icy Dock enclosures and only when connected via USB 3.0.
      My ComputerSystem Spec
  9.    06 Oct 2016 #29
    Join Date : Jun 2016
    Posts : 213
    Windows 10 64-bit home
    Thread Starter

    There's a warning on the product page but I don't think it applies to me:

    "Note: WD Green and WD Red hard drives have a feature called Intellipark. This feature makes the drives automatically park themselves after being idle for 8 seconds. There is a small chance that certain drives may appear offline to the USB host of the MB174U3S-4SB and can cause the USB host to refresh. This could cause the remaining drive(s) to power cycle, interrupting any data transfer and potentially causing data corruption on the drives. We recommend WD Green and WD Red drive users to disable the Intellipark feature to prevent this issue."

    I don't have any green or red drives in those enclosures.

    They mention the enclosures "Supports UASP function for even faster performance" over USB 3.0. Perhaps that has something to do with my issue? Is there something in the BIOS I could check that may affect USB recognizing external enclosures?
      My ComputerSystem Spec
  10.    06 Oct 2016 #30
    Join Date : Jul 2015
    Posts : 3,655
    10 Pro

    @river, I hate to say anything downbeat but I think you have just got an enclosure that doesn't work. I have a Iomega eGo USB3 drives which works perfectly fine with windows 7, Linux and macOS. They doesn't work with Windows 10 at all.

    The reason is simple - in Windows 7 the USB drivers were written by Intel. In 8 and above they are written by Microsoft. In Windows 8 you could install the legacy Windows 7 Intel USB 3 drivers. In 10 you can't and some (not all) USB 3 drives don't work.

    You have various options. Use another OS, connect through USB 2.

    I just bought a different SATA-USB cable which worked fine for me.
      My ComputerSystem Spec

 
Page 3 of 4 FirstFirst 1234 LastLast


Similar Threads
Thread Forum
Cannot Safely Remove External Drives
Hello all, In recent weeks, it has become impossible for me to safely remove my external drives. (Mostly, I use Western Digital Passports, Passport Ultras, etc). I am using Windows 10. I close all of my programs and folders. I get the...
Drivers and Hardware
Windows 10 Pro and External Hard Drives...
Hello, I recently bought a new PC with win 10 pro on board. I was disappointed to find that my Sabrent Dual Hard Drive bay as well as my Inateck external hard drive cable are not recognized by my laptop, a Lenovo Thinkpad. I had no issues with...
Drivers and Hardware
How to Benchmark External USB 3.0 Hard Drives?
I suspect the VIA USB 3.0 ports on my motherboard are not performing as well as the Intel USB 3.0 ports with my 1T & 2T Seagate Portable USB 3.0 Expansion Drives. What's the best way of benchmarking external USB 3.0 hard drives to troubleshoot...
PC Custom Builds and Overclocking
Why do external HDD enclosures have capacity limits listed?
I have never bothered to try to find this out. I am shopping for replacement HDD enclosures that can be used with my router for a large-capacity network drive. The only question I have is why do Manufacturers specify that enclosures have limits on...
Drivers and Hardware
Unable to access external USB Drives!
Hi I recently upgraded my PC to windows 10 and every since have been unable to access any USB external drive. The laptop picks up the drives and acknowledges that they are there and working but they do not appear in file explorer. I have...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:24.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums