Windows 10: Wi-fi, audio, USB not working on Asus X202E

  1.    26 Sep 2016 #1

    Wi-fi, audio, USB not working on Asus X202E


    Hi, it's my first time posting here but I've read and learned a lot from this forum, so thank you all very much in advance!

    I'm trying to repair a friend's Asus X202E notebook. It worked normally until it got stuck in the blue screen during startup, and wouldn't complete booting. Someone formated the HDD (including the recovery partition) and installed W8.1, which worked but with no sound or internet (wireless or cable). The device manager doesn't show these devices at all. One USB port doesn't work either.

    I first thought it was a driver issue, but couldn't make it work. After many attempts I decided to try a W10 clean install, which is installed now, but the symptoms remain the same. I can access the internet through a USB wifi dongle.

    I've tried:

    - Using Windows troubleshooter;
    - Downloading and installing many drivers from the Asus site, for many components (besides audio and internet cards);
    - Downloading a X202E drivers compendium some good soul posted here in this forum;
    - Using DriverEasy;
    - Installing the audio card as legacy in device manager;
    - Reseatting wi-fi card;
    - Checking the logic board for damage (not good at this, but it looked alright);
    - (Going to update as I remember more steps I tried)

    I'd really appreciate your assistance in this matter, thank you all!
    Last edited by Tomaz Lemos; 26 Sep 2016 at 20:08.
      My ComputerSystem Spec

  2.    26 Sep 2016 #2

    Summarizing the situation so far


    The full model of the notebook is Asus S200E - ct252h - X202E

    It had a persistent blue screen during boot which desapeared after a fresh install. After that, no wi-fi, no ethernet, no audio, no USB 3.0, on both W8.1 and W10.

    I have tested: ASUS driver update, Intel driver update, DriverEasy, many original X202E ASUS drivers. Neither Audio or Network devices appear on device manager.

    Can it still be a driver issue? Would it be a device by device driver solution, or could there be a chipset driver that would "unlock" the devices?

    If not a driver issue, what else could it be?
      My ComputerSystem Spec

  3.    26 Sep 2016 #3

    Go up to the tool bar in Device Manager and choose View/Show Hidden Devices
    Please attach a screenshot of Device Manager.
    Especially under Network Adapters, Universal Serial Bus Controllers, and Sound, Video and Game Controllers showing.
    If any of these devices have yellow flags, Go to the Asus drivers site ASUS Global
    the Chipset, LAN, Wireless and any other drivers you need from the Device Manager
    If that still doesn't work, try updating the Bios, using the Bios Utility
      My ComputerSystem Spec

  4.    26 Sep 2016 #4

    spunk said: View Post
    Go up to the tool bar in Device Manager and choose View/Show Hidden Devices
    Please attach a screenshot of Device Manager.
    Especially under Network Adapters, Universal Serial Bus Controllers, and Sound, Video and Game Controllers showing.
    If any of these devices have yellow flags, Go to the Asus drivers site ASUS Global
    the Chipset, LAN, Wireless and any other drivers you need from the Device Manager
    If that still doesn't work, try updating the Bios, using the Bios Utility
    Thank you very much for your reply!

    No yellow flags in the device manager, as the screenshots show. The screenshots are in portuguese, sorry about that, feel free to ask me if you need anything to be translated.

    Click image for larger version. 

Name:	snapshot1.PNG 
Views:	6 
Size:	43.5 KB 
ID:	103342Click image for larger version. 

Name:	snapshot2.PNG 
Views:	6 
Size:	13.6 KB 
ID:	103343

    Bios already updated to latest version, 210.
      My ComputerSystem Spec

  5.    26 Sep 2016 #5

    The USB Controllers section is displayed twice due to poor screenshot abilities on my part.

    Ive disabled USB shutdown in the energy sections of the USB drivers, and the USB 3.0 Host driver is up to date. The Realtek Wireless Adapter USB 2.0 is the Wifi dongle Im using.
      My ComputerSystem Spec

  6.    26 Sep 2016 #6

    Another screenshot of the System Devices section of the device manager. Again its in portuguese, I can translate whateaver is needed.

    Im still wondering if this is something related to a chipset driver... There is a Legacy Device (Dispositivo herdado) which I found out to be nothing of concern, checking the device ID: INT0800, as by this thread: G75VW Windows 10 Legacy Device?

    Click image for larger version. 

Name:	snapshot3.PNG 
Views:	5 
Size:	34.3 KB 
ID:	103350
      My ComputerSystem Spec

  7.    27 Sep 2016 #7

    Well, I finally gave up, going to assume the logic board is toasted and buy some USB dongles for the missing functions, as my friend cant afford a new logic board.

    Thank you all for the assistance!
      My ComputerSystem Spec


 

Related Threads
A few weeks back I got an ASUS ROG GL752VW. During my initial set up in the first few days, I went into device manager, to my sound card, which is Conexant brand and updated the drivers. This caused the sound on my laptop to completely stop working...
ASUS X202E Win 10 touchscreen in Drivers and Hardware
I acquired an ASUS X202E with cracked touchscreen and Win 10, replaced touchscreen but it does not work. Anyone have this system that touchscreen works with Win 10 ASUS says Win 10 not supported
My Asus X550LD laptop do not have any sound from internal speaker and headphone jack. After update the driver,it still not working. There is no any sound device found in device manager. So I decide to open the laptop and see whether there have...
Asus X202E - Missing Windows 10 Drivers? in Windows Updates and Activation
Hi guys, Hoping someone can help me. Trying to update a Asus X202E running windows 8.1 to windows 10 but I have been informed that there has been no drivers released for this model because it is to old. Is this correct? Any help would...
ASUS VivoBook X202E Drivers in Drivers and Hardware
This actually isn't directly Windows 10 related since it also affected Windows 8 and 8.1. A couple years back I swapped out the mechanical drive in this notebook for an SSD. Device Manager shows a lot of unknown devices that have no drivers, even...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:24.
Find Us