Windows 10: Problem with flash drive

  1.    15 Sep 2016 #1

    Problem with flash drive

    I have a question about my flash drive. It's a 4GB PNY and usually works with no problem when I plug it in. But lately when I plug it into my laptop (a 2 month old laptop with Windows 10), it plays a quick tune indicating I plugged it in, but it doesn't actually show up on my screen as available. That's what happened this morning, and I tried both USB ports repeatedly. Now I'm using a different a different computer and now my flash drive registers on the computer with no problem. Also, sometimes I have to plug it in and unplug it several times before it shows up on the screen even on this other computer. Today it had no problem.

    Can someone tell me why this stuff happens? Is it a flash drive problem, or a computer problem?

    EDIT: Now I'm back on my laptop again and tried the flash drive and it still doesn't appear on the screen. Then I remembered that I have another flash drive that I use as a backup for my files and tried plugging that into my laptop to see if it would work. It didn't. So it appears to be a computer problem after all. Is there a setting that I could change so that I can use a USB flash drive with my laptop again?

    I should add that I also inserted a memory card from my digital camera into the memory card slot on the laptop and was surprised that it actually worked. But any USB drive I insert into either one of my USB ports does not work.

    EDIT (again): I went to Devices and Printers and found the USB drive. There was a message there saying, "Windows cannot load the device driver for this hardware because a previous instance of the device driver is still in memory. (Code 38)

    The driver could not be loaded because a previous version of the driver is still in memory."

    With this information, what should I do to be able to use my flash drive with this computer again?
    Last edited by Delly10; 15 Sep 2016 at 17:10. Reason: Adding comment
      My ComputerSystem Spec


Related Threads
Problem Ejecting Sandisk Flash Drive in Drivers and Hardware
Whenever i try to eject my Sandisk flash drive, by right-clicking on it's icon and clicking on "Eject Cruzer", I get an error window with the title, "Problem Ejecting USB Mass Storage Device". The message says, "Windows is unable to stop the...
USB Flash Drive Problem in Drivers and Hardware
Hey guys, So, I have this 8 GB USB Flash Drive which is completely empty, no hidden files/folders, nothing. But it says that around 1 GB is used - Imgur: The most awesome images on the Internet Why is that? Can I free up that memory? Not that...
Solved USB Flash Drive UEFI problem in Installation and Upgrade
Hello No matter what I do, my Lenovo Flex 2-14 doesn't seem to recognise my USB as an UEFI Windows bootable flash device, despite following this guide...
now im a computer tec and i know that memory cards and hdd are sold as "base 10" like 1gb=1000mb to them instead of 1024mb but im revisiting this question because i was looking into this for some time now and there are some people claiming thats its...
Hi, I've had win10 about 2 months now and mail app wouldn't work and weather app stopped after the first day, this week Photo app stopped and usb 3 port locked up and some games graphics were slow. I made a recovery drive on a flash drive and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:08.
Find Us