Windows 10: PC will not go to BIOS - says no keyboard detected

Page 1 of 2 12 LastLast
  1.    09 Sep 2016 #1

    PC will not go to BIOS - says no keyboard detected


    Machine has been running Win 10 64 for about a month. No problems (except those relating to things Win 10 does that I don't like). Keyboard uses a USB 2 adapter since the MB no longer has a keyboard port. I use USB 2 because I don't think USB 3 is active early enough on this MB. I did try it; no joy. I have had no problem entering the BIOS until today. I have turned off secure boot and fast boot several weeks ago. Still worked fine. MB is an Asus P8Z77-V Deluxe. I checked connections and moved the mouse to another USB 2 port. No change. I have never had a problem with this keyboard, and it works fine once it gets into the OS. Previously it also worked fine with the BIOS.

    When booting the BIOS says there is no keyboard detected; hence it can't see the Del key to go into the BIOS. It is a strange boot. It starts and sits for quite a long time and says no keyboard. It then appears to start the boot again, but now goes to the OS. The OS seems to start more that once briefly and then go to a normal boot.
      My System SpecsSystem Spec

  2.    09 Sep 2016 #2

    I don't think this is a Windows issue. It's before Windows even loads.
    Since you've checked other USB ports, I'd hazard a guess it's time for a new keyboard. Good luck.
      My System SpecsSystem Spec

  3.    09 Sep 2016 #3

    The keyboard is, I believe, just fine. The keyboard works after boot. It used to work when entering the BIOS. Current behavior is not indicative of a keyboard failure. Something else is wrong.

    I have had one experience with Win 10 apparently altering parameters in the BIOS. To the best of my recollection (and I would have done it because I do not want them active) I had turned off secure boot and fast boot. And they were suddenly turned on.

    Win 10 is scary. I have no idea what it is doing and no way to manage what it does. I have two systems at this point that will not operate properly with Win 10, that worked just fine when Win 10 was initially installed. One will no longer boot.

    I strongly suggest that there is no hardware problem with either of these machines. Each worked until WIN 10 "helped". IT IS WIN 10. At this point, there needs to be government intervention (note: I really hate government intrusion) to control MS. They need to be stopped. They are just going crazy. These are my computers. I built them; I own them. MS has decided that all our computers are belong to us (for the newer generation, research that phrase replacing computer with data). MS is installing massive useless and unwanted applications and functions. Requiring massively intrusive data collection. Making it extremely difficult to even try to stop their massive attack on privacy. Destroying our ability to manage our property.

    So yeah, I think it is Win 10.
      My System SpecsSystem Spec


  4. Posts : 1,431
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)
       10 Sep 2016 #4

    That's an odd problem. You can enter the BIOS by holding the Shift key + Restart. Then select Troubleshoot / Advanced Options / UEFI Firmware Settings. Else, you can use Brink's method at https://www.tenforums.com/tutorials/5...dows-10-a.html The PC should restart into the BIOS screen.
      My System SpecsSystem Spec

  5.    10 Sep 2016 #5

    You might need to set USB ports in BIOS to "Legacy" but don't know how to enter BIOS without KB and without resetting it.
      My System SpecsSystem Spec

  6.    10 Sep 2016 #6

    Thanks Steve,

    I don't know what shift restart is. Is it something in windows if you are using the windows start menu (which I have not for years), or a key on more current keyboards? I use an Northgate OmniKey which lacks all modern added keys; which will have to be pried from my cold dead hand. But the keyboard works just fine if I am not trying to get to the BIOS.

    I tried the method in the link on booting inside OS. It did indeed reboot, but it did so in an unusable way. It went through the long wait in the initial Asus boot screen, said no keyboard found, went to the second Asus boot screen (I don't know what that is all about, but that has been what was happening). This time, that second booting screen brought me to the main page of the BIOS.

    Unfortunately, neither my keyboard not mouse worked. I should probably start thinking to look in the phone book for an exorcist. I now have 2 Win 10 computers being either broken or being strange.

    I am wondering if the boot information for the machine has been screwed up. If I found way to examine it I would not know what I was looking at.

    Something else I just realized. For several weeks, when I bring the machine out of sleep or boot, it takes maybe 20 seconds before the mouse works. It used to be immediate. I am guessing something changed in the way the USB interface is activated. That could be an associated symptom of the boot to BIOS issue. If it takes too long to activate the USB interfaces, it would time out. But the boot delay is much longer than the mouse under what is now a normal return from sleep.
    Last edited by alternety; 10 Sep 2016 at 19:42.
      My System SpecsSystem Spec

  7.    11 Sep 2016 #7

    Shift-restart = holding Shift key while clicking on restart = brings you to safe mode.
    If your problem stems from BIOS, OS still has nothing to do with it because it happens before OS boots. It has to be dealt with in the BIOS in legacy mode. UEFI bios resides on the disk, in it's own partition and it boots OS from there.
      My System SpecsSystem Spec


  8. Posts : 1,431
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)
       11 Sep 2016 #8

    I'm not convinced about your keyboard - are you using an old PS2 keyboard & USB adapter? That may be causing a problem at boot. It would save much trouble to try another one even if you just borrow one from a friend to try.

    If we can rule out a faulty keyboard, you could consider reflashing the BIOS. If you have a fancy motherboard with a dual BIOS you can flip a switch on the motherboard or there may be a key sequence on boot which load the back up BIOS. Read your motherboard manual before attempting this!
      My System SpecsSystem Spec

  9.    11 Sep 2016 #9

    I have continued searching for a cause. I may have found one.

    Looking at the boot manager file on the boot drive, the date last modified is near the end of last month. Nothing else has changed around it for a long time. Is there any way to examine the file in some reader application that I can try to see what it thinks it is doing?

    Looking at the GPT system partition, there are a whole bunch of MS changes in the last several weeks. I have nothing to see inside most of it. But there are changes on or just after the change I seen in the C drive.

    I would not have purposely made these changes.
      My System SpecsSystem Spec


  10. Posts : 1,431
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)
       11 Sep 2016 #10

    I use MiniTool Partition Wizard to explore the contents of hidden system partitions. You can use the command bcdedit /enum to view your boot configuration. You can also rebuild the boot configuration files if necessary. Make sure you have a system backup before you modify your boot files since you may end up in a worse place!
      My System SpecsSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
When I start my computer, immediately after the Intel logo, I get the message: "BIOS has detected unsuccessful POST attempt(s). Possible causes include recent changes to BIOS, Performance Options or recent hardware change. Press 'Y' to enter...
I have a USB keyboard which normally works fine but is not working when I enter the BIOS. (Which I am trying to do BTW so that I can boot from the the Win10 ISO install disk. I'm on Win7 now and I've tried the easier way many times but it always...
Hey guys! :D I recently got a Casio keyboard, with a new MIDI cable. I'm a music artist and I'm totally new with this 'keyboard-to-computer-via-MIDI' stuff. :huh: I don't know how to connect my Casio Keyboard to my computer with a MIDI...
Hi everyone Today my keyboard stopped working, there was a usb error message pop up but i didn't realise what it was about, then then my k70 corsair keyboard stopped working, i tried restarting and doing an sfc scan but nothing changed, then i...
Hi everyone, It's not a Windows 10 thing, but maybe someone can help me ! I'm trying to revive a very old computer here. It's a 15 year old machine. I intend to install Windows 2000 on it. It's more for fun, I really don't need the machine,...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:15.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums