Problems with USB SCSI Mass Storage Device

  1.    06 Sep 2016 #1

    Problems with USB SCSI Mass Storage Device

    Everytime my Seagate Expansion Portable Drive is plugged into my PC (Windows 10 64bit), Window's Event Viewer repeatedly reports warning messages:

    Event 129, UASPStor

    Reset to device,\Device\Raidport1, was issued

    Also, USB 3 write speed was extremely slow - it often took more then 8min to write a 5GB file into the drive. During the writing process, the writing speed cycled between 0MB/s to 90MB/s. Most of the time, the writing speed stayed at very low values, < 1MB/s.

    Device Manager reported that I have the latest UASPStor driver. If I disabled the UASPStor driver, the drive became disconnected.

    If I plugged in the Seagate drive into a Win 7 machine, it worked perfectly well.

    Can anyone help me to solve the problem?
      My ComputerSystem Spec

  2.    07 Sep 2016 #2

    When that drive is connected, locate it in Device Manager and search for an updated driver.
      My ComputersSystem Spec

  3.    07 Sep 2016 #3

    I had to give up on one of my external USB3 drives. It worked on Windows 7, and still works on OSX. From the research I did the reason is that up until Windows 7 Intel made the UAS drivers. In 10 they are made by MS and don't work quite the some drives just don't work - it doesn't seem to be one specific manufacturer - see

    Can anyone use USB attached SCSI in 10? - Windows 10 Forums
    External Hard drive not accessible... - Windows 10 Forums

    I tried forcing the Windows 7 Intel drivers to install (you need to update the inf files as described here) but it still didn't work (although it did on Windows 8.1).

    The only solution I could find was to use a different enclosure. I guess a SATA --> USB 3 cable would also work.
      My ComputerSystem Spec

  4.    07 Sep 2016 #4

    [QUOTE=Steve C;803255]When that drive is connected, locate it in Device Manager and search for an updated driver.[/QUOTE

    Thanks Steve. I tried your method, but problem persists.
      My ComputerSystem Spec


Related Threads
So Windows 10 has a feature to move apps from one drive to another. I have set my storage setting for everything to be stored on a HDD since my primary OS drive is SDD. Even though I've followed the proper steps, none of my installed apps are...
So I finally decided to do something about this. There is always a Safely Remove icon on my taskbar, so I click it and there is nothing to remove. In Device manager, it is also present under Disk Drives. Even under my computer there is a disk...
Is anyone using a UAS device successfully on 9926? I have a Iomega eGo USB 3 1TB drive which connects through USB Attached SCSI when running 9926 on 2012 Macbook Pro hardware. The drive is fine (works through USB2 on Thinkpad) and the Macbook is...
Adaptec 39320A SCSI drivers in Drivers and Hardware
You can download and use the Windows 7 drivers from the Adaptec support site, these seem to work fine (at least on x64). Other Adaptec cards may also work using the Windows 7 drivers. HtH Dave
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:19.
Find Us