Miracast connection problems after Anniversary Update?

  1. Posts : 1
    Windows 7 Ultimate, Windows 10 Home
       02 Sep 2016 #1

    Miracast connection problems after Anniversary Update?

    I currently own a Sony MP-CL1 Pico Projector. This is based on the same technology as the Celluon PicoPro (same laser diode). My laptop connected to the projector last month completely fine, and I had no problems using screen mirroring.

    However, one day, the function suddenly stopped working. I spent days pulling out my hair and couldn't figure out why, and would get random messages error messages on the projector saying that the "host device dropped the connection", "host device timed out", "could not establish P2P group", etc. The only thing that I could think of that has changed recently was the Anniversary Update, which was the latest and biggest update from Microsoft. (Keep in mind, I usually use my other notebook with Win7, and only use the Win10 ultrabook for screen mirroring projection and light web browsing.

    I know the projector definitely works because it continues to mirror both my android phones (android M) fine. And it also has no problem working through HDMI cables (although I guess that's through a wired connection, and an unfair comparison to the wireless issue at hand).

    I have tried deleting the device from the previously connected list, and tried doing fresh connections to the projector. I did notice that the computer was downloading? or installing? some type of drivers/files for the Sony MP-CL1 projector. The progress bar went all the way to the end and I didn't see any error messages.

    I have tried updating my Intel HD graphics drivers, but it was already updated ( The same goes for my Intel Wireless Pro drivers too. (19.2.0)

    I was wondering if anyone else has had issues with their Windows 10 mirroring function (especially after the Anniversary Update) and if they found any solutions to fix it. Any help/suggestions would be greatly appreciated.

    Thank you for your time.

    I don't know if this is useful information or not, but I just tried to use my notebook as a receiver display for my android phone (mirror my Android phone onto my notebook display using the "Connect" app from the Anniversary Update), and the whole phone image just gets scrambled and frozen. It seems that Miracast is just completely broken in both sending and receiving after the Anniversary Update.

    I see two different errors on the notification window: 1. "Protected content cannot be viewed on device." 2. "The device that is wirelessly projecting doesn't support input from this receiver's mouse."
    Last edited by Ragnarok7; 02 Sep 2016 at 23:19.
      My ComputerSystem Spec

  2.    08 Oct 2016 #2

    Any lick with this? I am having the same issues, couldnt figure out what was happening, I know it worked a couple months ago, but I really don't use it all to often. This makes sense though, it seems that everyone MA does a big update, stuff just stops working. Any help would be greatly appreciated. Thanks!
      My ComputerSystem Spec


Related Threads
I downloaded and installed the Anniversary update on my Dell laptop last week. Since then, I've been having trouble with the laptop's WiFi adapter setting getting changed from "Obtain DNS server address automatically" to "Use the following DNS...
Anniversary update problems in General Support
I finally got round to installing the anniversary update once I realised there was a way to disable Cortana through the registry, and it all seemed to install without any issues. Now that it's up and running though, a couple of problems have...
Anniversary Update Problems in General Support
Hi, I've tested a few anniversary update features and although it was going to get disabled on Win 10 Pro only, on Enterprise also some tricks are not working. As usual, to save time, after each clean Windows installation, I run a number of .reg...
Anyone else having problems with Anniversary Update? in Windows Updates and Activation
After waiting for it to show up, I went to https://support.microsoft.com/en-us/help/12387/windows-10-update-history?ocid=update_setting_client and asked for the upgrade. After a few hours of downloading + installing I turned on my desktop and it...
Since the Anniversary update (10.14393.51), which I did yesterday, to a Windows 10 Home laptop , I have several problems with Windows apps. Looking at the Event viewer I found several 5973 ERRORS for the following apps: ...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:17.
Find Us