Page 1 of 4 123 ... LastLast

  1. Joined : Jul 2015
    Posts : 40
    W10 Home 1607, build 14393.693
       02 Sep 2016 #1

    Windows won't detect some USB devices


    Hello! I know lots of people have a similar problem but as I haven't found a solution here nor anywhere else, I thought I'd share my specific case.

    I'm at Windows 10 version 1607, build 14393.105. System specs are in the profile, the UEFI is updated and the latest, settings there are on their defaults.

    Windows sees:
    * keyboard
    * mouse
    * Logitech F710 gamepad
    * Corsair Voyager Go usb stick
    * Smart card reader

    Windows doesn't see:
    * A Western Digital external drive
    * Canon 70D camera

    I had no problems with any USB devices with my previous computer which also had Windows 10 and the AU.

    I've already tried:
    * installing a USB driver from the motherboard manufacturer (which only relates to the 3.1 feature tbh)
    * different windows versions from 1507 and up
    * installing the commonly suggested Windows Media Transfer Protocol Kit (Download Media Transfer Protocol Porting Kit from Official Microsoft Download Center)
      My System SpecsSystem Spec


  2. Joined : Jun 2016
    Posts : 1,386
    Win10 1607
       02 Sep 2016 #2

    I'll give you a fair price for the Canon 70D ....... I use a Card Read for my 50D , so not sure if it works or not direct on my X99.

    Someone else just installed AU 105 and it cured his USB issues but he is on X99 not Skylake.....

    I am surprised the MTPP is suggested for Win10 it is from 2007.....

    It may not be Win10 though.....but a chipset error/issue...

    Does the WD have a Firmware upgrade ? There are issues with the xHCI controllers (usb3) and USB 2 devices esp. hubs and some joysticks eg the X55 , some problems are cured by newer firmwares that can "talk" to the xHCI controller properly. But some like my NEC monitor can't be upgraded so I can't connect it on the x99 comp. as the hub causes the comp. to stop booting even.

    KB
      My System SpecsSystem Spec


  3. Joined : Jul 2015
    Posts : 40
    W10 Home 1607, build 14393.693
       03 Sep 2016 #3

    Well, actually, I would be happy to sell the 70D but I'm guessing you're on another continent so it could include some undesireable costs for you. Also, considering the camera, I want the USB connection because I'm using Focal 2 program which needs that. Otherwise, the SD card reader and the USB passthrough on the BL3200PT work too (didn't mention in the original post).

    On another note, I have enabled the XHCI-handoff in the UEFI. Setting doesn't seem to help in this case.

    I've also found an interesting MS blog: Microsoft Windows USB Core Team Blog , need to see that through.

    Things to try:
    - Contacting Asus and MS support.
    - Try all different ports, including 2.0 ones.
    - Try connecting through the USB passthrough on the monitor.
    - See if the monitor can read the external drive itself (btw the drive works with the TV).
    - Check WD firmware.
      My System SpecsSystem Spec


  4. Joined : Jul 2015
    Posts : 40
    W10 Home 1607, build 14393.693
       03 Sep 2016 #4

    Update on the Western Digital drive (WDBPCK0010BBK-01):

    The drive works with the USB 2.0 ports which I didn't try before, but not on the 3.0 ports or the 3.1 port. The drive itself supports 3.0, though. It also works on the smart TV which has both 3.0 and 2.0 ports (works in any of them).

    Strangely enough, the connection is "almost achieved" when I connect the WD drive to the monitor's (BenQ BL3200PT) USB 3.0 passthrough and then connect the monitor's passthrough cable to any of the PC's USB ports, with 3.1 "coming closest" to getting the connection. By "almost achieved" I mean that windows repeatedly tries to install the device (pop-up window) and on some tries it even recognizes a "drive G:" but shows nothing on it. When I connect the passthrough cable to the PC's 2.0 port, it works ok as when putting the drive directly there.

    I managed to update the WD's firmware using the 2.0 connection, but that didn't change anything.

    Update on the Canon 70D connection:

    Nothing works.
      My System SpecsSystem Spec


  5. Joined : Jun 2016
    Posts : 1,386
    Win10 1607
       03 Sep 2016 #5

    Price on that 70D just went down even more if I have time later I will try to connect the 50D as see , never have .....

    Under USB Config.

    xHCI Mode......... Smart Auto (Try Auto too)
    EHCI Leg......... enabled
    XHCI HO........ enabled
    EHCI HO........ disabled

    No issues with the BL3200PT USB my bad USB2 hub was / is in a NEC 23" Monitor...

    seems to be alot of issues with that particular Passport Drive being recognised

    WDBPCK0010BBK-01 - Google Search

    KB
      My System SpecsSystem Spec


  6. Joined : Jun 2016
    Posts : 1,386
    Win10 1607
       03 Sep 2016 #6

    This is a better explanation of the xHCI settings.


    "XHCI Mode = Disabled
    The on-board USB 3.0 port function like a 2.0 port


    XHCI Mode = Enabled
    The on-board USB 3.0 port function like a 3.0 port


    XHCI Mode = Auto
    The on-board USB 3.0 port function like a 2.0 port before OS USB 3.0 driver load.
    If you reboot the OS, the on-board USB 3.0 port again function like a 2.0 port during this reboot BIOS phase before OS USB 3.0 driver load.


    XHCI Mode = Smart Auto
    The on-board USB 3.0 port function like a 2.0 port before OS USB 3.0 driver load.
    If you reboot the OS, during this reboot BIOS phase, BIOS is "Smart" enough to avoid downgrade the USB 3.0 port back to 2.0 functionality before OS USB 3.0 driver load. So Smart Auto is faster than Auto on 2nd boot onward, but Enabled is fastest once you are sure the OS has the USB 3.0 driver installed, because it avoid the switching. Making the on-board USB 3.0 port function like a 2.0 port is mainly to support OS installation or to support OS that does not have build-in USB 3.0 driver, so that the USB keyboard would still work if the user plug-in a USB keyboard or any other USB devices into the USB 3.0 ports before the OS is installed with the USB 3.0 driver come with the motherboard."

    KB
      My System SpecsSystem Spec


  7. Joined : Jul 2015
    Posts : 40
    W10 Home 1607, build 14393.693
       03 Sep 2016 #7

    Where do you find these settings? There's only the XHCI handoff enable/disable in the bios.
      My System SpecsSystem Spec


  8. Joined : Jun 2016
    Posts : 1,386
    Win10 1607
       03 Sep 2016 #8

    Oh , sorry I am on Asus X99A II and so I look in my bios in the USB Configuration Tab , the other info I saved from the Internet during my USB issues, I was under the impression the 100 Series Boards like the Z170 had similar bios options to X99.

    KB
      My System SpecsSystem Spec


  9. Joined : Jul 2015
    Posts : 40
    W10 Home 1607, build 14393.693
       03 Sep 2016 #9

    Hmm, well, ok. Some things yet to try here. I'll find a Windows 7 PC from my workplace and test the camera there. It isn't working with the W10 laptop either. Maybe the port on the camera is just plain dead, although that is very unlikely. Then again, so was the dreaded HDMI cable. Asus support should also have some insight regarding this, so should MS support. The fact that the WD doesn't work on 3.0 speaks for the hope that the camera is ok, really.
      My System SpecsSystem Spec


  10. Joined : Jun 2016
    Posts : 1,386
    Win10 1607
       03 Sep 2016 #10

    I assume you tried different cables with the Camera and WD HDD ?

    I have heard of USB3 devices being detected as USB2 if you push the plug in to quickly , the port doesn't have time to read the USB3 Pins and defaults to USB2 as those pins are in full contact when the plug is fully inserted..... the ding donging of the USB when on the BenQ has me wondering about something like that.

    KB
      My System SpecsSystem Spec


 
Page 1 of 4 123 ... LastLast


Similar Threads
Thread Forum
Solved Windows 10 doesn't detect my second monitor
I just upgraded from Windows 7 to Windows 10 and now my computer only detects one display rather than two. I have a Dell desktop computer and two Dell monitors. Using Windows 7 both monitors were being detected/used. Can anyone tell me how to...
Graphic Cards
Won't detect second monitor after Windows 10 upgrade
I was automatically upgraded from Windows 7 Home Premium to Windows 10 yesterday and now my second monitor can't be detected. Windows says it doesn't detect the second one, even though it displays two. When I move the mouse, it moves across both...
Graphic Cards
Solved Windows 10 won't detect second display on DVI, but Ubuntu will
I am having an issue with my dual-monitor setup in Windows 10. I have an NVIDIA GeForce GTX 650. My dual-monitor setup was working fine, until the computer complained it was overheating. I blew out the CPU and GPU heatsinks with compressed air. Now...
Graphic Cards
Cannot enable/detect 3rd monitor in Windows 10
I need help from the community. I've got a three monitor setup that is no longer working as expected. Monitor #3 is no longer showing up in "Customize your display" My setup is as follows Nvidia GTX 570 : Monitor #1, Monitor #2 Onboard Intel...
Graphic Cards
USB 4G Modem Dongle wont detect on windows 10
hey, well i upgraded to windows 10 and i use a usb 4g dongle to connect to the net, all software was installed for the device but it would not get detected, just kept saying unable to detect 4g modem, but all lights were flashing on the device....
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:46.
Find Us
Twitter Facebook Google+



Windows 10 Forums