Windows 10: No audio with PCI Express X-Fi Titanium Solved


  1. Posts : 11
    Windows 10, Build 10586
       20 May 2015 #1

    No audio with PCI Express X-Fi Titanium


    Build 10122

    In previous builds, I always had audio from my PCI Express X-Fi Titanium sound card but after upgrading from 10074, I have no audio. I've tried reinstalling the drivers. I verified that if I switch over to my HDTV that there is audio.

    I download the drivers from this site:
    http://support.creative.com/Products...+X-Fi+Titanium

    Any ideas?
      My ComputerSystem Spec


  2. Posts : 2,033
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       20 May 2015 #2

    Yep, Happened to me too.
    Open Device Manager->Sound, Video ...
    Right click on SB X-Fi. Disable and re-enable it. You'll get the sound back.
      My ComputerSystem Spec


  3. Posts : 11
    Windows 10, Build 10586
    Thread Starter
       20 May 2015 #3

    That worked, thanks!!!!!
      My ComputerSystem Spec

  4.    29 May 2015 #4

    Thank You sooo much!!!


    Worked exactly as stated, brilliant stuff!

    Thanks!
      My ComputerSystem Spec

  5.    21 Jun 2015 #5

    Anyone have problems with 10147 by chance? Like rebooting requirement now and doesn't fix it? Can't
    get it to work. Idea's? tia
      My ComputerSystem Spec

  6.    22 Jun 2015 #6

    sneekez said: View Post
    Anyone have problems with 10147 by chance? Like rebooting requirement now and doesn't fix it? Can't
    get it to work. Idea's? tia
    Fixed it...downloaded the drivers in post 1 sickmetal, didn't work but when I went to disable and enable it didn't ask
    me to do a restart and glorious sound was heard again Can't really explain how this happened, but it did. Now to
    try a fix for the slow/fast ring debacle.
      My ComputerSystem Spec


 

Related Threads
Source: http://blogs.windows.com/msedgedev/2015/05/26/announcing-dolby-audio-for-high-performance-audio-in-microsoft-edge/
Hello Everyone. I have a Jabra bluetooth speaker (the Solemate Mini). On Windows 8.1 I plug it in to my laptop using the 3.5mm to 3.5mm cable and then, when I watch a movie, it correctly outputs to the speaker and does not use my laptop speakers....
no audio in Drivers and Hardware
For some reason; the sound card driver for my sound blaster x-fi titanium pci express soud card that "top"(dont recall his full user name) gave me to install; seems to keep resetting itself every time I restart my system and then sign back in to ...
Solved no audio in Drivers and Hardware
After installing the latest iso of windows 10; I have no sound coming from my speakers; just crackling audio. What can be done to resolve this? I have a sound blaster x-fi titanium pci express that worked fine to provide my 5.1 surround audio under...
My ASUS M4N68T-M V2 has a VIA VT1708S onboard audio. The driver I have that worked in Windows 8.1 v10_1200a won't work in 10. Windows doesn't even see the onboard video so it doesn't even look for a driver. It doesn't show up in device manager. In...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:17.
Find Us