Page 1 of 2 12 LastLast

  1. Joined : May 2015
    Posts : 22
    10
       20 May 2015 #1

    Video driver issues


    Ok laptop Dell Latitude D510. 2 gigs of ram 1.4 gig processor 60 Gig hard drive. XP was on it installed Windows 10. Had audio and video issues.No drivers installed could not find or update them. Went to Dell site and downloaded drivers for audio, chipset and firmware. Got audio downloaded the Video driver no go keep getting a error message. All the drivers were for xp. Where can I get a video driver that will work?
      My System SpecsSystem Spec


  2. Joined : May 2015
    Posts : 22
    10
       20 May 2015 #2

    The device manager says the drivers for video are not installed. Click on find driver and none can be found that way. Like I said Dell's Video for XP won't load at the end I get an error message.
      My System SpecsSystem Spec


  3. Joined : May 2015
    Posts : 22
    10
       20 May 2015 #3

    Anyone?
      My System SpecsSystem Spec


  4. Joined : Sep 2014
    Posts : 729
    win 7 dual boot / 10
       20 May 2015 #4

    Did you go to dell support and look for drivers that they might have for win 7 or 8? I have a laptop about that era that is working good on 10. I will do some looking. try these vista drivers for a 520 lat
    http://www.dell.com/support/home/us/...e-d520/drivers
      My System SpecsSystem Spec


  5. Joined : May 2015
    Posts : 22
    10
       20 May 2015 #5

    Didn't work with the Vista one and would not let me access 7
      My System SpecsSystem Spec


  6. Joined : May 2015
    Posts : 330
    Redstone_One_Pro
       20 May 2015 #6

    jh45gun said: View Post
    XP was on it installed Windows 10.
    How did you install Win 10? While deleting partition(s), did it end up with one single NTSF partition? The XP drivers shouldn't be an issue no more.
    Last edited by MikeMecanic; 20 May 2015 at 22:47.
      My System SpecsSystem Spec


  7. Joined : May 2015
    Posts : 22
    10
       20 May 2015 #7

    MikeMecanic said: View Post
    How did you install Win 10? While deleting partition(s), did it end up with one single NTSF partition? The XP drivers shouldn't be an issue no more.
    used a disc a friend gave me with windows 10 on it and with a formatted hard drive. my hard drive was too small at 40 gig so got a 60 gig from him.
      My System SpecsSystem Spec


  8. Joined : May 2015
    Posts : 22
    10
       21 May 2015 #8

    I am stumped.
    Last edited by jh45gun; 21 May 2015 at 00:44.
      My System SpecsSystem Spec


  9. Joined : May 2015
    Posts : 330
    Redstone_One_Pro
       21 May 2015 #9

    jh45gun said: View Post
    with a formatted hard drive
    Press at the same time the 2 following key stroke: the Windows flag and Pause. What do you read there? What is the version that you install? You'll get the good one here: Download Windows 10 Insider Preview ISO - Microsoft Windows

    Did you install the 32 or 64 bit version: The answer for the good one is in the window I ask you to open.

    Now, at the specific portion of the installation, when your ask to delete partitions, is there was only one empty partition?
    Does the version of Win10 was out of date? Were you ask to provide an Email and your phone number? If so, you must delete the information to proceed with the same installer. But if I was you, I would download the 10074 version (64 or 32) and do a fresh installation again. This time, enable the delete function by pressing advance settings and delete the partition(s). Because, if your ask to install XP Drivers, it's me that is stumped like you say.

    All the best,
    Last edited by MikeMecanic; 21 May 2015 at 07:45.
      My System SpecsSystem Spec


  10. Joined : May 2015
    Posts : 22
    10
       21 May 2015 #10

    do I need special software to transfer to flash drive?
      My System SpecsSystem Spec


 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
AMD Radeon R9 380 Windows 10 bulid 10162 Driver Issues
Hi i cant install amd drivers on windows 10 on my r9 380 card at all. hope amd relesese a driver to fix it When i have my 7970 card the win 10 driver works good then but windows update didnt want to update the driver on my R9 380 card at all.
Graphic Cards
Video Driver For Gateway E6300 Radeon X 600/X550 for windows 10
Trying to find a video driver for my old Gateway E6300 with a Radeon X600/X550 video controller. The first test on Windows 10 several months ago worked but will not work on Windows 10 Inside Preview X32.
Drivers and Hardware
Audio/video issues in build 10051 and 10056
Ok I have an HP Spectre XT 15 touchsmart with IDT high definition audio drivers with beats. Recently when installing 10051 build. My sound and video would play fine then after a little bit my sound would start to slow down,crackle and lag. The video...
Drivers and Hardware
video driver won't work with 9926
My ATI Radeon Express 1150 video driver won't work correctly with the 9926 preview version but worked with the previous version very well. The microsoft basic driver provides very slow and jerky video and is almost unusable. When booting with the...
Drivers and Hardware
Looking for correct video card driver
I'm using Win10TP 64-bit. I'm having trouble finding a correct driver for my NVIDIA GeForce 8600GT PCIe card. The OS just lists my driver as "Microsoft Basic Display Adapter". I did find one link below that lists a bunch of drivers for this cards...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:11.
Find Us
Twitter Facebook Google+



Windows 10 Forums