Windows 10: Problem with my USB devices on Windows 10. Solved

Page 1 of 2 12 LastLast
  1.    28 Aug 2016 #1

    Problem with my USB devices on Windows 10.


    Hello people!

    I recently switched back to Windows 10 from Windows 7. I had to completely reinstall my system because of some driver fault. And then i went with Windows 7 for about a week without any problems. Now i decided to switch back to Windows 10 and after the first restart, Windows decided not to boot at all. It froze at the login screen. After 10 minutes of waiting, i decided to change some settings in my BIOS, mainly xHCI and EHCI support to off and Full USB Initialization instead of Half. Then, Windows booted sucessfully, however, no USB device worked, with the exception of those plugged into an USB2.0 Port. After relocating the important USB devices to USB2.0, everything worked and i tried to reinstall the USB3.0 driver from my Mainboard manufactor page. With no luck. Enabling xHCI and EHCI back resulted in Windows not booting up, and disabling those resulted in USB3.0 not working. So now i am here, with my keyboard and mouse plugged into USB2.0.

    Is there anything you guys know of i could try to get these things to work again?


    Thanks in advance!


    System :
    ASUS STRIX X99
    Windows 10
    Logitech G710+ and G502
    I think the rest is not interesting to this issue. If it may be, feel free to ask.
      My ComputerSystem Spec

  2.    28 Aug 2016 #2

    There are boot issues on all x99 chipsets and USB3 AKA xHCI as even USB2 uses xHCI , typically it is an older USB2 device ( HUB in Monitor for me ) which cause the computer to stop the boot process , in my case no setting helped with the monitor as NEC has not updated it's USB Firmware, but most of my other USB items I was able to find newer Firmware for eg Vantec USB3 HUB etc. Some Joysticks are known to cause this too if plugged in at boot.

    Mice and Keyboards don't use USB 3 anyway so nothing to worry about there , and for compatibility best to have them on a USB2 port anyway. Or use the PS2 Port

    Does the Strix have the Error LED/PostCode on the MB? my X99A II does , it can be helpful diagnosing boot issues from the code given.

    Setting the xHCI to Auto instead of smart Auto helps with some USB devices , I found this info online about it

    This is a better explanation of the xHCI settings.


    "XHCI Mode = Disabled
    The on-board USB 3.0 port function like a 2.0 port


    XHCI Mode = Enabled
    The on-board USB 3.0 port function like a 3.0 port


    XHCI Mode = Auto
    The on-board USB 3.0 port function like a 2.0 port before OS USB 3.0 driver load.
    If you reboot the OS, the on-board USB 3.0 port again function like a 2.0 port during this reboot BIOS phase before OS USB 3.0 driver load.


    XHCI Mode = Smart Auto
    The on-board USB 3.0 port function like a 2.0 port before OS USB 3.0 driver load.
    If you reboot the OS, during this reboot BIOS phase, BIOS is "Smart" enough to avoid downgrade the USB 3.0 port back to 2.0 functionality before OS USB 3.0 driver load. So Smart Auto is faster than Auto on 2nd boot onward, but Enabled is fastest once you are sure the OS has the USB 3.0 driver installed, because it avoid the switching. Making the on-board USB 3.0 port function like a 2.0 port is mainly to support OS installation or to support OS that does not have build-in USB 3.0 driver, so that the USB keyboard would still work if the user plug-in a USB keyboard or any other USB devices into the USB 3.0 ports before the OS is installed with the USB 3.0 driver come with the motherboard."
      My ComputerSystem Spec

  3.    29 Aug 2016 #3

    I'll try it out, however, my USB3.0 ports are not working at all, not even as USB2.0 ports.
    Thanks for the advice. I'll give an update as soon as i have news.
      My ComputerSystem Spec

  4.    29 Aug 2016 #4

    @RockCoach
    Does your Motherboard comes with usb 3 ? or are these added usb 3? if yes Motheboard comes with usb 3 then keep looking for the right drivers it is a little hard to find and it will take some research
    if NO there is no much Luck here as on my old pc I had the same problem i had 3 usb 2 ports and 2 usb 3 ports and i never got the usb 3 ports to work,, every time i installed a new driver for the usb3 all usb 2 and 3 stopped working
    to get around that I stayed with only the usb 2 and uninstalled all drivers and disabled usb 3 ports

    I still dont know why this happened but it was Like this

    If you have a motherboard that comes only with usb3 or all usb 3 and only one usb 2 port then the usb 3 will work without any problem

    this is just what happened to me i am sharing it with you, your situation can be different then mine

    good luck
      My ComputerSystem Spec

  5.    29 Aug 2016 #5

    RockCoach said: View Post
    I'll try it out, however, my USB3.0 ports are not working at all, not even as USB2.0 ports.
    Thanks for the advice. I'll give an update as soon as i have news.
    No they won't , you said you disable the xHCI Controller in the OP, that is All your USB 3 ports , on X99 even USB2 is handled via xHCI instead on EHCI , which is why X99 has many issues with this and many older USB 2 Devices can not negotiate Speeds etc properly with the xHCI Controller so it hangs and stops the boot in many cases.

    I found Auto instead of Smart Auto helped with some devices for the xHCI Controller , setting it to Enabled actually made it worse.....
      My ComputerSystem Spec

  6.    30 Aug 2016 #6

    Unfortunately, what you suggested, Kbird, didn't work. I still can only get any devices to work with every option disabled in the BIOS. And i also can just use a very limited amount of USB ports with my PC. Which sucks, since i have a bunch of USB devices i cant use now because of that. The issue is Windows 10 only, so i think the mainboard is not at fault/damaged.
      My ComputerSystem Spec

  7.    30 Aug 2016 #7

    Some things to try and how I figured out my Boot issue:

    Make note of any Post Codes on the LED when you fail to boot

    Unplug ALL USB devices and try booting with ALL xHCI etc on Smart Auto in the bios , if no boot try it on Auto

    If one of above works , plug in 1 USB device and see if it boots , keep trying 1 device at a time until you find the device causing the Boot issue . Now Leave it unplugged.

    Then try adding one device at a time and test boot to see if you can still boot successfully .

    Took me a while , but it was how I figured out my Monitor's USB HUB is not compatible with the X99 Chipset on my X99A II.

    KB.
      My ComputerSystem Spec

  8.    01 Sep 2016 #8

    I tried everything, as suggested, however, with no effect. While Windows 10 does boot now, if these options are enabled, no USB device works, not even in the USB 2.0 ports.
      My ComputerSystem Spec

  9.    01 Sep 2016 #9

    Asus released a new Bios yesterday 0903 if you are willing to try it....

    So what happens if you set optimised Defaults on the bios ?
      My ComputerSystem Spec

  10.    01 Sep 2016 #10

    As i mentioned, if i set it to optimised Defaults, the settings go to :
    Intel xHCI Mode : Smart Auto
    EHCI Legacy Support : Enabled
    xHCI Hand-off : Enabled
    EHCI Hand-off : Disabled.

    Fast Boot : Enabled
    USB Support : Half Initialization

    And unless the upper four are disabled, no USB device works, no matter the port. When i disable them, only the USB 2.0 ports seem to work.

    I'll try the BIOS if i get back home from work.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Hi there Not sure whats happening here but getting multiple displays for the same devices !!!! Any fix, or is system Broken. 83419 Cheers jimbo
In Windows 7, if I needed to grab something off the desktop of one of my other boxes, I would just run something like the following... \\COMPUTERNAME\c$\users\myself\desktop and it would open an explorer window to that folder on that box. ...
http://i.imgur.com/rzy1xGn.png As you can tell from looking at this; there are Outdated Devices / Drivers. :shock: Problem that I have is that I apparently MUST purchase the Software in order to update them. So, can someone please help me?...
I have a network of Virtual machines some Windows 7 and 2 Windows 10. One of the Windows 10 I installed 10122 from an ISO and have had to restore back to 10074 because of a failure to connect to the other machines on my LAN. The other was upgraded...
Hi there when running msinfo32 to get the system details I see a sub category Problem devices --- shows everything is working - but it confuses me as I assume a header that says problem devices means DEVICE NOT working or HAVE a problem. I...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:54.
Find Us