Windows 10: Windows 10 v1607: Logitech TRB-22 Wireless Trackman Problems...

Page 3 of 5 FirstFirst 12345 LastLast
  1.    07 Sep 2016 #21

    Thanks for the effort, Kbird. Hopefully, MS will fix the issue; or, at least maybe someone else can come up with a fix. Then again, there may not be any fix as Logitech has discontinued the trackman and thus MS may not feel "obliged" to correct things. I think my next best option if no fix is forthcoming, would be to get the Logitech M570...although it won't come close to the TRB-22's functionality.
      My ComputerSystem Spec

  2.    07 Sep 2016 #22

    Keep in mind on the M570 the ball is thumb operated, and its right hand only. No tilt scroll wheel either. Just the basic buttons and two extra forward back buttons.
    Orientation looks to be opposite to the TRB-22's. Ball is on the left and buttons on the right. Might take some getting used too.

    It works great for me as I don't need any extra features. It may not suit others though. I do game with it, FPS mostly, and like aiming with my thumb and shooting with my trigger finger.
      My ComputerSystem Spec

  3.    07 Sep 2016 #23

    I just installed SetPoint6.67.83_64, and no issues I can see. One thing I would try, is open the unifying software, unlink your trackball, and relink it again. You may need a spare USB mouse to do it. You can download just the unifying software, without having to install the full setpoint too. It's what I usually do if I have to link or unlink devices to my unifying dongle. I bought a keyboard mouse combo a while back and only wanted the keyboard. I unlinked the keyboard from the dongle it came with and then linked it to my trackballs dongle. Lets me use just the one dongle, and give the mouse with its original dongle to my father. He then linked his keyboard to the mouse I gave him. We both use Logitech keyboards and mice so that worked out great. It was the exact same mouse he already had, except the buttons weren't worn out, lol.
      My ComputerSystem Spec

  4.    07 Sep 2016 #24

    Are you using the web installer or the full installer for setpoint? And installing the 64 bit version?
      My ComputerSystem Spec

  5.    07 Sep 2016 #25

    At least with me the RB22 does not use the Unifying Software , I think because it uses a "Puck" not a dongle.

    FC ...I am not sure this is a Win10 issue as it been happening to me for years , but certainly Setpoint 6 has had more issues with it. As I couldn't buy another RB22 I got several 4 button Marble Mice instead since they were the closest , with a Finger Ball , but there is no scroll wheel if you like to use that regularly. However they have also disappeared occasionally. I have never like the thumb ball ones but I think that is a personal RSI thing with my Thumb and why I switched to TB's years ago from mice.

    Actually when I 1st switched I used the Kensington Trackballs which I liked too , they are still around.

    Trackballs | Trackball Mouse | Wireless Mouse - Kensington - Kensington


    If I figure out the exact steps I will post back here....
      My ComputerSystem Spec

  6.    07 Sep 2016 #26

    AH, OK, not Unifying. At one time I can remember double checking the boxes when buying, to make sure they were unifying, and not the other wireless variant. I bought one marble mouse and quickly returned it when I discovered it didn't have a dedicated scroll wheel. That setup just confused the hell out of me?

    The thumb ball versus finger ball preference is almost as polarized as the trackball versus mouse debate, lol. Like you say, if you have hand or finger issues, one type just won't work for you. Kensington and Logitech seem to be the predominant makers of trackballs. I'm not sure I'd buy from anybody else.
      My ComputerSystem Spec

  7.    07 Sep 2016 #27

    I checked my downloads folder FC and on one system I have 8 versions of Setpoint I tried it looks like 610 being the earliest , on the other system 9 versions , the earliest is 480 , so maybe I did follow the age old fix and go back to Setpoint 4 1st , then upgrade?

    I just found a link that says to do that XP fix and then install version 4 to fix it too

    Fix Setpoint Mouse Tab Missing in Windows 7 or 8 via CMD and Setpoint 4.24

    and here is one I have not seen before , saying to disable UAC during install if you use it..... others in the thread also say Version 4 works for them.

    Solved Logitech Setpoint


    If you try again I would uninstall all Logitech SW and also delete all the files in C:\Program Files\Logitech\SetPointP , which I did too at one point.


    KB.
      My ComputerSystem Spec

  8.    07 Sep 2016 #28

    And two more slight different fixes , which point to it being a Administrator Issue too.


    My fix was slightly different and SetPoint now works. I’m running Win 8.1 x64 Pro
    1. Open Task Manager with CTRL-SHIFT-ESC and select Processes.
    2. Click on each Logitech process and click the End task button to close each of them in turn, and then close the Task Manager.
    3. Go to c:/Program Files/Logitech/SetPointP.
    4. Scroll down to SetPoint.exe.
    5. Right click on it, select Properties.
    6. Click the Compatibility tab.
    7. Click the Change settings for all users button.
    8. Check the box Run this program as an administrator
    9. Click OK, again click OK
    10. Click the start button > Control Panel > Mouse. In the Mouse Properties window you should see the SetPoint Settings tab,

    11. Click the SetPoint Settings tab and you should then see the SetPoint Settings window
    12. Voila! Problem solved – for a while, at least, probably until one needs to complete the routine all over again.

    --------------------------------------------------------------------------------------------------------------------------------------------

    Here’s how I solved the problem with Windows 8 (if you’re running Win7, give it a try and let me know if it works):


    Open Task Manager with CTRL-SHIFT-ESC and select Processes.
    Right click on Logitech KHAL Main Process and Logitech SetPoint Event Manager (UNICODE), select End task to close each of them in turn, and then close the Task Manager.
    Go to c:/Program Files/Logitech/SetPointP.
    Scroll down to SetPoint.exe.
    Right click on it.
    Select Run as administrator, and
    Voila! Problem solved – for a while, at least, probably until one needs to complete the routine all over again.


    Update:


    If you create a desktop shortcut to SetPoint.exe like I did, you won’t have to continually drill down into Program Files. All you have to do is right click and select Run as administrator after exiting the SetPoint icon in the Task Manager.
    I have discovered that if I select Show hidden icons on the Taskbar, right click on the Logitech icon and select close, then all I have to do is the first bullet point, above. There’s no need to go into the Task Manager at all.


    both found here on a Blog about the issue

    Logitech Setpoint missing mouse and keyboard tabs fixed | on the road
      My ComputerSystem Spec

  9.    07 Sep 2016 #29

    Hey Kbird, tried everything to no avail.
      My ComputerSystem Spec

  10.    07 Sep 2016 #30

    Holy Wow really , , sorry to hear that , I'd suggest the Marble Mouse in the mean time as it is relatively cheap and has 4 buttons but that might lead to the same issue being Logitech on your current system. Though I have both running here ATM. Perhaps get at BestBuy or staples or somewhere with an easy return policy if it acts up too , with any luck installing it my "fix" the registry and allow
    both too show , that works here , I have a MM on each system on USB and use the TrackMan on PS2 so it will still Wake the system if I want it too.

    even Version 4 Setpoint didn't work? or wouldn't it install ?

    Oh.... did you try PS2 ? with the Converter or vica versa try USB instead , with the Green converter.



    Well next time I have to reinstall Win10 , I will have to make better notes


    KB.
      My ComputerSystem Spec


 
Page 3 of 5 FirstFirst 12345 LastLast

Related Threads
Dear all, I have this issue that has been driving me nuts ever since I upgraded my Windows 10 Pro x64 to v1607 (from 1507) recently. It's a desktop PC with a trusty old Logitech MX518 plugged into a back panel USB 2.0 slot. Same symptom with or...
We have a new (albeit old) wireless printer (HP Color laserjet CP3525) with a wireless adapter card. Computers running Windows 7 or Windows 8 could see the network and connect. All computers could then print to the printer. None of our computers...
Hello, On my old PC running W7, I used it with a Logitech MK 300 wireless Keyboard and with atheir Wireless Mouse. Worked just fine. Would like to use them both with my new W10 PC. The Wireless Mouse works just fine. I cannot get the...
This is a wireless keyboard and mouse wirelessly connected via a Logitech USB unifying receiver. The mouse works fine, and strangely the hot keys on the keyboard (mail, calculator, sleep etc) work fine. However, after booting into W10 the normal...
Haven't found other threads dealing with this, but I'm trying to figure out if there's a way to get my wireless display adapter working properly in Win10 (worked great with my Surface Pro 3 with Win 8.1 - I'm on Win 10 build 9926 at the moment). ...

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 18:54.
Find Us