Windows 10: Odd problem with USB device Broken Error

  1.    23 Aug 2016 #1

    Odd problem with USB device Broken Error

    I have a faulty 64Gb USB stick and every time iI insert it I get the Broken device not recognised error and I click the error off. Occasionally the message pops up after about five minutes that the device is installed and it is recognised as a valid USB device; but it has 0 bytes memory??? I gave up and removed the USB Stick. Then I noticed something odd when I tried to Play a video on YouTube; the same thing happened playing an audio file... The Speaker Icon in The Notification section of the Task bar is meant to allow you to set the system volume etc.. The volume was too high even when turned down in the You Tube or Audio player. So I went to the Volume icon and it was gone. The only way I could get it back was to restart the Computer. Why should a USB Device error remove the Volume control? Windows 10 is getting quirkier by the day. It's not a real issue; but I would love to know the connection to the Unknown/Faulty USB device error and Sound control. Anyone? And before you ask...No I have not Updated to the Anniversary Update yet. (and after seeing the issues people are having I don't want to)
      My ComputerSystem Spec

  2.    23 Aug 2016 #2

    Sorry about Your Problems

    But this is one solution to help you out with your usb ( note this is not related to you speakers or sound system )

    Install Gparted reboot live CD you usb should be inserted

    format / delete and make new drive with NTFS and Switch from 4096 to 8192 bytes

    this way if there was any virus or any thing on that usb Gparted should take care of it
    Use this Link or just go to google and search for Gparted

    Good luck
      My ComputerSystem Spec


Related Threads
Problem with USB Audio Device? in Drivers and Hardware
My headset (HyperX Cloud2) doesn't show up here. 67676 It's microphone doesn't show up here either... 67677 So I checked my device manager. 67675 and when I tried to update the drivers, I got this error. 67678 Thank you for the help, I...
During Windows backup, which wants to backup the 'C' drive and my games drive 'E' (for some reason), I get the following error message after the 'C' backup has completed but not the 'E': 'The backup operation that started at...
Device manager problem in Drivers and Hardware
Since upgrading to Win 10 I have these "other devices" flagged. I have tried updating each and get the same results. I tried deleting them, but when re-discovered them I get the same flags. Pic attached. I have a Gigabyte GA-Z87X-UD5H mb, an i7...
Audio device problem in Performance & Maintenance
I'm hoping someone has come across a resolution for this. So I have a Soundblaster Z audio card. Now I don't use all the outputs so I put it on stereo front speakers, instead of 5.1 However every time I turn on my pc I have to change that...
Hello, Ive been recently having a problem with duplicated items in taskbar and broken Jump Lists. Im now using Windows 10 but this problem occurred in Windows 8.1 too but then it somehow fixed itself. Some programs that I pin to taskbar have...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:58.
Find Us