I have a very strange printer problem. I have a very good but bit older PC with an HP Laserjet 4000.

I have used this printer and this PC originally with Windows 7, 8 and 8.1 with no problem. I upgraded to Windows 10 last year and still no problem with this PC and printer.

Then a few days ago it stopped printing - it appears that no data is being received by the printer from the PC. No changes were made to the PC. The printer is attached to a network and it prints fine from my Macbook Air and an old Mac Mini that are also attached to the network.

I tried deleting the printer and then adding it again but get the error message "Unable to install printer. Dynamic Link Library ("DLL") Initialization Routine Failed"

Even stranger, one time after I shut down and restarted both the printer and PC the Laserjet 4000 did install and print for a few minutes, then it stopped working again. I have been unable to successfully install the printer again.

Any ideas how to solve this problem? Thanks.