I just purchased an Alienware 17R3 running Windows 10.
My BIOS, drivers and Alienware/Dell applications are up to date, thanks to my tech support phone call today.
When I start my laptop, if it has been sitting more than 30 minutes, I have several keys fail to respond.
The keys are 4, 5, e, t y, f, g, v, b. ( I have to double check to be sure of the exact keys.)
If I leave the laptop on for 5-10 minuets they will eventually start to work.
Once it starts working, I can use the computer as much as I want to, restart it or shut it off for less than 30 minutes, and the keys will continue to work.

I then ran the two tests.
I started the computer, after letting it sit for 30 minutes, and verified the keys mentioned did not work. I then attached a Bluetooth keyboard and all of the keys did work. I then tried the laptop keyboard again, and it still did not work.

I let the computer sit and verified the e key did not work. I then rebooted the laptop using a clonezilla usb key. All of the keys worked immediately.
I then restarted the laptop and booted into windows. All of the keys immediately worked.
* I don't know if it has any bearing on the situation, but in order to boot from the USB stick, i had to turn off UEFA and enable legacy boot support. I then had to re-enable UEFA in order to boot from windows.

I am kind of stumped. I would rather not reinstall windows.

Any thoughts?