Marvell 92XX SATA Controller 6GB Driver for Windows 10 1.2.0.1039-WHQL

Page 4 of 5 FirstFirst ... 2345 LastLast

  1. Posts : 12
    Windows 10 64 Home Home Edition
       #31

    tried checking properties no policy tab, uninstalling the system devices Marvell 91xx driver the system won't boot, blue screen then after entering safe mode and reboot drives get recognized as IDE no trim and performance loss, I'm only seeing the Marvell driver for system devices in control panel I added it's bus number to the TreatAsInternalPort. reg. value but the safely remove USB icon is still present in tool bar with no devices listed under itMarvell 92XX SATA Controller 6GB Driver for Windows 10 1.2.0.1039-WHQL-screenshot-15-.pngMarvell 92XX SATA Controller 6GB Driver for Windows 10 1.2.0.1039-WHQL-screenshot-17-.pngMarvell 92XX SATA Controller 6GB Driver for Windows 10 1.2.0.1039-WHQL-screenshot-18-.png
    Last edited by Xenon 775; 07 Mar 2021 at 17:00.
      My Computer


  2. Posts : 9
    Windows 10 20H2 (19042.804)
       #32

    Xenon 775 said:
    tried checking properties no policy tab, uninstalling the system devices Marvell 91xx driver the system won't boot, blue screen then after entering safe mode and reboot drives get recognized as IDE no trim and performance loss, I'm only seeing the Marvell driver for system devices in control panel I added it's bus number to the TreatAsInternalPort. reg. value but the safely remove USB icon is still present in tool bar with no devices listed under it
    As per my previous post; assuming an entry existed to uninstall the Marvell drivers from the system via Control Panel > Program And Features (not Device Manager):

    Windows has determined that the previously installed Marvell drivers contained a better match for that device than its original "generic" Microsoft version and therefore preserved the .INF.


    The TreatAsInternalPort registry setting is specific to the Microsoft "Standard SATA AHCI Controller" (registry: MSAHCI); it likely won't apply when the Marvell drivers are installed.

    Couple of questions ...

    • What controllers are available under "IDE ATA/ATAPI Controllers" and what Driver Provider is displayed on the Driver tab?
    • What controllers are available under "Storage Controllers" and what Driver Provide is displayed on the Driver tab?



    Typically, controllers will appear in Safely Remove Hardware And Media when they have been detected as "Hot Plug" capable - i.e. devices can be connected/disconnected while the system is operational (powered on).
      My Computers


  3. Posts : 12
    Windows 10 64 Home Home Edition
       #33

    Marvell 92XX SATA Controller 6GB Driver for Windows 10 1.2.0.1039-WHQL-screenshot-19-.png actually it removed the appearance of Marvell 91xx under removable USB safely remove hardware when I added the bus number to the reg. key TreatAsInternalPort

    - - - Updated - - -

    Marvell 92XX SATA Controller 6GB Driver for Windows 10 1.2.0.1039-WHQL-screenshot-20-.png
      My Computer


  4. Posts : 426
    Windows 11 pro X64 latest
       #34

    The registry fix for the policy tab don't work anymore. Also keep in mind that with the Marvell driver after 20h1 windows, it see the ssd if you have connected one there as hdd.
      My Computers


  5. Posts : 9
    Windows 10 20H2 (19042.804)
       #35

    boombastik said:
    The registry fix for the policy tab don't work anymore. Also keep in mind that with the Marvell driver after 20h1 windows, it see the ssd if you have connected one there as hdd.
    I'm running Windows 10 (20H2) with an Adaptec controller card that is based on the Marvell chipset for quite some time now without issues. Have a look at the following topics in this thread.

    Unless you're using RAID, you likely won't need to install the drivers; or at the very least, you may only require some of the driver components. If you are using RAID, the controller handles the SSD trimming and reports back to Windows that the array an HDD.

    HQL Driver Differences (1.2.0.1039 <-> 1.2.0.1049)
    Internal SATA Shows As Removable
      My Computers


  6. Posts : 58
    Windows 10 Pro 64bit 21H2 19044.1503
       #36

    I've got a GA-Z68XP-UD3 (rev 1.0) motherboard and am not using the Marvell drivers. When I installed Win 10 Pro I just let it do whatever. Not having any system issue/s but I've always noticed all my internal (x4) SSD drives do appear under the 'Safely Remove Hardware and Eject Media' such as C: , D:, E:, F:

    Haven't been concerned given I know not to remove them especially the system drive while running the PC.

    Is there any benefit to installing the Marvell drivers vs just letting Windows 10?

    When I installed Windows 10 I did not use any of the drivers from Gigabyte given their age. Should that be a concern? See 'My Computer' for full specs.

    I notice that on the Gigabyte site for my board that under Windows 10 there are only (2) choices under 'Driver>(+2)

    1. Intel Management Engine Interface

    2. Intel INF Installation

    Whereas under Windows 8.1 (64bit) there are...

    options (5) under SATA RAID/AHCI...

    1.
    Intel SATA Preinstall driver
    (For AHCI / RAID Mode)
    Note: Press F6 during Windows setup to read from floppy.


    [12.8.0.1016]

    2.
    Intel Rapid Storage Technology


    [12.8.0.1016]

    3.
    Marvell Preinstall Driver
    Note: Press F6 during Windows setup to read from floppy.


    [1.2.0.1035]

    4.
    Marvell SATA Controller Driver
    [1.0.0.1062]

    5.
    Marvell Storage Utility
    [4.1.0.2022]
      My Computers


  7. Posts : 3
    windows 10
       #37

    hi everyone-

    just did an install and post installed the marvel sata achi drivers ( didnt f6 it in the preinstall environment)
    1.2.0.1039-WHQL
    and update to Marvell_SATA_V1.2.0.1047

    I got trim confirmed with fsutil query disabledeletenotify but optimization is not available for the drive?
    its currently on the intel driver on a second controller with sata II but would like the extra read speed since its an old x58 board
      My Computer


  8. Posts : 58
    Windows 10 Pro 64bit 21H2 19044.1503
       #38

    r3nimator said:
    hi everyone-

    just did an install and post installed the marvel sata achi drivers ( didnt f6 it in the preinstall environment)
    1.2.0.1039-WHQL
    and update to Marvell_SATA_V1.2.0.1047

    I got trim confirmed with fsutil query disabledeletenotify but optimization is not available for the drive?
    its currently on the intel driver on a second controller with sata II but would like the extra read speed since its an old x58 board
    I had the very same issue on my Z68 board. Ended up just letting Windows 10 supply the driver. The GSATA Marvell chipset likely would need a firmware upgrade (very risky). Not worth bricking the board.

    See the following thread I started...PCIe x1 SATA card | TechPowerUp Forums

    Before the Marvell drivers....
    What is your AS SSD Benchmark score? | Page 15 | TechPowerUp Forums

    After the Marvell drivers (latest version same as you)...What is your AS SSD Benchmark score? | Page 16 | TechPowerUp Forums


    Another option you may try is to but a SATA PCIe add on card and install it into a PCIe slot. Then move the drive/s to the add on card.
      My Computers


  9. Posts : 3
    windows 10
       #39

    Thanks for the reply-

    as for 1st install
    I did a quick install without the drivers initially-
    and by the end of it i was in ide mode with sata III link
    and i/o was roughly 350Read 250Write off of AS SSD
    not sure what driver took precedent but i regret not leaving it that way as
    would have wanted to have ACHI support queueing etc. so i kind of did myself in.

    second time im on achi mode in bios and i got 250/250 in AS SSD dont quite understand it
    also had to enable trim service, and do the usual self verification.

    i should also mention its on a ich10R intel chipset, so sata II on four ports
    and marvel and their "SATA 6g" on 2 ports.
    Last edited by r3nimator; 16 Sep 2021 at 10:29. Reason: clarity
      My Computer


  10. Posts : 58
    Windows 10 Pro 64bit 21H2 19044.1503
       #40

    r3nimator said:
    Thanks for the reply-

    as for 1st install
    I did a quick install without the drivers initially-
    and by the end of it i was in ide mode with sata III link
    and i/o was roughly 350Read 250Write off of AS SSD
    not sure what driver took precedent but i regret not leaving it that way as
    would have wanted to have ACHI support queueing etc. so i kind of did myself in.

    second time im on achi mode in bios and i got 250/250 in AS SSD dont quite understand it
    also had to enable trim service, and do the usual self verification.

    i should also mention its on a ich10R intel chipset, so sata II on four ports
    and marvel and their "SATA 6g" on 2 ports.

    The Marvell GSATA ports are likely 500mb combined (sharing) and if you have (2) drives connected to the ports it will be 250. I ended up buying a PCIe x1 SATA adapter to install in one of my (x1 slots). My other PCIe x16 slot is occupied by my 3.2 USB adapter card so that slot is a no go. The card I bought was...

    https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:38.
Find Us




Windows 10 Forums