Windows 10: Latest Realtek HD Audio Driver Version

  1.    1 Week Ago #1511

    bisko said: View Post
    This one is the nvidia hd audio. Is it possible the onboard audio is wrong? Because even if there is no drivers isntalled i think i should see it in the device manager.
    The AL1220 is not the Nvidia HD Audio. but it looks like your Nvidia HD Audio is also using the Microsoft Driver , not the Nvidia HD Audio Driver, but I also use the M$ Driver as the Nvidia Driver causes my BenQ Monitor not to wake properly from sleep.

    You are correct the Realtek 1220 HD Chip should be showing in DM even if you don't do anything , Win10 would install Drivers even if you didn't .....if it found a Hardware Device......it's not disabled in the Bios is it? is it set to HD Audio or AC97 in the Bios?

    Perhaps you should contact AsRock T.S. too ....hopefully it is not a faulty Motherboard.
      My ComputerSystem Spec

  2.    1 Week Ago #1512

    Set to HD and onboard audio is enabled in BIOS.
      My ComputerSystem Spec

  3.    1 Week Ago #1513

    bisko said: View Post
    Set to HD and onboard audio is enabled in BIOS.
    Have you looked through DM in ALL the sections to see if it is being detected incorrectly and listed in the wrong place ?

    I am sorry I can't think of anything else to try , you should try the AsRock Forums and their Tech. Support ( T.S.) I think.
      My ComputerSystem Spec


  4. Posts : 284
    Windows 7 Home Premium x64
       1 Week Ago #1514

    bordo38 said: View Post
    hello which driver do you recommend?

    asus m5a97 r2
    Realtek® ALC887
    windows 10 rs4
    I answered this question in Station drivers forum.

    Kbird said: View Post
    The AL1220 is not the Nvidia HD Audio. but it looks like your Nvidia HD Audio is also using the Microsoft Driver , not the Nvidia HD Audio Driver, but I also use the M$ Driver as the Nvidia Driver causes my BenQ Monitor not to wake properly from sleep.

    You are correct the Realtek 1220 HD Chip should be showing in DM even if you don't do anything , Win10 would install Drivers even if you didn't .....if it found a Hardware Device......it's not disabled in the Bios is it? is it set to HD Audio or AC97 in the Bios?

    Perhaps you should contact AsRock T.S. too ....hopefully it is not a faulty Motherboard.
    I kinda had this problem with an old proprietary HP M2N68-LA Narra board for an HP computer where the Realtek HD Audio device sometimes won't show up in Device Manager. when that happens the "High Definition Audio Controller" device in System Devices section of Device Manager may have also disappeared as well, taking the Realtek audio device with it. Eventually it turned out to be a faulty board and had to be replaced.

    There should be two instances of High Definition Audio Controller device in the System Devices section of Device Manager for the ASRock board, bisko; one for nVidia HD audio and the other for Realtek audio. It was like this with my Gigaybte 78LMT-USB3-R2 board that has AMD HD Audio & Realtek ALC892 audio and has two instances of High Definition Audio Controller devices listed in Device Manager.
    Last edited by erpster4; 1 Week Ago at 14:09.
      My ComputerSystem Spec

  5.    1 Week Ago #1515

    erpster4 said: View Post
    I answered this question in
    erpster4 said: View Post


    Thank you

    HDAUDIO\FUNC_01&VEN_10EC&DEV_0887&SUBSYS_10438444&REV_1003
      My ComputerSystem Spec


  6. Posts : 284
    Windows 7 Home Premium x64
       1 Week Ago #1516

    Cliff S said: View Post
    Support for new hardware, CODEC, DAC; and improvements for things like Sonic Radar, Sonic Studio(ASUS) for gamers to hear direction of sound?
    maybe even improve compatibility with the newest Win10 release (1809/RS5)
    need at least 8540 something (or 8550+) when running Windows 10 v1809

    Cromax said: View Post
    i tried hdxrog.inf but didnt work .. but i installed from station drivers even though i dont like generic drivers because they arent optimized for specific hardware
    but did you uninstall the old Realtek audio drivers first either thru Programs and Features control panel or Device Manager before installing the new ones as I suggested (like in this example)?

    when I remove/uninstall existing Realtek audio drivers thru Device Manager I check the box that says "Delete the driver software for this device" to remove the drivers completely, then I reboot and then attempt to install the newest Realtek audio drivers.
    Attached Thumbnails Attached Thumbnails realtek-hda-uninstall-devmgmt.png  
      My ComputerSystem Spec


  7. Posts : 284
    Windows 7 Home Premium x64
       5 Days Ago #1517

    8551 HDA was recently mentioned in the Station Drivers forum, a few hours ago (at last a new driver version in the 8550s)
    since I didn't try out any of the 854x versions except 8541 on a few machines, I'm updating many of them that have Realtek audio chips to 8551.
      My ComputerSystem Spec

  8.    5 Days Ago #1518

    erpster4 said: View Post
    8551 HDA was recently mentioned in the Station Drivers forum, a few hours ago (at last a new driver version in the 8550s)
    since I didn't try out any of the 854x versions except 8541 on a few machines, I'm updating many of them that have Realtek audio chips to 8551.

    Hey erpster, could you explain why you chose to ignore the 854x updates?
    Anything new re the 855x?
      My ComputerSystem Spec

  9.    5 Days Ago #1519

    8551 is a lot more neutral than 854x
      My ComputerSystem Spec

  10.    5 Days Ago #1520

    khanmein said: View Post
    8551 is a lot more neutral than 854x
    Well if that means better, it certainly is here! I'm leaning towards 8551 being the best driver ever, or at least in quite a while.
      My ComputerSystem Spec


 

Related Threads
Hello : I have my realtek driver tweaked in windows 7 , I have it set in the registry to have 2 outputs , instead of one - will the new win 10 driver be able to be adjusted ... Thanks
Hello Everyone. I have a Jabra bluetooth speaker (the Solemate Mini). On Windows 8.1 I plug it in to my laptop using the 3.5mm to 3.5mm cable and then, when I watch a movie, it correctly outputs to the speaker and does not use my laptop speakers....
New RealTek HD Audio Driver available in WU. 18634
My ASUS M4N68T-M V2 has a VIA VT1708S onboard audio. The driver I have that worked in Windows 8.1 v10_1200a won't work in 10. Windows doesn't even see the onboard video so it doesn't even look for a driver. It doesn't show up in device manager. In...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 20:14.
Find Us