Latest Realtek HD Audio Driver Version

  1.    13 Sep 2018 #1421

    Kbird said: View Post
    I just got a MSI Laptop replaced and setup the last couple of days,every working fine, but tonight WU updated some A-Volute extensions and the Realtec APP and now the Realtec App no longer works ? so YMMV even if you do get it to work..... I should of blocked Hardware updates from WU by the look of it...

    Anyone have an idea on how to Roll UWP Apps back ?
    Thankfully the Realtek with Nahimic UAD 8531 got the Realtek Drivers and Console working again , on reboot the RT Console was auto Updated to 1.2.137.0 and it is working again as is the Nahimic App.

    1.2.136.0 was working before the reboot though , so I guess it doesn't work with 8522 UAD Drivers? and that was my issue???

    I got them over on Station Drivers page 22 of the Realtek Thread or the Realtek Thread on LaptopVideo2Go page 25.
    ( I think I read I am not allowed to link to them for you sorry)
      My ComputerSystem Spec


  2. Posts : 316
    Windows 7 Home Premium x64
       13 Sep 2018 #1422

    Ryoken said: View Post
    I don't have the 'Software components' devices at all (Except an Intel Graphics one). Just the normal sound card, which shows up as 'Realtek High Definition Audio'. As with previous times, installing those drivers and rebooting, still no joy. Even tried DUU to ensure there was no trace of previous drivers.
    see attached picture, Ryoken -

    Click image for larger version. 

Name:	devmgr-realtek-components-listed.png 
Views:	127 
Size:	24.7 KB 
ID:	203826


    You need "Extension INFs" like HDX_GenericExt_RTK.inf to get the Realtek Software components listed in Device Manager. that can only be done after installing/updating the main or base INF file (like HDXRT.INF) of the Realtek UAD driver, not the Realtek HDA driver.

    AND Device Manager can NOT understand/process extension INF files as noted in this Microsoft document:
    https://docs.microsoft.com/en-us/win...sion-inf-files

    The reason Extension INFs cannot be published as optional is because they are not listed in Device Manager for an end user to initiate an “Update Driver” action.
    you must use either pnputil.exe or DriverStore Explorer [RAPR] to install a Realtek "extension" INF file like HDX_GenericExt_RTK.inf after installing the main/base INF file like HDXRT.INF from the Realtek UAD driver.
    Same applies when removing/uninstalling the "extension" inf file - use pnputil.exe or RAPR to accomplish this.

    Also extension INFs are NOT included in Realtek UAD driver cab packs from MS Update Catalog. sometimes extension INFs are included in OEM based Realtek UAD driver packs from PC makers / OEMs or the "generic" Realtek UAD drivers from Github.

    Ask alanfox2000 of GitHub on how to install Realtek UAD main driver, along with installing Realtek extension INF file - he has written a guide here.

    need an older version of the Realtek audio console, Kbird? you can find them here. (no option to rollback older versions of that - just uninstall it, reboot and install an older version)
    Last edited by erpster4; 13 Sep 2018 at 17:50.
      My ComputerSystem Spec

  3.    13 Sep 2018 #1423

    My mobo is: ASRock Fatal1ty H97 Performance LGA 1150 Intel H97

    And my current realtek driver is 6.0.1.7560 (07/15/2015). Is that the most recent one I can upgrade to? When I try to update it, I'm told the best drivers for my device are already installed.

    I'm having issues with Camtasia and the only thing I haven't fiddled around with or researched up are my audio drivers. Curious if that is the most recent one for me.

    Thank you for any help.

    eta Windows 10 64 bit and no sound card. I do have AMD HD Audio Device (10.0.1.7) installed for my gpu and to use the audio coming from my monitor (Microboard M340CLZ).
      My ComputerSystem Spec

  4.    14 Sep 2018 #1424

    MuteRecording said: View Post
    My mobo is: ASRock Fatal1ty H97 Performance LGA 1150 Intel H97

    And my current realtek driver is 6.0.1.7560 (07/15/2015). Is that the most recent one I can upgrade to? When I try to update it, I'm told the best drivers for my device are already installed.

    I'm having issues with Camtasia and the only thing I haven't fiddled around with or researched up are my audio drivers. Curious if that is the most recent one for me.

    Thank you for any help.

    eta Windows 10 64 bit and no sound card. I do have AMD HD Audio Device (10.0.1.7) installed for my gpu and to use the audio coming from my monitor (Microboard M340CLZ).
    Use the Device ID to confirm the Sound Chip but it appears to be the ALC 1150 from the MB Page, which would mean the latest Full 8531 generic Drivers (FF00) should work. I would suggest a Full Driver package since it has been so long since you upgraded. See this post and the one 2 below it to see if your HW ID is the same one :

    Station-Drivers - [DRIVERS] Realtek High Definition Audio Codecs (HDA/UAD) - Page 23 - STATION-DRIVERS

    Use this page to learn how to get your HW ID number if you don't know how :

    How to Find Drivers for Devices Using a Hardware ID | Dell Australia
      My ComputerSystem Spec

  5.    14 Sep 2018 #1425

    8536 > 8531
      My ComputerSystem Spec


  6. Posts : 12
    Windows 10-64bit Pro
       14 Sep 2018 #1426

    Kbird said: View Post
    Use the Device ID to confirm the Sound Chip but it appears to be the ALC 1150 from the MB Page, which would mean the latest Full 8531 generic Drivers (FF00) should work. I would suggest a Full Driver package since it has been so long since you upgraded. See this post and the one 2 below it to see if your HW ID is the same one :

    Station-Drivers - [DRIVERS] Realtek High Definition Audio Codecs (HDA/UAD) - Page 23 - STATION-DRIVERS

    Use this page to learn how to get your HW ID number if you don't know how :

    How to Find Drivers for Devices Using a Hardware ID | Dell Australia
    God Bless you. Thanks for fixing my MaxxAudio from Dell. It really drove me crazy on this forum cuz i could't improve my audio quality.
      My ComputerSystem Spec

  7.    14 Sep 2018 #1427

    realtek universal console version ending in 39 doesnt work after it installs. says its not for my machine. I found version ending in 36 and uninstall 39 and install 36 and now working again.


    but had to disable auto update for the store because it keeps replacing it with the none working version.


    I was hoping that by updating the drivers, that the audio quality in Forza Horizon 4 demo would improve but stills sounds like music played over dialup connection.
      My ComputerSystem Spec

  8.    14 Sep 2018 #1428

    Thank you very much for the updated link!
      My ComputerSystem Spec

  9.    14 Sep 2018 #1429

    Kbird said: View Post
    Use the Device ID to confirm the Sound Chip but it appears to be the ALC 1150 from the MB Page, which would mean the latest Full 8531 generic Drivers (FF00) should work. I would suggest a Full Driver package since it has been so long since you upgraded. See this post and the one 2 below it to see if your HW ID is the same one :

    Station-Drivers - [DRIVERS] Realtek High Definition Audio Codecs (HDA/UAD) - Page 23 - STATION-DRIVERS

    Use this page to learn how to get your HW ID number if you don't know how :

    How to Find Drivers for Devices Using a Hardware ID | Dell Australia
    I did not know that. Thank you for both information.

    And it does match.
      My ComputerSystem Spec

  10.    14 Sep 2018 #1430

    khanmein said: View Post
    8536 > 8531
    Have to agree, they did it again.
      My ComputerSystem Spec


 

Related Threads
Hello : I have my realtek driver tweaked in windows 7 , I have it set in the registry to have 2 outputs , instead of one - will the new win 10 driver be able to be adjusted ... Thanks
Hello Everyone. I have a Jabra bluetooth speaker (the Solemate Mini). On Windows 8.1 I plug it in to my laptop using the 3.5mm to 3.5mm cable and then, when I watch a movie, it correctly outputs to the speaker and does not use my laptop speakers....
New RealTek HD Audio Driver available in WU. 18634
My ASUS M4N68T-M V2 has a VIA VT1708S onboard audio. The driver I have that worked in Windows 8.1 v10_1200a won't work in 10. Windows doesn't even see the onboard video so it doesn't even look for a driver. It doesn't show up in device manager. In...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 10:56.
Find Us