Windows 10: Latest Realtek HD Audio Driver Version

  1.    26 Aug 2018 #1331

    Tonyb said: View Post
    so glad i went to creative looks like they are messing with them again, my sound has never been better with the new sound blaster,if you tired of updating i highly suggest it, the new sound blaster cards are so nice. my days of messing with realtek stuff are past so glad i took the plunge and went to a dedicated sound card.
    Same for me
      My ComputerSystem Spec

  2.    27 Aug 2018 #1332

    pietcorus2 said: View Post
    " 8519 > 8514".........this means you find 8519 better then 8514 ?
    Can you explain why you find this driver better ?
    I think a lot depends on the system. 8519 has a little better clarity than 8514 on my main machine with optical feed into a receiver. Yet, I heard a bit of distortion with 8519 that I don't hear with 8514 on another machine with analog feed into a receiver, so have rolled back to 8514 on that. I'll add that both motherboards support Sound Blaster Cinema (I use Realtek Creative driver versions), so that may have something to do with the difference.
      My ComputerSystem Spec

  3.    27 Aug 2018 #1333

    pietcorus2 said: View Post
    " 8519 > 8514".........this means you find 8519 better then 8514 ?
    Can you explain why you find this driver better ?
    I personally felt it more fealty, but @larc919 stated some statements I also agreed. Let's wait for the next best driver, but I still prefer 8519 more than 8514.
    FYI, I'm not good in describing using the correct terms.
      My ComputerSystem Spec

  4.    27 Aug 2018 #1334

    Guys, I am new to this thread, and I apologise if this kind of thing has been asked before, but can anyone tell me why I just get the surround channels playing through my front speakers in tests like these AAC Multichannel Playback Test
    I am connected via SPDIF to my onboard Realtek HD Audio to my Yamaha receiver.
    Selecting Properties on the Supported formats plays the test DTS and DD files OK.
      My ComputerSystem Spec

  5.    29 Aug 2018 #1335

    I solved the problem - I bought a Soundblaster Z! Hugely superior sound quality, and no issues with surround sound.
      My ComputerSystem Spec

  6.    29 Aug 2018 #1336

    Dealing with Realtek Audio Console; Can't Connect to RPC issues


    I just tried to install and use the new UWP Realtek Audio Console and ran into various issues that I've fixed. Thought other forum members might benefit from what I learned along the way. Bottom line: you can't use the latest 8509 drivers HD Audio drivers and expect the Realtek Audio Console to work. As numerous other posters have observed, the UAD (Universal Audio Drivers) must be installed to avoid the issue where you fire up the console and get an error message that reads "Can't connect to RPC" instead of a working UWP application.

    This requires that one download and install the latest UAD Realtek drivers. Despite what other posters have claimed here -- namely, that it is not a simple task, and not suited for newbies or amateurs -- if you permit the RealTek installer to do its complete thing it does the job. Normally, I don't have the patience to go through two complete reboot cycles just to update a driver so I unpack the various files and use Device Manager to update them directly instead. This time, I endured the 8 minutes or so it took to go through the whole process, and the result was a set of 8501 UAD drivers and a working Realtek Audio Console.

    Where did I get my RealTek UAD drivers? I found a working set at the excellent and reliable French driver site: Station-Drivers.com. Here's a link: https://www.station-drivers.com/inde...d=3572&lang=en.

    If you download and install these drivers, you can then visit the Store and install the Realtek Audio Console. If your experience is the same as mine, you'll get the console working right away.
    HTH,
    --Ed--

    Click image for larger version. 

Name:	image.png 
Views:	87 
Size:	93.1 KB 
ID:	201332

    Click image for larger version. 

Name:	image.png 
Views:	1 
Size:	89.8 KB 
ID:	201333
      My ComputersSystem Spec

  7.    29 Aug 2018 #1337

    Hi Ed @EdTittel quick question:
    It has been stated numerous times, that UAD drivers can be used in new (less than a year) systems. Is it possible to post the Hardware ID of your Realtek chip?

    For instance I have ALC282. Would it be possible to follow your method and install the UAD drivers and then the Store Realtek control? In your Station-Drivers link ALC282 is included but my impression until now, as I follow closely this thread, is that for ALC282, that is not possible.

    Update: I found for my laptop the HP UAD version 6.0.1.8509, which supposedly supports ALC282
    Last edited by ddelo; 29 Aug 2018 at 14:16.
      My ComputerSystem Spec

  8.    29 Aug 2018 #1338

    Dear @ddelo. I'll be darned if I know what RT Audio chip I've got. The hardware ID is HDAUDIO\FUNC_01&VEN_10EC&DEV_0900&SUBSYS_18491151&REV_1000. Let me look it up in the mobo manual ... goes off to check ... says ALC 1150 Codec but doesn't identify chip. Can't identify it so far. Further inspection says, "Yes, the ALC 1150 is the name of the chip." Here's a link to the RealTek product page for that device: Realtek ALC1150.
    Does any of this help?
    --Ed--
      My ComputersSystem Spec

  9.    29 Aug 2018 #1339

    EdTittel said: View Post
    Dear @ddelo. I'll be darned if I know what RT Audio chip I've got. The hardware ID is HDAUDIO\FUNC_01&VEN_10EC&DEV_0900&SUBSYS_18491151&REV_1000. Let me look it up in the mobo manual ... goes off to check ... says ALC 1150 Codec but doesn't identify chip. Can't identify it so far. Further inspection says, "Yes, the ALC 1150 is the name of the chip." Here's a link to the RealTek product page for that device: Realtek ALC1150.
    Does any of this help?
    --Ed--
    To be honest I would have thought that the 3rd part of the Hardware ID should have been the chip (DEV_0900 = ALC900)

    Mine for example is HDAUDIO\FUNC_01&VEN_10EC&DEV_0282&SUBSYS_103C80C1&REV_1000 and the chip is ALC282 (from DEV_0282).

    Anyway strange things happen!

    Thanks a lot Ed and sorry for the trouble I put you in. Without being a Realtek expert, I believe that you have a pretty new chip and that's why you could use the UAD drivers.
    I'll make my weekly full Macrium image on Fri, and I'll try your method with the hp UAD driver I found in Station-Drivers.
    Thanks again!!



    UPDATE: Checking both the Generic 6.0.1.8501 that you used and the 6.0.1.8509 from HP, none contains my Hardware ID HDAUDIO\FUNC_01&VEN_10EC&DEV_0282&SUBSYS_103C80C1.
    Which brings me back to the original statement:


    ddelo said: View Post
    It has been stated numerous times, that UAD drivers can be used in new (less than a year) systems.

    OK, so much for this one!
      My ComputerSystem Spec

  10.    30 Aug 2018 #1340

    MUC have released the UAD for 6.0.1.8519:
    Microsoft Update Catalog
      My ComputerSystem Spec


 

Related Threads
Hello : I have my realtek driver tweaked in windows 7 , I have it set in the registry to have 2 outputs , instead of one - will the new win 10 driver be able to be adjusted ... Thanks
Hello Everyone. I have a Jabra bluetooth speaker (the Solemate Mini). On Windows 8.1 I plug it in to my laptop using the 3.5mm to 3.5mm cable and then, when I watch a movie, it correctly outputs to the speaker and does not use my laptop speakers....
New RealTek HD Audio Driver available in WU. 18634
My ASUS M4N68T-M V2 has a VIA VT1708S onboard audio. The driver I have that worked in Windows 8.1 v10_1200a won't work in 10. Windows doesn't even see the onboard video so it doesn't even look for a driver. It doesn't show up in device manager. In...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 00:11.
Find Us