1.    08 Aug 2016 #1
    Join Date : Aug 2016
    Posts : 1
    Windows

    Office apps stop responding until Print Spooler is restarted


    Hi,
    I have posted this in other forums in an attempt to get to a wide audience so I apologise if you have seen it before and cannot help.

    I have stuck a strange print spooler problem that I would like to get some direction on. I have read the solutions presented but I'm not sure how relevant they are. I am also still gathering info but need some pointers on exactly what would be useful.

    We have 5 computers in an office of various types with windows 7 (home premium) or windows 10, all exhibiting the same symptoms. Approximately 3 weeks ago the all suddenly started having problems with the print spooler. If the computers are restarted they will work for a while and then the office apps (word, excel, access and outlook) will stop responding. The will either not load (normally word) or will stop when selecting the print function. Other spooler-related issues such as viewing the print queues also do not load.

    Stopping the pint spooler immediately fixes the issue, but after the spooler is restarted, the problem will eventually reoccur. Rebooting the computer also fixes the issue temporarily.

    There are several different printer models and types in the environment including a couple of network-connected and also directly-connected USB printers.

    I am told that there have been no new applications nor software loaded nor were any updates applied around the time that the problem first occurred, although Microsoft patches are applied automatically so they may not have noticed one.


    The network in the office is very simple with an Internet (cable) router/switch/wireless access point. Two of the computers are on Ethernet with others being connected via wireless (standard WiFi). There is no file or print server in the environment and all computers print directly to the printers. The only reason for the network connectivity is for Internet access and printing to the network-connected printers.

    The stranger part of this is that if the laptop computers are away from the environment, they normally work correctly and do not exhibit the problem. It is only in the office environment that this occurs. I am tempted to blame one of the printer drivers and so will continue my investigation around this for the moment. However, no new printers have been introduced into the office, and I am told no drivers have been updated or changed.

    I have asked them to create a log of what is happening when the problem occurs, but haven't reviewed this yet.
    Does anybody have any other ideas on where to start on this one?
      My ComputerSystem Spec
  2.    28 Aug 2017 #2
    Join Date : Aug 2017
    Posts : 1
    Win 10 Pro

    Hello, I had a same proplem.
    What did I do:
    1) Delete all printer drivers
    2) Delete all files in C:\Windows\System32\spool\drivers
    There was folder "color' which does not have NT permissions to modify and delete files. I changed folder owner, add permissions and delete it.
    3) Delete dependance of spool service in registry:
    [HKLM\SYSTEM\CurrentControlSet\Services\Spooler\DependOnService]
    There was two dependances, I left only RPCSS.
    Possible all of this does not reqired.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Print Spooler
My update to Windows 10 from Windows 7 went without problems but none of the three printers attached to my computer worked and I have been struggling with the problem over the last two weeks. There is another long thread "Can't connect to Printer"...
Drivers and Hardware
Solved Print spooler chokes when attempting to print certain pdf files
The print spooler chokes on both of my Windows 10 machines when trying to deal with certain pdf files. For instance when I tried to print https://thebasscase.files.wordpress.com/2013/01/so-what.pdf via my browser (Chrome), it printed the first 6...
Drivers and Hardware
"Print Spooler service isn't running"
For some reason, my printer doesn't show up in applications such as Microsoft Word or Libre Office, although I'm sure that it's connected properly to the computer because it still lets me scan documents. When I troubleshoot the printer, I get this...
Drivers and Hardware
Help: Print Spooler won't start after upgrading from windows 7
Dear all, I'm stuck with my print spooler that doesn't want to start. It was working fine before the upgrade. I get the following message when going to the "view services on local computer" Windows could not start the Print Spooler service on...
General Support
Windows 10 Print Spooler stops & Remote Procedure Call Issue
I've had Windows 10 since Monday, I haven't been able to print anything, even making PDF files because the print spooler will not start. Or more accurately, it will start and then when you try to add a printer, it will stop. When I run the printer...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:53.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums