Windows 10: Unknown Device (WsAudioDevice_383S(1)) after Anniversary Update


  1. Posts : 18
    Win10 Tech Preview
       05 Aug 2016 #1

    Unknown Device (WsAudioDevice_383S(1)) after Anniversary Update


    Just completed anniversary update and I find Device Manager shows one "Other Device": "Unknown Device", with Hardware ID of "WsAudioDevice-383(1)". From other research I gather this is connected with Realtek Audio. Update Driver doesn't work!

    Only 2 of my 5.1 speakers appear to be working (by testing in Realtek HD Audio Manager) and I am not hearing other Windows sounds like USB Device Connecting/Deconnecting.

    (Apologies if this is posted elsewhere... I looked but did not find!)

    Any ideas?

    Thanks

    UPDATE: Resolved my audio problems by updating Realtek High Definition Audio drivers through Device Manager. Then got rid of the unknown device by uninstalling it, then re-scanning for hardware changes. It did not re-appear!
    Last edited by greybat; 06 Aug 2016 at 17:33.
      My System SpecsSystem Spec


 

Related Threads
Fresh install of Windows 10 and the last driver I need to sort out is the above. I believe it is my powered USB 3 hub to which I plug in my keyboard and mouse. Technically it is working but I don't like seeing yellow triangles on devices. So...
After installing Windows 10 anniversary update, I get the following error in the device manger: Unknown USB Device (Device Descriptor Request Failed) Tried uninstalling and restarting PC. Reinstalled Windows made from media tool. Nothing fixed...
Unknown device - no idea what it is in Drivers and Hardware
Hi all, i just recently bought a gigabyte brix mini PC for casual use on our living room tv via eBay. Starting the long process of setup but so far one thing is bothering me. Under devices there is an unknown device PCI encryption/decryption...
Hey guys, yesterday I've shut down my PC, telling him to install the update. This morning the PC was on, not responding to any key press, nothing. Pressed reset, and now I'm being greeted with "Reboot and Select proper Boot device or Insert Boot...
It was also unknown in 8.1 here are some pics https://lh3.googleusercontent.com/-4tVSkontibA/VdYbCYhtsAI/AAAAAAAAJng/d90nLGBOlXo/s912-Ic42/P8202614_1.JPG I tried looking up this device, but found nothing to help me....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:08.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums