touchpad stopped working after 1607 update

  1. Posts : 27
    Windows 10 Pro 64-bit

    touchpad stopped working after 1607 update

    I have an Acer Aspire ES1-711-P14W, When I initially reinstalled my touchpad wasn't working so I installed these drivers from Acer it worked fine until I updated to Version 1607 Build 14393.10:
    • Chipset Intel Chipset Driver
    • IO Drivers Intel Serial IO Driver 604.10135.1001.53001
    • MBI Intel Sideband Fabric Device Driver 1.70.305.16316
    • TXE Intel Intel TXE Driver
    • TouchPad ELANTECH Touchpad Driver
    Last edited by AvidSurvivalist; 05 Aug 2016 at 16:06.
      My Computer

  2. Posts : 27
    Windows 10 Pro 64-bit
    Thread Starter

    Touchpad is unresponsive as well as Acer support! HELP!!
      My Computer

  3. Posts : 27
    Windows 10 Pro 64-bit
    Thread Starter

    Acer is blaming my edition of Windows for my touchpad not working! They told me they can't help me because I have Windows 10 Pro instead of Home, I have no idea how I even got Pro!
      My Computer

  4. Posts : 7,829
    Windows 11 Pro 64 bit

    Try reinstalling the last Acer Windows 10 Touchpad driver for your PC?
      My Computers

  5. Posts : 27
    Windows 10 Pro 64-bit
    Thread Starter

    I installed it and it says I'm ready to go and that's pretty much it. Nothing in the device manager at all. In the UEFI there is a setting to set it from Advanced to Basic operation, I did that and it made it work but I don't have gestures or scrolling.
      My Computer

  6. Posts : 7

    Same occurs with my Asus Zenbook. I'll roll back to ~3 days ago, and the issue goes away, but with automatic updates on windows 10, it doesn't take long for it to come back. I'd rather not block all updates.

    I tried to reinstall the driver, but it doesn't help.

    Also, oddly, the multitouch will stop working when windows downloads the files. I would think it would not occur until the required restart.

      My Computer

  7. Posts : 7

    Update: I reinstalled the ATK Package and that seemed to fix my issue. This is a hotkey/trackpad associated program apparently.

    Problem: Asus zenbook (UX303L) trackpad lost multitouch capabilities with an automatic windows update.

    Solution: Delete ATK Package from add/remove programs, restart, install new ATK Package (2016/10/17), restart, ?, profit.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:26.
Find Us

Windows 10 Forums